Pregunta sobre evolve de Wordpress:

Acceso directo de Woocommerce + página de producto

Un usuario preguntó 👇

Ho. Ya quería comprar otro tema, pero como solo está disponible el tema evolutivo, muchas cosas han mejorado positivamente. ¡Quiero darle otra oportunidad a un tema evolutivo (versión premium)! Desafortunadamente, tengo dos problemas con woocommerce que no puedo resolver por mí mismo, tal vez alguien pueda ayudarme o darme una pista.

1. Si inserto accesos directos en una página de woocommerce, ya no puedo abrir esta página, muestro una página en blanco. Necesito eliminar el acceso directo en la base de datos, luego puedo abrir la página nuevamente. ¿Qué podría ser la causa?

2. un problema aún mayor e importante. Estoy usando symbiostock (vendo fotos con licencias) en la página del producto, las variables no se me muestran. Están en el código fuente, pero con «display: none», ¿cómo se mostrarán?

Para un breve ejemplo, necesitamos el «ss … ..» que se muestra en la página del producto.

<div class="single_variation_wrap">
<div class="woocommerce-variation single_variation" style="">
<div class="woocommerce-variation-description"></div>
<div class="woocommerce-variation-price"><span class="price" style="display: none;"><span class="woocommerce-Price-amount amount">10,70&nbsp;</div>
<div class="woocommerce-variation-availability"></div>
</div><div class="woocommerce-variation-add-to-cart variations_button woocommerce-variation-add-to-cart-enabled">
	<script>
jQuery(document).ready(function($) {
    $(document).on("change", "select#pa_license", function() {
		$('[id^="ss_div_"]').hide();
		$("#ss_div_" + $( "select#pa_license" ).val()).fadeToggle('slow');
    });

    $(document).on("click", ".reset_variations", function() {
		$('[id^="ss_div_"]').hide();
    });
});
</script>
<div id="ss_div_einfachjpeg" style="display:none;">
		<div class="sse_licencing_info">
			<span class="ss_product_license_title">Lizenz</span>
			<span><a href="http://" target="_blank">Use</a></span>		
		</div>
		<div class="sse_licencing_info">
			<span class="ss_product_resolution_title">Size:</span>
			<span>400x218</span>
		</div>
</div>
<div id="ss_div_standardjpeg" style="display:none;">
		<div class="sse_licencing_info">
			<span class="ss_product_license_title">Lizenz</span>
			<span><a href="http://" target="_blank">Use</a></span>		
		</div>
		<div class="sse_licencing_info">
			<span class="ss_product_resolution_title">Size</span>
			<span>800x436</span>
		</div>
</div>
<div id="ss_div_erweitertjpeg" style="display:none;">
		<div class="sse_licencing_info">
			<span class="ss_product_license_title">Lizenz</span>
			<span><a href="" target="_blank">Use</a></span>		
		</div>
		<div class="sse_licencing_info">
			<span class="ss_product_resolution_title">Size</span>
			<span>4847x2642</span>

¡Gracias! cristiano

(@ romik84)

Hace 1 año, 11 meses

Hola @christiantp,

1. ¿Qué atajos ingresas? que codigo exactamente?

2. Proporcione una URL a la página con la pregunta.

gracias

(@christiantp)

Hace 1 año, 11 meses

Este atajo [product_categories number="" parent=""] Es el único que puedo instalar sin problemas. Este es un ejemplo [products limit="" columns="" category=""] no funciona, después de guardar la página en admin no puedo volver a abrir la página para editarla, pero si elimino antes del acceso directo en la base de datos, puedo abrir el editor. ¡Frontend funciona!

El sitio web no está en línea (accesible al público)

(@ romik84)

Hace 1 año, 11 meses

has probado esto con otro tema? ¿Simplemente sucedió con un tema evolutivo?

(@christiantp)

Hace 1 año, 11 meses

¡Sí, pero con el tema evolutivo!

(@christiantp)

Hace 1 año, 11 meses

Bien, probé algunas correcciones, siguiendo la información:

Para las variables del punto 2. Con otros temas, todo funciona, y no evolución-más (y evolución-más-niño), sino….

… si no activo evolution-plus en el administrador, solo obtenga una vista previa, ¡entonces las variables funcionan!

Espero que esto ayude a encontrar el error. Esto también puede resolver el problema con los atajos de Woocommerce.

Esta respuesta fue modificada hace 1 año, 11 meses por.

(@ romik84)

Hace 1 año, 11 meses

1. Encontré el error debajo de la página en blanco, se solucionará en la próxima versión del tema. Gracias

2. sobre esto quiero ver un ejemplo en vivo de lo que quieres decir

Esta respuesta fue modificada hace 1 año, 11 meses por.

(@christiantp)

Hace 1 año, 11 meses

¡Mil gracias! Quiero poner mi sitio web en línea la próxima semana. Luego publicaré el enlace.

(@christiantp)

Hace 1 año, 11 meses

Hola Romik, mi sitio web aún no está terminado, pero está en línea. Aquí está el enlace a un producto: https://travelpois.de/artikel/leerer-strand-mit-weissen-sand-und-gruenen-pflanzen/

Si selecciona una licencia, el tipo y formato de la licencia deberían aparecer encima del botón.

<div class="woocommerce-variation-add-to-cart variations_button woocommerce-variation-add-to-cart-enabled">

<div id="ss_div_einfachjpeg" style="display:none;">
		<div class="sse_licencing_info">
			<span class="ss_product_license_title">Lizenzart:&nbsp;</span>
			<span><a href="https://travelpois.de/licensing/#einfachjpeg" target="_blank">Einmalige Nutzung</a></span>		
		</div>
		<div class="sse_licencing_info">
			<span class="ss_product_resolution_title">Format:&nbsp;</span>
			<span>500x281</span>

He probado todo, cambio de diseño, desactivo plugins, etc. Espero que puedas ayudarme o darme una pista.

Por la página en blanco. ¿Cuándo se espera que se publique la actualización?

(@ romik84)

Hace 1 año, 11 meses

en la consola es probable que vea un error de jQuery. Intente moverlo al área del encabezado si ayuda https://wordpress.org/support/topic/update-version-4-0-3-placing-jquery-in-footer/#post- 11125027

(@christiantp)

Hace 1 año, 11 meses

Está funcionando ahora, muchas gracias !!!

(@ romik84)

Hace 1 año, 11 meses

gracias por la info 😉

(@christiantp)

Hace 1 año, 11 meses

Con la nueva versión del tema evolution plus (2.9.4) también se solucionó el primer punto, ¡gracias de nuevo!

Debido a algunos errores, quería cambiar el tema con frecuencia, valió la pena esperar. ¡Buen trabajo hasta ahora!

(@ romik84)

Hace 1 año, 11 meses

gracias 😉

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *