Pregunta sobre Collapsing Pages de Wordpress:

Advertencia: call_user_func_array () [function.call-user-func-array]: Primer argumento

Un usuario preguntó 👇

Advertencia: call_user_func_array () [function.call-user-func-array]: Se espera que el primer argumento sea una recuperación válida ”, dado en /home1/larryb44/public_html/wp-includes/class-wp-hook.php online 298 …… aparece en la portada de http://www.ussfranklindroosevelt.com ¡POR FAVOR AYUDA!

(@ cy_borg5)

Hace 3 años, 6 meses

Tengo el mismo problema en dos de mis blogs. Veo que este mensaje no ha sido respondido en tres meses. ¿Este plugin todavía es compatible o no?

(@antoiiine)

Hace 3 años, 5 meses

De la actualización a la 4.7 tengo el mismo problema. ¿Sería genial saber si este plugin todavía es compatible o no?

(@gerryhickman)

Hace 3 años, 2 meses

Esta advertencia de PHP puede estar relacionada con un cambio en el núcleo de WordPress 4.7.x que pertenece a una nueva clase ‘wp-include / class-wp-hook.php’. Como advertencia, normalmente no lo verá en el navegador a menos que haya habilitado WP_DEBUG o le haya dicho a PHP que muestre errores.

Este es un arreglo posible, es solo experimental, pero solo hay una línea, por lo que es fácil regresar.

haga una copia de seguridad, luego edite collapsPage.php, cambie esta línea cerca de la parte superior (tenga cuidado con el ajuste de palabras, este código tiene solo dos líneas)

//add_action('wp_head', wp_enqueue_script('jquery'));
add_action('wp_enqueue_scripts', function(){wp_enqueue_script('jquery');});

recarga la página para probar. En mi sistema, la advertencia desapareció después de este cambio y JavaScript aún puede expandirse y colapsarse.

Esta respuesta fue modificada hace 3 años, 2 meses por.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *