Pregunta sobre Authorizer de Wordpress:

Advertencia de PHP: ldap_search

Un usuario pregunt贸 馃憞

Hola,

Estoy usando Author 2.9.7 con WP 5.2.2 (ejecut谩ndose en modo multiling眉e) y PHP 7.2.21.

Veo esto en mis registros de errores:

PHP Warning: ldap_get_entries() expects parameter 2 to be resource, boolean given in /path_to_wordpress/wp/wp-content/plugins/authorizer/src/authorizer/class-authentication.php on line 641

Todo lo que tienes que hacer鈥

(@figureone)

Hace 1 a帽o, 2 meses

Esto indica un problema con ldap_search() buscando autenticaci贸n de usuario. Si desea investigarlo m谩s a fondo, coloque esta l铆nea justo encima de la l铆nea a la que se hace referencia en el registro de errores (autenticaci贸n de clase: 641):

if ( ! $ldap_search ) { error_log( ldap_error( $ldap ) ); }
https://github.com/uhm-coe/authorizer/blob/master/src/authorizer/class-authentication.php#L641

Luego, verifique sus registros de errores para el error espec铆fico.

(@figureone)

Hace 1 a帽o, 2 meses

驴Puede verificar que el LDAP Directory User Password 驴Es correcto el campo en Configuraci贸n de autor? Otro usuario declar贸 que no era v谩lido en una actualizaci贸n reciente del sistema. https://wordpress.org/support/topic/ldap-not-authenticate-after-update-to-php-7-3-9/

(@vickita)

Hace 1 a帽o, 2 meses

Interesante.

Creo que la contrase帽a probablemente est茅 bien, en la medida en que la autenticaci贸n se realice correctamente, pero investigar茅 la b煤squeda cuando regrese a la oficina, despu茅s de las vacaciones.

隆Gracias por la informaci贸n!

(@pkarjala)

Hace 1 a帽o, 1 mes

Hola @vickita haciendo un chequeo r谩pido para ver si todav铆a necesitas ayuda con este problema. 隆Haznos saber!

(@vickita)

Hace 1 a帽o, 1 mes

Hola @pkarjala, 隆el horario lo es todo! S铆, hoy vuelvo a esta pregunta. Ahora veo dos mensajes de error, el del anterior:

PHP Warning: ldap_get_entries() expects parameter 2 to be resource, boolean given in /path_to_wordpress/wp-content/plugins/authorizer/src/authorizer/class-authentication.php on line 641

y 茅ste:

PHP Warning: ldap_search(): Search: Operations error in /path_to_wordpress/wp-content/plugins/authorizer/src/authorizer/class-authentication.php on line 639

Agregu茅 la l铆nea que me diste arriba y obtengo esto:

AH02261: Re-negotiation handshake failed

lo cual tiene sentido para m铆, porque siento que estoy ingresando, pero el sistema no est谩 obteniendo la respuesta esperada. Y as铆 queda ah铆.

Estoy buscando contratar a un consultor de recursos humanos y voy a informar a la gente local relevante nuevamente sobre esto, por lo que cualquier aportaci贸n que tenga ser铆a excelente.

(@pkarjala)

Hace 1 a帽o, 1 mes

Hola @vickita creo que en este caso lo mejor ser铆a ver qu茅 se est谩 poniendo en el ldap_get_entries valor de $ldap_search en el lugar ya mencionado.

驴Puedes contribuir?

error_log(print_r( $ldap_search, true ));

justo antes de la l铆nea 641 pm https://github.com/uhm-coe/authorizer/blob/master/src/authorizer/class-authentication.php#L641 ?

Luego verifique los registros de errores en el servidor web de WordPress y h谩ganos saber cu谩les son los resultados.

Esta respuesta fue modificada hace 1 a帽o, 1 mes por.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *