Pregunta sobre MailPoet - emails and newsletters in WordPress de Wordpress:

Advertencia: inicio de sesi贸n

Un usuario pregunt贸 馃憞

Se encontr贸 un problema al actualizar y revertirlo a 3.33.0.

El mensaje de error es el siguiente.

Advertencia: session_start (): open (/ var / cpanel / php / session / ea3 / sess_caa107f4e97772d211b42919839a090a, O_RDWR) fall贸: dicho archivo o directorio (2) no se encontraba en / home / site / public_html / wp-content / plugins / mailpoet / lib /Config/Session.php en l铆nea 10

Advertencia: session_start (): no se pudieron leer los datos de la sesi贸n: archivos (ruta: / var / cpanel / php / session / ea3) en /home/site/public_html/wp-content/plugins/mailpoet/lib/Config/Session.php en l铆nea 10

(@wysija)

Hace 1 a帽o, 5 meses

Hola @ajamm,

驴Ve si recibe las mismas advertencias que en 3.34.4?

隆Gracias!

(@ajamm)

Hace 1 a帽o, 5 meses

Misma pregunta lo siento. Curiosamente, al actualizar el plugin, se activ贸 solo (estaba deshabilitado antes de que lo actualizara). Comportamiento extra帽o.

(@oaz)

Hace 1 a帽o, 5 meses

Tengo exactamente la misma Advertencia. Gracias por tu ayuda

(@mathiaskahn)

Hace 1 a帽o, 5 meses

El mismo problema aqu铆 El plugin mailpoet tuvo que ser deshabilitado para eliminar la advertencia que apareci贸 en la parte superior de cada p谩gina del sitio …

(@wysija)

Hace 1 a帽o, 5 meses

Hola a todos,

Esto est谩 afectando actualmente a una peque帽a cantidad de instalaciones y nuestros desarrolladores lo est谩n investigando.

Est谩 directamente relacionado con las sesiones de PHP y c贸mo se manejan las sesiones en el lado del servidor.

Le avisaremos cuando tengamos m谩s informaci贸n.

隆Gracias!

(@mathiaskahn)

Hace 1 a帽o, 4 meses

驴Alguna novedad sobre este asunto? Gracias.

(@ajamm)

Hace 1 a帽o, 4 meses

Mis servidores intentaron cambiar la ubicaci贸n de los archivos de sesi贸n, pero eso no supuso ninguna diferencia. Todav铆a volv铆 a Mailpoet tech 3.33 y logr茅 iniciar sesi贸n en mi sitio, pero no lo arregl茅 (aunque fue justo, creo que, dado que el sitio est谩 en vivo, no hicieron mucho)

(@ajamm)

Hace 1 a帽o, 4 meses

Esto ahora est谩 resuelto en mi caso. El soporte del host del servidor dijo: 鈥淟a ruta de la sesi贸n parec铆a estar configurada incorrectamente. Deber铆a ser / var / cpanel / php / session / ea-php72 鈥

(@ psmits1567)

Hace 1 a帽o, 4 meses

Hola amigos

Tengo el mismo problema en diferentes sitios. En el archivo /www/wp-content/plugins/mailpoet/lib/Config/Session.php no hay un comando final para php 芦?>禄 Despu茅s de agregar esto, parece que el problema ya no est谩 presente . Ya no puedo reproducir el mensaje. Por lo tanto, verificar茅 los registros durante los pr贸ximos d铆as si realmente est谩 resuelto. Acerca de 茅l, Peter

(@oaz)

Hace 1 a帽o, 4 meses

Hola Peter, no lo entiendo, revis茅 otros archivos php y tampoco hay un comando final. donde escribiste esto

(@ psmits1567)

Hace 1 a帽o, 4 meses

Hola Oaz Est谩 en el archivo session.php como se muestra en mi soluci贸n. Tienes raz贸n. Muchos archivos no tienen la declaraci贸n final 芦?>禄 Pero eso parece ser un problema aqu铆. En muchos foros se ve un letrero de que este mensaje de error aparece si hay espacios en blanco despu茅s del comando 芦

(@ psmits1567)

Hace 1 a帽o, 4 meses

Hola oaz

Esto es lo que tengo actualmente en mi session.php

if (! session_id ()) {error_log (‘隆Esa es la identificaci贸n de sesi贸n!’); return session_start (); } else {error_log (print_r ($ session_id)); }}}?>

(@oaz)

Hace 1 a帽o, 4 meses

Muchas gracias por estas explicaciones Peter, ahora lo estoy probando y te dir茅 si me funciona

(@oaz)

Hace 1 a帽o, 4 meses

Bueno, no, no me funciona, todav铆a recibo la misma advertencia cada 5 minutos .. 馃檨

(@oaz)

Hace 1 a帽o, 4 meses

Oh, actualic茅 a 3.35.0 y no m谩s advertencias.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *