Pregunta sobre AMP de Wordpress:

amp-img No establecido alto y ancho

Un usuario preguntó 👇

A partir del 1/23, algunas de mis páginas comenzaron a fallar en la validación debido a la falta de valores de alto y ancho de amp-img. Las imágenes provienen de una red de afiliados. Los tamaños de imagen se especifican en la etiqueta original.

Aquí está el código:
<a href="https://macphun.evyy.net/c/316572/407053/3255?subId1=AUR300x600NOIMGBG"><amp-img src="//a.impactradius-go.com/display-ad/3255-407053" alt="" width="300" height="600" sizes="(min-width: 300px) 300px, 100vw" class="amp-wp-enforced-sizes"></amp-img></a><amp-img height="" width="" src="//macphun.evyy.net/i/316572/407053/3255" sizes="(min-width: 0px) 0px, 100vw" class="amp-wp-enforced-sizes"></amp-img>

¿Cómo puedo hacer que los atenuadores amp-img muestren los atenuadores img regulares?

Gracias por adelantado,

Daniel

Este tema fue modificado hace 3 años, 1 mes por. Lanzador de hilos

(@dbruyteryahoocom)

hace 3 años

Impulsando esto. Recibo más de estos errores con la última actualización y no puedo averiguar cómo especificar la altura y el ancho de amp-img. ¿Alguien más ha experimentado esto o tiene un arreglo?

El error en GSC es: «El atributo ‘ancho’ en la etiqueta ‘amp-img’ se establece en un valor no válido».

Gracias de antemano por cualquier ayuda.

(@westonruter)

hace 3 años

Supongo que el desinfectante está interpretando el ancho / alto 0 como sinónimo de ”o falso, por lo que cree que no se proporcionó ancho / alto. Probablemente se requiera un arreglo enchufable.

(@westonruter)

hace 3 años

Esto se está trabajando: https://github.com/Automattic/amp-wp/pull/979

(@westonruter)

hace 3 años

@dbruyteryahoocom La configuración para esto acaba de entrar en el develop extremidades: https://github.com/Automattic/amp-wp/pull/979

Será parte de la versión 0.7 en algún momento de marzo. Debería haber una versión 0.7-beta2 una o dos semanas más tarde que podrías probar si no quieres probar con código directamente desde GitHub.

(@autocoaching)

Hace 2 años, 7 meses

¿Está realmente resuelto?

También tengo este problema en una fuente visual:https://www.pedroamador.com/como-hacer-videos/amp y la página normal no da ningún error !!!

¡Cualquier comentario es bienvenido!

Todo lo mejor

Pedro Amador

(@autocoaching)

Hace 2 años, 7 meses

En esta página encontrará:

https://www.pedroamador.com/wp-content/uploads/2014/04/story-board-autocoaching-800MU503.jpg ”; alt = ”800 × 503 storyboard autocoaching – ▷ PARA DUMMIES: Cómo hacer videos profesionales en 10 pasadas 📹 (ACTUALIZADO 2018)» width = «» height = «»

¿Por qué son estos «» ???

(@westonruter)

Hace 2 años, 7 meses

@autocoaching Parece que no estás usando este plugin de AMP, sino el otro plugin de «páginas móviles aceleradas para dispositivos móviles». Recomiendo abrir un ticket de foro de soporte con ellos: https://wordpress.org/support/plugin/accelerated-mobile-pages

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *