Pregunta sobre Amazon Product in a Post Plugin de Wordpress:

API de publicidad de productos de Amazon 5.0

Un usuario preguntó 👇

Hola,

¿El plugin es compatible con la API de publicidad de productos 5.0?

PA-API 5.0

Muchísimas gracias.

Este tema fue modificado hace 1 año, 6 meses por.

(@ tuar 2040)

Hace 1 año, 6 meses

Hola Ivan, No, no es compatible con PA-API 5.0.

En este momento, no tenemos planes de actualizar la compatibilidad del plugin debido a la complejidad del proceso de aprobación de API PA. Debido a los cambios implementados por Amazon y las limitaciones recientes en las solicitudes de tarifas, es demasiado difícil que el plugin se pueda usar fácilmente incluso por encima del promedio, y como tal, no admitiremos el plugin ni realizaremos actualizaciones futuras.

Saludos, Don

Esta respuesta fue modificada hace 1 año, 6 meses. Motivo: se inició el hilo de ortografía

(@ calvin13)

Hace 1 año, 6 meses

Gracias por la respuesta.

Muy triste por leer esto 🙁

Tu plugin es genial …

Entonces … ¿alguna actualización de seguridad también?

¡Gracias!

(@ tuar 2040)

Hace 1 año, 5 meses

Hola Ivan, tal vez actualice en los próximos meses para llevar todo a los estándares PHP7 y corregir algunos errores anteriores. Pero no haremos actualizaciones de funciones ni nada más. Tenemos una versión más reciente que nunca se ha lanzado, si está interesado. Estábamos en el proceso de agregar algunas cosas cuando Amazon cambió los requisitos y las limitaciones de la API (lo que provocó que muchas personas perdieran el acceso a la API o realizaran demasiadas solicitudes), por lo que nunca la lanzamos.

Si estás interesado, puedes descargarlo aquí:
https://www.fischercreativemedia.com/current-downloads/amazon-product-in-a-post-plugin4.0.3.9.zip

Gracias por las amables palabras sobre el plugin. Si Amazon alguna vez lo hace un poco más fácil, es posible que regresemos al plugin, pero el tiempo lo dirá.

Creé el plugin hace más de 10 años donde se podía usar una clave API universal y era simple, simplemente conéctelo y desenchúfelo. En los últimos años, el proceso se ha vuelto más complejo hasta los cambios recientes de este año que han dificultado mucho la creación de un plugin consistente y fácil de usar para las personas. Entiendo la necesidad de reforzar la seguridad, pero me decepcionó que Amazon hiciera mucho más difícil el uso de la API (para el usuario medio). Ahora, realmente necesita ser un proveedor avanzado que ya tiene una cuenta de API para usarla de manera efectiva; los usuarios pequeños no tienen ninguna posibilidad real porque el proceso es difícil y la cuenta de API requiere ventas regulares y consistentes. 🙁

Sinceramente, Don

Esta respuesta fue modificada hace 1 año, 5 meses. Causa: ortografía del hilo de arranque

(@ calvin13)

Hace 1 año, 5 meses

¡Muchas gracias por tu trabajo!

Probaré la nueva versión 🙂

Todo lo mejor,

Iván

(@mkarg)

Hace 1 año, 5 meses

En una publicación de Amazon que leí, planean cerrar PA-API 4.0 antes del 31 de octubre de 2019. Por lo tanto, cualquier plugin basado en PA-API 4.0 no funcionará de ninguna manera después de esta fecha. PA-API 5.0 es diferente de PA-API 4.0, solo permite respuestas HTTPS y JSON con una estructura diferente a las antiguas respuestas XML de PA-API 4.0. Solo mira sus documentos https://webservices.amazon.com/paapi5/documentation/

Cambiar la PA-API 4.0 existente a la PA-API 5.0 no es un trabajo simple, cuesta una gran cantidad de recursos para desarrolladores.

(@betterlifereviews)

Hace 1 año, 5 meses

Don,

Lamento escuchar esto. Este plugin funcionó igual de bien para mostrar productos específicos de Amazon. Su propio plugin no funciona bien. No comprendo bien los datos de la API, pero comprendo los requisitos de ventas. Mi plugin dejó de mostrar productos correctamente en los últimos días (betterlifereviews.com). No estoy seguro de qué cambio causó eso; tal vez una actualización de WordPress. Si puede pensar en alguna solución, hágamelo saber. Intenté cargar la próxima actualización en el archivo Zip anterior, pero no funciona.

Gracias,

Sead

(@ tuar 2040)

Hace 1 año, 5 meses

Hola Chad, las actualizaciones de WordPress no deberían afectar al plugin. Lo más probable es que las llamadas a la API se estén enrutando por una razón u otra y coincidió con una actualización (si la hubo).

Puede verificar el deslizamiento mirando el caché del plugin. Si expande uno de los elementos almacenados en caché, verá los datos XML sin procesar, y si está limitado, aparecerá un mensaje que lo afectará. Si se trata de alguna otra pregunta, se mostrará en ese momento.

Una cosa que puede hacer es establecer su tiempo de caché en 72000 o algo mucho más alto que 3600 (por defecto una hora). Además, intente desactivar la opción de caché directa si está activada. Esto obligará al plugin a llamar a la API solo cuando se cargue una página que necesita una actualización para cargar el producto y la caché no estará a tiempo tan rápido. Estos pueden ayudar a reducir los problemas de resbalones.

Si se trata de un problema de limitación, intente borrar uno de los dos cachés limitados y vuelva a cargar la página en el frente. No los limpie todos a la vez o el plugin lo obligará a recuperar todos los productos y puede causar agitación nuevamente si tiene un límite de llamadas muy bajo.

También recuerde, si desea alcanzar su número máximo de llamadas en un segundo, una hora o un día, puede llevar de 1 a 24 horas restablecerlo en Amazon.

Saludos, Don

Esta respuesta fue modificada hace 1 año, 5 meses. Razón: ortografía

(@ jihad-sinnaour)

Hace 1 año, 5 meses

Un buen plugin es genial, pero también la nueva API de Amazon que habla de velocidad de respuesta … etc. Hay una nueva biblioteca de PHP que ayudará a actualizar los plugins de wordpress para la nueva api https://github.com/Jakiboy/apaapi

Esta respuesta fue modificada hace 1 año, 5 meses.

(@ mattmatt88)

Hace 1 año, 3 meses

Demasiado marrón. Necesitas un plugin como el tuyo para continuar. Si es demasiado complicado para un desarrollador de plugins profesional, no veo la manera de continuar con la API de Amazon

Entonces, cualquiera tuvo una idea, cómo obtener información del producto automáticamente después del 11 de febrero, y esa es la fecha en la que finalmente cerraron API 4.0.

(@ tuar 2040)

Hace 1 año, 3 meses

Hola @ mattmatt88: dado que Amazon extendió la fecha límite de la API, planeamos agregar la nueva API al plugin antes de la fecha del 11 de febrero de 2020. Probablemente no agregaremos más funciones, pero intentaremos aumentar todo a la correcta niveles de soporte para API y PHP 7.3+ (y corregir algunos errores).

Este plugin siempre ha sido gratuito y lo mantenemos en nuestra propia función, por lo que solo podemos hacerlo cuando tenemos el tiempo y los recursos para hacerlo.

Saludos, Don

(@ mattmatt88)

Hace 1 año, 3 meses

Eso es genial. No necesito ninguna característica nueva, siempre y cuando los accesos directos del plugin funcionen como nunca antes. ¡Gracias por tu maravilloso trabajo!

(@cecilette)

Hace 1 año, 1 mes

Hola @ tuar 2040,

¡Gracias por tu trabajo en este plugin! ¿Tiene alguna actualización sobre cómo funcionaría el plugin con la nueva API?

Gracias Cecile

(@ mattmatt88)

Hace 1 año, 1 mes

Sí, solo quedan 7 días para que se desactive la antigua API. ¿Actualizará el plugin esta semana?

Gracias por su respuesta rápida

(@ tuar 2040)

Hace 1 año, 1 mes

Hola @ mattmatt88, Amazon movió la fecha límite al 9 de marzo de 2020, por lo que todavía queda algo de tiempo. Nuestro objetivo es actualizar el plugin a finales de febrero.

Sinceramente, Don

(@ mattmatt88)

Hace 1 año, 1 mes

¡Gracias por el rompecabezas! Me alegro de escuchar eso

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *