Pregunta sobre WP Store Locator de Wordpress:

Aún no funciona (mapa no cargado / límite de uso de API)

Un usuario preguntó 👇

Hola,

Estoy construyendo un sitio para un cliente y ahora está en mi servidor de prueba. Puede que no entienda todo lo que se necesita para que funcione el buscador de tiendas, pero este es mi caso.

Tengo claves de API de navegador y servidor. Ahora son para mi propio dominio (no el dominio del cliente).

Envié estos y configuré un sitio de tienda.

Cuando voy a la página con el buscador de tiendas, encuentro un error que dice «Se alcanzó el límite de API». Puedo descartar esa alerta, pero luego, cuando aparece el mapa, otra alerta dice «Esta página no puede cargar Google Maps correctamente».

¿Me falta algo en mi configuración? Gracias.

(@tijmensmit)

Hace 2 años, 4 meses

Vea esta respuesta.

(@milauskas)

Hace 2 años, 4 meses

Hola Tijmen,

Hemos habilitado la facturación, pero sigo recibiendo los mismos errores. Se alcanzó el límite de uso de API, etc. Pasé por el proceso para crear nuevas claves pero no funciona. ¿Me estoy perdiendo de algo?

Tenga en cuenta que recibo la advertencia de dirección IP cuando instalo el plugin por primera vez. Cambié la dirección IP en la cuenta de Google Maps de la IP de mi cuenta de alojamiento a la que se muestra en el mensaje de error y ya no encontré ese error. Sin embargo, no sé por qué sigo recibiendo el error de límite de uso.

(@tijmensmit)

Hace 2 años, 4 meses

El error de borde sigue siendo visible en la página y en la consola del navegador.

Si tiene la facturación habilitada, deberá ponerse en contacto soporte de facturación.

(@milauskas)

Hace 2 años, 3 meses

Hola Tijmen, me comuniqué con el soporte de facturación de Google. Aquí está la respuesta que obtuve:

—– Este es Rob, de Map Platform Support. Al mirar su sitio, veo que la URL que está utilizando para cargar la API de JS es la siguiente:

https://maps.google.com/maps/api/js?

Tenga en cuenta que esta URL tiene dos parámetros principales en los que solo debería tener uno. El problema es la segunda clave que proviene de un proyecto que no parece ser tuyo y no está relacionado con una cuenta de facturación válida. —-

Esta fue mi respuesta: (tenga en cuenta que cometí un error y, sí, es una de las claves que creé)

– Gracias, Rob. Estoy usando un plugin de wordpress llamado WP Store Locator. Voy a crear 2 claves de API de Google, una de las cuales es una «clave de navegador» con restricciones establecidas en mi dominio. La segunda es una «clave de servidor» con restricciones fijas a una dirección IP. Lo que aparece en ese código que me enviaste no parece ser ninguno de los dos que estoy usando (https://maps.google.com/maps/api/js?)

Tengo: clave del navegador: AIzaSyDkB1m_nXuJtxnX9xMR1lawvabLrY4jX14 y clave del servidor: AIzaSyClBp9076AC8hs0gJQk_pThJNJOmfFJT3w

¿Estoy probando esto incorrectamente? ¿Estoy quizás en el área equivocada? Estoy conectado a mi cuenta de Google como LesJardins cuando los creo. Y tenemos la facturación habilitada. Incluso creé NUEVAS claves de API después de habilitar la facturación para asegurarnos de que estuvieran conectadas a la cuenta de facturación. Revisé todos los artículos de apoyo y no veo nada que esté haciendo mal. Si puedes guiarme en la dirección correcta, sería genial. ¡Gracias!

Entonces, ¿podría decirme por qué aparece una clave diferente en la URL de Google Maps a pesar de que ingresé las 2 que creé tal como se muestra en su tutorial? O como escribió Rob, ¿debería tener solo UN parámetro? Traté de seguir tu tutorial exactamente, así que no sé dónde me estoy equivocando. Gracias @

(@tijmensmit)

Hace 2 años, 3 meses

No debe compartir sus claves API aquí a menos que haya configurado un redirector para las claves.

Es probable que ambas teclas aparezcan debido a un conflicto con otro plugin / tema.

¿Puede habilitar el modo de compatibilidad en la página de configuración (sección de herramientas) y todos los demás plugins y deshabilitar su tema actual por segundos y ver si eso lo soluciona?

No sucede que esté utilizando código personalizado en functions.php dentro de una carpeta de tema activa para modificar cualquier cosa relacionada con el buscador de repositorios.

(@milauskas)

Hace 2 años, 3 meses

Sí, sabía que no debería haber compartido las llaves. Puedo ir y borrarlos / cambiarlos. No tengo nada que ver con functions.php (pero lo comprobaré dos veces). Gracias por la respuesta y la información. También comprobaré los plugins y te lo haré saber.

(@milauskas)

Hace 2 años, 3 meses

El método de compatibilidad ya ha sido verificado, así que lo dejé para verificar. Desactivé todos los plugins excepto el buscador de tiendas y sigo teniendo el mismo problema. Se alcanzó el límite de uso de la API.

Déjame preguntarte esto: en las instrucciones para crear una clave de navegador tienes «* .example.com / *», así que primero escribí «* .mydomain.com / *». Pero veo en Google que los ejemplos anteriores están en http o https. Revisé el mío que http: //*.mydomain.com/* ¿Es esto correcto?

Solo quiero eliminar cualquier cosa que pueda estar mal mientras preparo las cosas.

(@tijmensmit)

Hace 2 años, 3 meses

Si usa un subdominio, debe ser * .domain.com / * de lo contrario, use domain.com/*

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *