Pregunta sobre Simple Image Sizes de Wordpress:

Clase no encontrada para actualizaci贸n de errores a la versi贸n 3.2.1

Un usuario pregunt贸 馃憞

Hola,

Trabaj茅 alrededor de este problema, pero quer铆a publicarlo por temor a ayudar a otros. Actualizo los plugins en el entorno de desarrollo, env铆o esos cambios a Git y luego uso esos cambios en el escenario y en los servidores en vivo. Cuando actualic茅 la versi贸n 3.2.1 a mi entorno de desarrollo, no tuve problemas. Sin embargo, cuando envi茅 esa actualizaci贸n de Git a mi servidor de escenario, encontr茅 una clase sin errores y el sitio se volvi贸 inutilizable.

鈥斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺 Se produjo un error de tipo E_ERROR en la l铆nea 42 de /var/www/vhosts/acme.co.uk/httpdocs/ wp-content / archivo de plugins / simple-image-size / simple_image_sizes.php. Mensaje de error: Error no capturado: Clase ‘Rahe Simple_Image_Sizes Main’ encontrada en /var/www/vhosts/acme.co.uk/httpdocs/wp-content/plugins/simple-image-sizes/simple_image_sizes.php:42 – 鈥斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺

TRABAJO: Descubr铆 que la conclusi贸n es actualizar el plugin en el servidor. Supongo que hace algo durante ese proceso que est谩 separado de los archivos actualizados. Una vez que el plugin se actualiz贸 en el servidor, pude enviar mi actualizaci贸n de forma normal y volver b谩sicamente al mismo trabajo.

Ser铆a genial si este problema se pudiera evitar en el futuro para aquellos de nosotros que usamos el control de fuente.

Gracias

Este tema fue modificado hace 1 a帽o, 8 meses por.

(@gmetais)

Hace 1 a帽o, 8 meses

Yo tuve el mismo problema. Algunos nombres de archivos parecen haber cambiado el caso.

Ejemplo:
wp-content/plugins/simple-image-sizes/classes/main.php
ahora
wp-content/plugins/simple-image-sizes/classes/Main.php

Descubr铆, por defecto, que a Git no le importa la situaci贸n. Debe configurar su repositorio para estar al tanto de la situaci贸n:
git config core.ignorecase false

(@ nort99)

Hace 1 a帽o, 8 meses

Gracias gmetais. Ese era el problema. Revis茅 mi servidor y ahora tengo dos versiones de clase, una main.php y una Main.php. Luego, las abejas deben escribirse actualizando el plugin a trav茅s del servidor. Actualizar茅 mi configuraci贸n de git para evitar esto en el futuro.

Esta respuesta fue modificada hace 1 a帽o, 8 meses por.

(@medieskolen)

Hace 1 a帽o, 5 meses

驴Alguien podr铆a explicar c贸mo hacer este cambio (en detalles, por favor)?

(@medieskolen)

Hace 1 a帽o, 5 meses

Mi error

Error E_ERROR en la l铆nea 56 en este archivo /home/k/o/ftp_xxxxxxxxcom/wp-content/plugins/simple-image-sizes/simple_image_sizes.php.

Mensaje de error: Sin comillas Error: Clase ‘SIS_Admin_Main’ encontrada en /home/k/o/ftp_xxxxxxxxcom/wp-content/plugins/simple-image-sizes/simple_image_sizes.php:56 Pista de apilamiento: # 0 / home / k / o / ftp_xxxxxxxxcom / wp-include / class-wp-hook.php (286): init_sis (鈥) # 1 /home/k/o/ftp_xxxxxxxxcom/wp-includes/class-wp-hook.php(310): WP_Hook-> apply_filters (NULL, Array) # 2 /home/k/o/ftp_xxxxxxxxcom/wp-includes/plugin.php(465): WP_Hook-> do_action (Array) # 3 / home / k / o / ftp_xxxxxxxxcom / wp-settings. php (394): do_action (‘plugins_loaded’) # 4 /home/k/o/ftp_xxxxxxxxcom/wp-config.php(97): require_once (‘/ home / k / o / ftp_k鈥’) # 5 / home / k / o / ftp_xxxxxxxxcom / wp-load.php (37): require_once (‘/ home / k / o / ftp_k鈥’) # 6 /home/k/o/ftp_xxxxxxxxcom/wp-admin/admin-ajax.php ( 22): require_once (‘/ home / k / o / ftp_k鈥’) # 7 {main} usado

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *