Pregunta sobre Remote Content Shortcode de Wordpress:

Compatibilidad PHP 7.2

Un usuario pregunt贸 馃憞

驴Es el plugin Remote Content Shortcode compatible con PHP 7.2?

Intent茅 usar el plugin PHP Compatibility Checker de WPEngine, pero no puedo escanear el plugin en el tiempo permitido.

Lo siento, el sitio no est谩 disponible p煤blicamente, pero el comportamiento que veo es que la p谩gina se quedar谩 con el acceso directo hasta que exista el acceso directo. Sin depurar, solo hay un espacio en blanco en la p谩gina, que muestra la depuraci贸n:

Error fatal: Error no recuperado: la clase ‘DOMDocument’ se encuentra en /wp-content/plugins/remote-content-shortcode/inc/phpQuery.php:255 Pista de apilamiento: # 0 / wp-content / plugins / remote-content-shortcode /inc/phpQuery.php(324): DOMDocumentWrapper-> documentCreate (‘UTF-8’) # 1 /wp-content/plugins/remote-content-shortcode/inc/phpQuery.php(244): DOMDocumentWrapper-> loadMarkupHTML ( ‘鈥 ‘) # 2 /wp-content/plugins/remote-content-shortcode/inc/phpQuery.php(191): DOMDocumentWrapper-> loadMarkup (‘ … ‘) # 3 / wp-content / plugins / remote-content-shortcode / inc / phpQuery.php (177): DOMDocumentWrapper-> load (‘鈥 ‘, NULL, NULL) # 4 / wp-content / plugins / remote- content-shortcode / inc / phpQuery.php (4857): DOMDocumentWrapper -> __ subir (‘鈥 ‘, NULL, NULL) # 5 / wp-content / p en / wp-content / plugins / remote-content -shortcode / inc / phpQuery.php en l铆nea 255

(@doublesharp)

Hace 2 a帽os, 1 mes

Parece que no php-xml instalado. Dependiendo de su sistema operativo, puede instalarlo a trav茅s de algo como sudo apt-get install -y php-xml para Ubuntu / Debian o sudo yum install -y php-xml para CentOS / Redhat. Aseg煤rese de reiniciar Apache / php-fpm / etc antes de realizar la prueba.

(@tcmw)

Hace 2 a帽os, 1 mes

隆Gracias! Tengo php-xml instalado ahora.

Cuando ejecuto el Comprobador de compatibilidad de PHP, encuentro algunos errores: ARCHIVO: /wp-content/plugins/remote-content-shortcode/inc/phpQuery.php 鈥斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺 鈥斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺 ENCONTRADOS 2 ERRORES y 3 ADVERTENCIAS QUE AFECTAN A 5 L脥NEAS 鈥斺 鈥斺斺斺斺斺斺斺 鈥斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺 2233 | ADVERTENCIA No se recomienda el nombre de m茅todo 鈥減hpQueryObject :: __ pseudoClassParam鈥; PHP ha reservado todos los nombres de m茅todos con un prefijo doble a continuaci贸n para uso futuro. 2469 | ADVERTENCIA No se recomienda el nombre de m茅todo 鈥減hpQueryObject :: __ loadSuccess鈥; PHP ha reservado todos los nombres de m茅todos con un prefijo doble a continuaci贸n para uso futuro. 4209 | ERROR | La funci贸n split () no se informa en PHP 5.3 y se ha eliminado de PHP 7.0; Utilice preg_split () en su lugar ADVERTENCIA No se recomienda el nombre de m茅todo 鈥減hpQueryObject :: __ dumpTree鈥; PHP ha reservado todos los nombres de m茅todos con un prefijo doble a continuaci贸n para uso futuro. 5639 | ERROR | El uso de ‘ruptura’ fuera de un bucle o estructura de cambio no es v谩lido y requiere un error fatal de PHP 7.0 鈥斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺 鈥斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺斺

驴Sabe si el plugin Remote Content Shortcode es compatible con PHP 7.2?

(@doublesharp)

Hace 2 a帽os, 1 mes

Parece que puede no ser compatible con 7.2 seg煤n su descripci贸n. El archivo phpQuery.php se incluye aqu铆 https://github.com/punkave/phpQuery y no se ha actualizado en 7 a帽os por lo que no es de extra帽ar que est茅 desactualizado.

Si tiene tiempo para parchearlo o puede obtener una biblioteca actualizada, h谩gamelo saber e intentar茅 actualizarlo. De lo contrario, puedo intentar actualizarlo cuando tenga tiempo, pero ahora estoy bastante ocupado con otros trabajos.

隆Gracias!

(@reidverblio)

Hace 2 a帽os

PhpQuery parece mantenerse actualizado aqu铆 ahora https://github.com/slaith/phpQuery

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *