Pregunta sobre Autoptimize de Wordpress:

CSS no cargado en la primera carga del sitio web

Un usuario preguntó 👇

Hola,

Estoy usando el plugin Autoptimize, pero descubro que mi hoja de estilo no se carga en la primera carga del sitio web. Necesito actualizarlo para cargar la SEC.

¿Alguna idea de qué puedo hacer para solucionar este problema?

(@optimizingmatters)

Hace 1 año, 2 meses

Archivo AO 404, ¿tiene caché de página para borrar?

También; Veo que está utilizando «fusionar, minimizar, actualizar», que también tiene el archivo CSS 404 y «Fast Velocity Minify». Más de un plugin para llevar a la optimización de activos puede generar problemas graves, es mucho más seguro ceñirse a uno.

honesto

Lanzador de hilos

(@ 123fotografía)

Hace 1 año, 2 meses

Hola,

gracias por encender el fuego para responder.

Eliminé el plugin Merge, Minify, actualizado hace unas semanas, así que no estoy seguro de por qué todavía muestra que lo estoy usando.

Ahora también he destruido Fast Velocity Minify.

También borré el caché …

¿Ves estos errores ahora?

(@optimizingmatters)

Hace 1 año, 2 meses

después de una actualización completa (para asegurarse de que el navegador no muestre una versión en caché de la página), las referencias a MMR y FVM parecen haber desaparecido y el sitio ahora parece estar cargado correctamente, así que todo está bien ahora 🙂

Lanzador de hilos

(@ 123fotografía)

Hace 1 año, 2 meses

Es raro. Parece que se solucionó cuando lo cargo en Google Chrome, pero en Firefox el CSS aún no se cargó en el primer intento.

(@optimizingmatters)

Hace 1 año, 2 meses

Soy un usuario de FF y funciona para mí, ctrl-f5 (actualización completa) o borrar el caché debe configurarse manualmente.

Lanzador de hilos

(@ 123fotografía)

Hace 1 año, 1 mes

Hola,

Parece que sigo teniendo este problema de CSS sin cargarlo primero en algunos navegadores.

Cuando hago una prueba de velocidad de un sitio web en GTMEtrix, es la pantalla la que carga la página sin cargar el CSS correctamente …

https://gtmetrix.com/reports/www.123photography.co.uk/hFT8NP7h

Es muy extraño …

(@optimizingmatters)

Hace 1 año, 1 mes

Bueno, tienes una edición de almacenamiento en caché de páginas (los puntos HTML ya están almacenados en caché para eliminar CSS automatizado), esta prueba de https://www.123photography.co.uk/?bustthatcache=yesplease bustos de caché de página y sin problemas 404.

Lanzador de hilos

(@ 123fotografía)

Hace 1 año, 1 mes

gracias … ¿entonces quieres decir que el sitio web es bueno? ¿Es solo mi computadora y mi teléfono los que todavía están en el sitio?

(@optimizingmatters)

Hace 1 año, 1 mes

si y no; el problema no es el caché en su navegador / computadora, sino en el nivel del servidor / cadena / plugin, dependiendo de dónde se realiza el almacenamiento en caché de la página.

Lanzador de hilos

(@ 123fotografía)

Hace 1 año, 1 mes

Estoy usando los plugins de caché Autoptimize y WP Super cache más los usos del sitio úsáideann de Cloudflare.

Creo que todo esto es un depósito. ¿Alguna idea de como resolver esto?

(@optimizingmatters)

Hace 1 año, 1 mes

bueno, borre WP Super Cache y Cloudflare tal vez (AO no almacena páginas en caché) + verifique si su host también tiene almacenamiento en caché de páginas que debe borrarse

Lanzador de hilos

(@ 123fotografía)

Hace 1 año, 1 mes

Intenté borrar el caché en WP Super Cache y Cloudflare, pero sigo encontrando que CSS no está cargado en la primera carga …

(@optimizingmatters)

Hace 1 año, 1 mes

prueba con https://www.123photography.co.uk/?bustthatcacheagain=yesplease, si funciona de esa manera, me temo que es un problema de almacenamiento en caché de la página en algún lugar.

(todo funciona para mí, incluso con la cadena de caché)

Lanzador de hilos

(@ 123fotografía)

Hace 1 año, 1 mes

Hola,

sí, me funciona con esa conexión.

Vea si puede recrear el error que recibo:

Recibo el error cuando uso Firefox y cuando hago Historial, borro el historial reciente, vacío el caché, etc.

Luego busco en mi sitio web en google «123 fotografía» y hago clic en el enlace de Google. La primera vez que miro el sitio después de hacerlo, aparece el error.

Cada vez después de ser bueno …

(@optimizingmatters)

Hace 1 año, 1 mes

Puedo reproducirlo fácilmente cargando su sitio en una ventana anónima / privada, en cuyo caso veo un enlace a un archivo CSS automatizado que no existe. Basado en los encabezados de respuesta HTTP (específicamente: x-proxy-cache:hit header) de hecho, hay un almacenamiento en caché de páginas que no es Cloudflare de WP Super Cache, pero que puede estar a nivel de host:

Deberá averiguar dónde está sucediendo el almacenamiento en caché de esta página de proxy y aclarar que esto no es algo que yo (o AO) podamos arreglar: – /

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *