Pregunta sobre Arreglando WordPress de Wordpress:

CSS personalizado no funciona en máquinas con Windows

Un usuario preguntó 👇

Hola,

Hice una pregunta de que el CSS personalizado que agregué no se muestra en ningún navegador en Windows 10, pero que funciona perfectamente en OSX. El CSS principal del tema funciona perfectamente en ambos, pero no muestra el CSS personalizado que agregué.

Agregué los estilos a las siguientes formas sin solución.

1) Plugin CSS personalizado simple 2) Agregar CSS al tema secundario 3) Agregar CSS al tema principal al final de style.css

Cada vez que borro mi caché y reviso el sitio en OSX 10.13.2 y Windows 10 en Edge y Chrome.

Gracias por cualquier ayuda. -Viaje

(@keithdriscoll)

Hace 3 años, 1 mes

¿Qué navegador estás usando en OSX? ¿Puede dar un ejemplo de qué CSS no funciona exactamente?

Lanzador de hilos

(@triplwu)

Hace 3 años, 1 mes

Gracias por la respuesta. En OSX, estoy usando Safari, Chrome y Firefox con CSS que se muestra correctamente. Todos los navegadores en OSX se ven muy bien por lo que puedo decir, Windows no parece estar cargando los estilos que agregué.

Aquí hay una imagen de ejemplo con la escena en OSX Safari y Windows Edge uno al lado del otro.

http://uvello.com/benepaytech/wp-content/uploads/2017/12/css-issue.jpg

Se supone que la barra de navegación está configurada en 850px de ancho y flota a la derecha. Se cree que el texto de la imagen es más grande

Sé que este no es un problema específico de Edge porque se muestra en Chrome y Firefox en Windows 10 para numerosos usuarios. A continuación se muestra un ejemplo del CSS que agregué a la hoja de estilo secundaria sin pantalla.

.bio-paragraph h3 {
  margin:0;
  padding:0;
}

 #site-navigation {
  width: 850px;
  float: right;
  margin-top: 20px;
  position: absolute;
  right: 0;
}

.photo-text {
  font-size: 44px;
  font-weight: 400;
  line-height: 40px;
  color: #000;
}

(@jaycbrf)

Hace 3 años, 1 mes

No estoy seguro de qué es esto:


@media 
(-webkit-min-device-pixel-ratio: 2), 
(min-resolution: 192dpi) { 
   	.logo {
  		content: url(https://uvello.com/benepaytech/wp-content/uploads/2017/12/logo.png);
  		width: 265px;
}

hacerlo, pero si se elimina, soluciona el problema

Lanzador de hilos

(@triplwu)

Hace 3 años, 1 mes

Muy interesante, gracias por hacérmelo saber! Lo elimino y parece funcionar.

Ese fragmento de código se utilizó para colocar un logotipo de retina en pantallas con densidades de píxeles más altas. Me suscribiré al logo de otra forma. ¡Gracias por tu ayuda!

(@keithdriscoll)

Hace 3 años, 1 mes

¡Buena suerte @jaycbrf!

Si tuviera que adivinar, algún código de preprocesador CSS (LESS o SASS) parece pegarse directamente en un archivo CSS 🙂

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *