Pregunta sobre Chatbot with IBM Watson de Wordpress:

Después de actualizar a v0.8.16, la conversación ya no comienza

Un usuario preguntó 👇

Hola,

Después de actualizar a la última versión, el chat ya no inicia el flujo de chat. Pero cuando haga clic en el icono de la papelera, comenzará a fluir.

Tengo el caché deshabilitado y lo he probado en diferentes navegadores. Te envío el registro completo.

Gracias

Lanzador de hilos

(@nicoter)

Hace 1 año, 5 meses

FYI: volví a la versión 0.8.15 y funciona de nuevo.

(@intelahelp)

Hace 1 año, 5 meses

Hola @nicoter. Hemos lanzado la nueva versión del plugin (0.8.18) que tiene la posibilidad de emitirse. Actualice su plugin a la última versión y avísenos si el problema persiste.

(@remyreurling)

Hace 1 año, 4 meses

Todavía tengo el problema anterior con 0.8.18. Se iniciará el mensaje de bienvenida (incluso cuando se cambie a Watson Assistant en IBM Cloud) pero no se pueden enviar mensajes.

A continuación se muestran algunos mensajes de registro:

desde la consola:


Error: "Message could not be sent."
    value https://chatmetwillem.nl/wp-content/plugins/conversation-watson/app.js?ver=0.8.18:1

de WP:

Event 5d9c3431f1770, 2019-10-08 07:01:05

#8: Watson Assistant response error

Service Unavailable - Zero size object

The server is temporarily unable to service your request.  Please try again
later.

Reference #15.d7f31502.1570518065.1030597

No se envían mensajes a IBM porque la pestaña de análisis no los enumera.

Lanzador de hilos

(@nicoter)

Hace 1 año, 4 meses

FYI: No puedo comentar sobre 0.8.18 solucionó el error, ya que todavía estoy en 0.8.15.

(@intelahelp)

Hace 1 año, 4 meses

Muchos clientes de IBM Watson Assistant Plugin informaron en el foro, así como en un correo electrónico, sobre el «Error 500 del servidor interno».

Este error fue causado por el cambio reciente a la API Watson Assistant v2. Este cambio no se describe en la documentación oficial: 1. https://cloud.ibm.com/apidocs/assistant-v2#create-a-session, captura de pantalla; 2. https://cloud.ibm.com/docs/services/assistant?topic=assistant-api-client-get-context, captura de pantalla.

Antes de que se cambiara la API, la estructura del objeto era «contexto» (en la respuesta del Asistente Watson):
{"context": {"skills": {"main skill": {"user_defined": {}}}}}.

Luego se agregó un nuevo objeto «sistema» no documentado y ahora la estructura del objeto «estructura» es:
{"context": {"skills": {"main skill": {"user_defined": {}, "system": {}}}}},
captura de pantalla.

Debido a la diferencia entre la estructura documentada y la actual, el plugin con «Error interno del servidor 500» falla.

Estamos trabajando para solucionarlo.

Esta respuesta fue modificada hace 1 año, 4 meses.

(@intelahelp)

Hace 1 año, 4 meses

Hola @remyreurling. Hemos lanzado la nueva versión del plugin (0.8.19) que tiene la posibilidad de emitirse. Actualice su plugin a la última versión y avísenos si el problema persiste.

Lanzador de hilos

(@nicoter)

Hace 1 año, 4 meses

La versión 0.8.19 está funcionando para mí y también solucionó el error inicial introducido con 0.8.16.

¡Gracias @intelahelp!

(@intelahelp)

Hace 1 año, 4 meses

¡De nada!

(@intelahelp)

Hace 1 año, 4 meses

Hola @remyreurling.

No hemos tenido noticias tuyas recientemente. ¿Todavía tiene alguna pregunta o necesita nuestra ayuda? Con mucho gusto te ayudaremos.

(@remyreurling)

Hace 1 año, 4 meses

Hola @intelahelp,

En su lugar, respondí a tu correo electrónico.

Al igual que con OP, el problema se solucionó con la introducción de 0.8.19. Gracias por la respuesta.

(@intelahelp)

Hace 1 año, 4 meses

@remyreurling. Nos alegra que todo le funcione ahora. Gracias por dejarnos saber.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *