Pregunta sobre Google Pagespeed Insights de Wordpress:

El plugin no se puede instalar ni actualizar

Un usuario pregunt贸 馃憞

Hola,

Tuvimos problemas para instalar y actualizar el plugin en muchos de nuestros sitios a trav茅s de WordPress, ya que recibimos el siguiente mensaje de error: Actualizaci贸n fallida: el archivo no se pudo copiar. google-pagespeed-insight / lib / google-api-php-client / vendor / google / apiclient-services / src / Google / Service / Pagespeedonline / ResultFormattedResultsRuleResultsElementUrlBlocks.php

Esto parece estar sucediendo porque estamos ejecutando los sitios en Windows (s铆, lo s茅, esta es una decisi贸n comercial y est谩 fuera de nuestras manos, solo los desarrolladores), que tiene un l铆mite de ruta de archivo de 260 su personaje.

La ruta es: C: inetpub wwwroot XXXXXXXXXXXXXXXXXXX wp-content upgrade google-pagespeed-insight-XXXXXX google-pagespeed-insight lib google-api-php-client vendor google apiclient -services src Google Service Pagespeedonline ResultFormattedResultsRuleResultsElementUrlBlocks.php encima del borde.

驴Ser铆a posible reestructurar las bibliotecas de proveedores en una versi贸n futura para acortar la ruta y permitir que funcione en Windows?

Actualmente, la 煤nica forma en que podemos actualizar el plugin es descargarlo manualmente y cargarlo en el directorio del plugin, que no es una soluci贸n ideal cuando se administran 75 sitios.

Gracias Jim

(@mattkeys)

Hace 2 a帽os, 1 mes

Hola Jim

La buena noticia es que no utilizar茅 la biblioteca PHP de Google en versiones futuras. Tiene m谩s problemas de los que vale la pena y no se ha actualizado para admitir la 煤ltima versi贸n de las p谩ginas de la API.

No estoy exactamente seguro de cu谩ndo tendr茅 un nuevo dise帽o con la ajetreada temporada navide帽a sobre nosotros, pero es una gran prioridad para m铆.

Matt Keys

(@ wrbm-ops)

Hace 2 a帽os, 1 mes

Hola Matt,

Gracias por la actualizaci贸n, estar茅 deseando probar la nueva versi贸n.

Saludos, Jim

(@mattkeys)

Hace 2 a帽os, 1 mes

Hola @ wrbm-ops,

Beta1 ahora est谩 disponible para probar, esta nueva versi贸n cae de la biblioteca PHP de Google que le estaba brindando ediciones. Puede encontrar instrucciones para descargar aqu铆:

https://wordpress.org/support/topic/v4-0-0-beta-1-needs-testers/

Av铆same si puedes probarlo.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *