Pregunta sobre WooCommerce de Wordpress:

Error crítico en su sitio web después de actualizar WooCommerce

Un usuario preguntó 👇

Error crítico después de actualizar wooCommerce. Cuando está desactivado, el sitio web funciona, pero con woocommerce activo hay un error fatal.

Plantillas de temas actualizadas.

https://wordpressplugs.com/shop/

(@dynamiczach)

Ingeniero Automático de Felicidad

Hace 6 meses, 1 semana

¡Hola!

¿Tiene alguna información específica sobre el error que cometió? Quizás estaba incluido en el correo electrónico, o podrías buscarlo WooCommerce > Status > Logs compruebe si hay registros de «errores graves».

Supongo que la actualización es inconsistente con uno de sus otros plugins instalados, ya que hemos visto algunos informes de plugins de terceros que causan problemas después de la actualización.

(@ sitio web-rob)

Hace 6 meses, 1 semana

Obtenga el mismo error con WP 5.5 y WooCommerce 4.4.0.

[18-Aug-2020 18:44:42 UTC] Error fatal de PHP: Automattic WooCommerce Internal DependencyManagement ExtendedContainer :: Confirmation ($ id, new bool $ = false) debe ser compatible con League Container Container :: get ($ alias, edit $ args = Array) en / wp-content / plugins / woocommerce / src / Internal / DependencyManagement / ExtendedContainer.php en línea 18

Esto también se observó en los resultados de la descarga:

No se pudo verificar la autenticidad de woocommerce.4.4.0.zip porque no se encontró ninguna firma.

(@maskedmayhemuk)

Hace 6 meses, 1 semana

lo mismo aquí Error fatal no se puede iniciar sesión en el panel del sitio web

Error fatal: Error no detectado: Llame a la función no especificada wc_get_loop_prop () en /home/bg4ghub1/public_html/wp-content/plugins/woocommerce/includes/class-wc-query.php:376 Pista de apilamiento: # 0 / home / bg4ghub1 / public_html / wp-content / plugins / woocommerce / include / class-wc-query.php (363): WC_Query-> adjust_total_pages () # 1 /home/bg4ghub1/public_html/wp-includes/class-wp-hook.php (289 ): WC_Query-> handle_get_posts (Array) # 2 /home/bg4ghub1/public_html/wp-includes/plugin.php(249): WP_Hook-> apply_filters (Array, Array) # 3 / home / bg4ghub1 / public_html / wp- includes / class-wp-query.php (3190): apply_filters_ref_array (‘the_posts’, Array) # 4 /home/bg4ghub1/public_html/wp-includes/class-wp-query.php(3448): WP_Query-> get_posts () # 5 /home/bg4ghub1/public_html/wp-includes/class-wp-query.php(3559): WP_Query-> query (Array) # 6 / home / bg4ghub1 / public_html / wp-content / theme / gau / lib / framework / extensions / metaboxes / extension_metaboxes.php (680): WP_Que ry -> __ build (Array) # 7 / home / bg4ghub1 / public_html / wp-content / theme / gau / li b / framework / extensions / metaboxes / exte in / home / bg4ghub1 / public_html / wp-content / plugins / woocommerce /includes/class-wc-query.php en línea 376

(@aimaatigari)

Hace 6 meses, 1 semana

El mismo error aquí, ¿qué está pasando? Tuve que desactivar completamente el plugin woocommerce

Seguimiento de pila: wp-content / plugins / woocommerce / include / class-wc-query.php (363): WC_Query-> setting_total_pages () /wp-includes/class-wp-hook.php(289): WC_Query-> handle_get_posts (Editar) # 2 /wp-includes/plugin.php(249): WP_Hook-> apply_filters (Array, Array) # 3 /wp-includes/class-wp-query.php(3190): apply_filters_ref_array (‘the_posts’, Editar) # 4 /wp-includes/class-wp-query.php(3448): WP_Query-> get_posts () # 5 //wp-includes/query.php(98): WP_Query-> Query (Editar) # 6 /wp-content/plugins/notificationx/extensions/form/class-cf7.php(94): query_post en /home1/circlej4/public_html//plugins/woocommerce/includes/class-wc-query.php en línea 376

(@aimaatigari)

Hace 6 meses, 1 semana

Acabo de volver a 4.3.3. Funciona. Solución temporal

Esta respuesta fue modificada hace 6 meses, hace una semana por.

(@ goran468)

Hace 6 meses, 1 semana

Hola.

Cubrimos el problema con varios temas. Después de actualizar a WooCommerce 4.4.0, aparece el error:

Error fatal: Error no reconocido: Llame a la función no especificada wc_get_loop_prop () en wp-content plugins woocommerce includes class-wc-query.php en línea 376

(@humanitymedia)

Hace 6 meses, 1 semana

Pude volver a poner en funcionamiento el sitio desactivando el plugin del administrador de estado de pedidos de Woocommerce (algo que realmente necesitamos para que nuestro sitio funcione correctamente). Pero vemos el mismo error tan pronto como intentamos reactivar ese plugin.

(@dynamiczach)

Ingeniero Automático de Felicidad

Hace 6 meses, 1 semana

¡Hola!

Si usa el plugin WP Rocket, actualice el plugin WP Rocket a la versión 3.6.4.

Si no está utilizando el plugin WP Rocket, este tipo de conflicto generalmente se debe a un conflicto con su tema u otro plugin. La mejor forma de determinar esto es:

Cambia temporalmente tu tema a Frente de la tienda

Deshabilite todos los plugins excepto WooCommerce Repita la acción que causa el problema

Si no ve el mismo problema después de completar la prueba de conflicto, entonces sabe que el problema fue con los plugins y / o el tema que desactivó. Para averiguar qué plugin está causando el problema, reactive sus otros plugins uno por uno, probando después de cada uno, hasta que encuentre el que está causando el conflicto. Puede encontrar una explicación más detallada de cómo realizar una prueba de conflicto aquí.

O puede volver a la versión anterior 4.3.3 de WooCommerce y eso resolverá el problema (como @aimaatigari mencionó anteriormente). Más sobre eso aquí: https://github.com/woocommerce/woocommerce/issues/27389

(@josephcondon)

Hace 6 meses, 1 semana

@dynamiczach Para que lo sepas, @humanitymedia tiene razón. Este problema es causado por el Administrador de estado de pedidos. Este artículo está disponible en la tienda woocommerce y está desarrollado por Sky Verge. También necesito este plugin para que los comandos de mi sitio funcionen correctamente.

Tuve que revisar todos los plugins manualmente y ese es el único que causa problemas después de una nueva versión de woocommerce.

¿Cómo solucionamos esto lo antes posible?

(@dynamiczach)

Ingeniero Automático de Felicidad

Hace 6 meses, 1 semana

@humanitymedia y @josephcondon: Si el Order Status Manager plugin instalado y activado en su sitio, le recomiendo que se ponga en contacto con nosotros en WooCommerce.com> Mi cuenta> Entradas a través de la cuenta que compró la extensión.

SkyVerge podrá ayudarlo aún más después de abrir un boleto. Agregue un enlace a este hilo del foro para que SkyVerge pueda realizar un seguimiento de esta conversación.

(@humanitymedia)

Hace 6 meses, 1 semana

Gracias @dynamiczach y @josephcondon … Busqué soporte para Woocommerce. Informaré cuando tenga noticias de ellos.

(@josephcondon)

Hace 6 meses, 1 semana

@humanitymedia gracias! Me parece extraño ver qué causó este problema con ese plugin en particular. Espero que reciba una respuesta pronto.

Lanzador de hilos

(@ mohitmahajan077)

Hace 6 meses, 1 semana

Encontré que el sitio funcionaba al eliminar el plugin de notificación del sitio.

Esta respuesta fue modificada hace 6 meses, hace una semana por.

(@dynamiczach)

Ingeniero Automático de Felicidad

Hace 6 meses, 1 semana

Como actualización, deberíamos lanzar una versión de WooCommerce. 4.4.1 en algún momento de hoy debería resolver estos problemas.

Recomendamos encarecidamente que primero pruebe las actualizaciones de un sitio de etapa.

Si actualmente no tiene un escenario, el WP Staging el plugin https://wordpress.org/plugins/wp-staging/ es perfecto para clonar su sitio en vivo para que pueda configurar un sitio de escenario y probar problemas sin afectar su sitio en vivo de ninguna manera.

Si necesita ayuda para configurarlo, puede encontrar la documentación paso a paso aquí: https://wordpress.org/plugins/wp-staging/#description en «¿CÓMO ESTABLECER Y CONFIGURAR?»

Aquí hay una captura de pantalla que muestra el proceso de instalación después de la instalación: https://cld.wthms.co/HC1pdz

Cuando el sitio del escenario esté listo para funcionar, verá azul Open staging site botón como este: https://cld.wthms.co/77o0FX

Haga clic en eso e inicie sesión en el sitio del escenario con las mismas credenciales que usa para iniciar sesión en su sitio web principal.

Luego puede seguir la información aquí para probar conflictos con su tema, plugins y configuraciones:

https://docs.woocommerce.com/document/woocommerce-self-service-guide/#section-4

(@elmalak)

Hace 6 meses, 1 semana

La nueva actualización de Woocommerce 4.4.1 acaba de ser lanzada y la instalé y el problema ahora se solucionó para mí.

Espero que funcione bien para todos los que han estado discutiendo estos temas ahora.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *