Pregunta sobre Force HTTPS (SSL Redirect & Fix Insecure Content) de Wordpress:

Error de an谩lisis: error de sintaxis, inesperado

Un usuario pregunt贸 馃憞

No se puede activar el plugin debido a un error.

Error de an谩lisis: error de sintaxis, inesperado ‘[鈥 in /wp-content/plugins/force-https-littlebizzy/admin-notices-ms.php on line 85

This topic was modified 1 year, 11 months ago by .

(@deltafactory)

1 year, 11 months ago

What version of PHP are you using? That line uses the 鈥渘ew鈥 array notation [] introducido en v5.4. Ejecutar una versi贸n anterior explicar铆a el error.

En otra nota, recomiendo encarecidamente actualizar las versiones de PHP. Hay grandes mejoras de rendimiento, especialmente en v7.0 +.

(@deltafactory)

Hace 1 a帽o, 11 meses

Seguimiento r谩pido:

Si est谩 utilizando una versi贸n m谩s reciente de PHP, es posible que tenga la misma pregunta que se detalla aqu铆: https://wordpress.org/support/topic/php-7-compatibility-229/

En ese caso, no utilice [] pero en cambio el & usado antes de este $ en las l铆neas 85, 86.

(@tneveu)

Hace 1 a帽o, 8 meses

El plugin va al directorio mu-plugins. Si no tiene el directorio mu-plugins, env铆e un FTP a su sitio y cr茅elo en el directorio wp-content. Entonces, la ruta ser铆a / wp-content / mu-plugins / Simplemente cargue toda la carpeta force-https en este directorio.

Debe utilizarse el mu. Dependiendo de su empresa de hosting, probablemente ya lo tenga. Los plugins de Little Bizzy pueden necesitar su script autoloader.php, que se encuentra en el mismo directorio. Es un solo archivo y estaba disponible en git-hub. No estoy seguro de si Little Bizzy lo quit贸.

Muchos plugins solo est谩n disponibles si aloja su sitio en sus servidores. Por lo tanto, probablemente no tengan tiempo para brindar asistencia a los clientes que no son anfitriones. Mi empresa de alojamiento es una porquer铆a de la misma manera que utiliza sus propios plugins patentados.

Utilizo Really Simple SSL que est谩 disponible aqu铆. Instala, activa y selecciona la configuraci贸n adecuada para usted (la configuraci贸n predeterminada deber铆a funcionar perfectamente). Espero que esto ayude.

(@krovedd)

Hace 1 a帽o, 6 meses

El plugin va al directorio mu-plugins. Si no tiene el directorio mu-plugins, env铆e un FTP a su sitio y cr茅elo en el directorio wp-content. Entonces, la ruta ser铆a / wp-content / mu-plugins / Simplemente cargue toda la carpeta force-https en este directorio.

Forzar HTTPS para ir al directorio normal / plugins / … funciona bien.

Vi que este error de PHP es solo de PHP 5.3 y 5.5, deber铆a actualizarse a 7.0 o 7.2

La 煤ltima versi贸n todav铆a existe 1.4.0
https://github.com/littlebizzy/force-https/archive/1.4.0.zip

Debe utilizarse el mu. Dependiendo de su empresa de hosting, probablemente ya lo tenga. Los plugins de Little Bizzy pueden necesitar su script autoloader.php, que va en el mismo directorio. Es un solo archivo y estaba disponible en git-hub. No estoy seguro de si Little Bizzy lo quit贸.

autoloader.php si desea agregar muchos plugins mu solo

A煤n no eliminado: https://github.com/littlebizzy/autoloader

NO UTILICE si desea plugins de WP normales, es decir, solo para agencias (sysadmin) … sin embargo, no es necesario, el 99% de los usuarios no est谩n preocupados

Muchos plugins solo est谩n disponibles si aloja su sitio en sus servidores. Por lo tanto, probablemente no tengan tiempo para brindar asistencia a los clientes que no son anfitriones. Mi empresa de alojamiento es una porquer铆a de la misma manera que utiliza sus propios plugins patentados.

mal de nuevo, todos los plugins de Littlebizzy todav铆a est谩n en GitHub (gratis) como antes

no importa por qu茅 difundes esta informaci贸n falsa …

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *