Pregunta sobre Arreglando WordPress de Wordpress:

Error de cURL 60 al actualizar WordPress

Un usuario preguntó 👇

Hace unos meses que tenía una pregunta que no tenía tiempo para mirarla, pero hoy traté de investigar por qué tengo un problema de cURL al intentar actualizar WordPress o cualquier tema relacionado. Incluso fui tan lejos como para descargar trapos de WordPress.org y agregarlos a mi repositorio de certificados.

Al actualizar a través del navegador, obtendrá cURL 60: El certificado de pares no es un error reconocido.

Cuando abro una ventana de terminal (Centos 7) e intento curvar la URL, es decir, http://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip Se devuelve un mensaje de error del servidor de WordPress, ejecutando NGINX ,, Error 301 Movido permanentemente.

Si vive el mismo recibo pero usa HTTPS en su lugar, se puede acceder al archivo con éxito https://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip

Wget también funcionará.

¿Es esto algo que los administradores de WordPress pueden arreglar? ¿Quizás un sitio en NGINX sin restaurar y redirigir el 301 a HTTPS o actualizar para que todas las URL para actualizaciones sean automáticamente HTTPS en lugar de necesitar http para redirigirlas?

Ahorrará mucho tiempo y permitirá que las herramientas de actualización automática disponibles a través de WordPress y otros funcionen de manera eficiente.

Parece un problema mayor por lo que puedo decir cuando el servidor está detrás de Proxy Server, pero parece que los desarrolladores de WordPress podrían resolverlo.

He visto una gran cantidad de contenido quejándose sobre este problema y debo admitir que no soy un experto o por qué sería necesario iniciar la sesión de actualización usando HTTP cuando el servidor debe ser redirigido a HTTPS.

Gracias

(@pothi)

Hace 1 año, 9 meses

Cuando abro una ventana de terminal (Centos 7) e intento curvar la URL, es decir, http://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip Se devuelve un mensaje de error del servidor de WordPress, ejecutando NGINX ,, Error 301 Movido permanentemente.

¿Qué sucede cuando usa la marca «–location» para un rizo a través de la línea de comando?

¿Su servidor está actualizado? (puedes correr yum update para actualizar todos los paquetes en el servidor).

Lanzador de hilos

(@westofsa)

Hace 1 año, 9 meses

Disculpe la demora. Sí, mi servidor está actualizado. Utilizo WebMin para mantener el servidor actualizado sin problemas. También he experimentado el mismo problema en Windows Server. Ambos servidores están detrás del servidor proxy de red. Si mantengo HTTP de Linux, obtengo un error 301 Move Permanent, pero si utilizo HTTPS en su lugar, eso es lo que impone una actualización de WordPress (por una buena razón), entonces el archivo se descarga.

Si utilizo curl http://downloads.wordpress.org/release/wordpress-5.1.1-partial-0.zip -location obtengo% Total% Received% Xfer Average_Dload Speed_Upload Time_Total Time_Spent Time_Left Current_Speed

100162100162 0 0 1209 0 -: -: – -: -: – -: -: – 1218

(@pothi)

Hace 1 año, 9 meses

Eso es bastante extraño. No hay más idea de por qué ocurre el error («cURL 60: El certificado de pares no es un error reconocido»).

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *