Pregunta sobre Wordfence Security de Wordpress:

Error de PHP de Wordfence para $ HTTP_RAW_POST_DATA?

Un usuario pregunt贸 馃憞

Recibo esto en mi registro de errores de PHP:

PHP obsoleto: $ HTTP_RAW_POST_DATA no se completa autom谩ticamente y se eliminar谩 en una versi贸n futura. Para evitar esta advertencia, establezca ‘always_populate_raw_post_data’ en ‘-1’ en php.ini y use el flujo de entrada php: // en su lugar. en Desconocido en l铆nea 0

Busqu茅 software de ubicaci贸n usando $ HTTP_RAW_POST_DATA y Wordfence aparece una y otra vez.

驴Es esto algo de lo que deber铆as cuidar?

Gracias por cualquier informaci贸n sobre esto.

MTN

(@wfyann)

hace 3 a帽os

Hola @ mountainguy2,

Como puede ver en este hilo que trata el mismo problema que el n煤cleo de WordPress, este no es un problema espec铆fico de Wordfence (aunque configuramos HTTP_RAW_POST_DATA para compatibilidad con versiones anteriores de PHP; los datos est谩n disponibles en versiones de PHP que no admiten lectura) php://input mas de una vez)

Esto solo ocurre cuando se realiza una aplicaci贸n POST en un sitio que no es una aplicaci贸n POST normal.

Para suprimir este advertencia puede seguir las instrucciones del mensaje (establezca 芦always_populate_raw_post_data禄 en 芦-1禄 en php.ini) o actualizar a PHP 7.

(@ mountainguy2)

hace 3 a帽os

Gracias, actualic茅 todos mis sitios a PHP 7, en mi entorno de 芦WordPress no administrado禄. Estaba emocionado por dicho incre铆ble aumento de velocidad que habilita PHP 7, lamentablemente ese no fue el caso. Software de 芦actualizaci贸n禄 t铆pico. MTN

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *