Pregunta sobre Zotpress de Wordpress:

Error fatal de PHP: llamada a la función miembro getAll () de un no objeto

Un usuario preguntó 👇

Utilizo la última versión de WordPress y Zotero. Desde la actualización, no actualiza la biblioteca correctamente.

Error fatal de PHP: llamada de la función miembro no objeto getAll () en /www/virtualhosts/perceptualdynamics.be/html/wp-content/plugins/zotpress/lib/request/request.class.php en línea 146

También obtengo al iniciar el mensaje de error:

Error fatal de PHP: el objeto de tipo WP_Error no se puede usar como una matriz en /www/virtualhosts/perceptualdynamics.be/html/wp-content/plugins/zotpress/lib/admin/admin.browse.php en línea 195

Incluso una desinstalación completa de Zotero y una nueva instalación, sin eliminar la caché o restablecer el plugin, no ayuda.

Alguna idea sobre cómo resolver el problema …

saludos cordiales Marco Maas

(@pdlowner)

Hace 3 años, 3 meses

Hola, este error sigue ocurriendo en mi sitio web después de que borré mi caché. Incluso después de la última actualización.

Antes de borrar el caché, recibí el siguiente mensaje de error nuevo después de instalar la actualización

[18-Aug-2017 08:45:26] Error fatal de PHP: llamada de la función gzdecode () indefinida en /www/virtualhosts/perceptualdynamics.be/html/wp-content/plugins/zotpress/lib/request/request.class.php en línea 94

editar: Estaríamos muy agradecidos por un poco de ayuda ya que incluso ahora, después de restaurar la copia de seguridad, el plugin no quiere funcionar en absoluto …

Esta respuesta fue modificada hace 3 años, 3 meses por.

(@kseaborn)

Hace 3 años, 3 meses

Hmm, parece que no tienes la biblioteca Zlib instalada o activada en PHP, o la versión no tiene esta función. ¡Muy extraño! ¿Se puede modificar PHP? También encontré trabajo potencial … si quieres probarlo, contáctame. http://katieseaborn.com/contact

Esta respuesta fue modificada hace 3 años, 3 meses por.

(@kseaborn)

Hace 3 años, 3 meses

Pruebe 6.2.1 cuando se publique y avíseme si eso soluciona las cosas.

(@jdavidstark)

Hace 3 años, 3 meses

Para mí, la versión 6.2.1 da el siguiente error:

Fatal error: Can't use function return value in write context in /home/jdavidst/public_html/wp-content/plugins/zotpress/zotpress.php on line 355

He eliminado y reinstalado el plugin y obtengo el mismo resultado. Cualquier sugerencia de remedio será bienvenida.

Muchas gracias.

(@kseaborn)

Hace 3 años, 3 meses

Hm, no estoy seguro, pero siento que tengo trabajo a mi alrededor. Ojalá pudiera generar estos errores por mi parte para estar seguro. De todos modos lo resolveremos, ¡lenta pero seguramente! Necesitaré algo de tiempo para armarlo.

(@jdavidstark)

Hace 3 años, 3 meses

Gracias. Parece que si vuelvo a la v.6.1.6, todo vuelve a estar bien (en WP v.4.8.1).

(@pdlowner)

Hace 3 años, 3 meses

perdón por la respuesta tardía, ahora ni siquiera puedo activar el plugin

Error fatal: el valor de retorno de la función no se puede usar en el contexto de escritura en /www/virtualhosts/perceptualdynamics.be/html/wp-content/plugins/zotpress/zotpress.php en línea 355

Primero tuve un error HTTP 500 después de actualizar a 6.2.1. Luego, después de reinstalar el plugin, aparece el error anterior.

(@pdlowner)

Hace 3 años, 3 meses

Instalé 6.1.6, desafortunadamente no ayudé con el error que mostraba al principio. Cuando actualizo a 6.2.1, vuelve a aparecer el error HTTP 500 …

(@pdlowner)

Hace 3 años, 3 meses

acaba de comprobar su aplicación en la biblioteca zlib. En el servidor, la versión 1.2.3 está instalada y habilitada

(@kseaborn)

Hace 3 años, 3 meses

Creo que esta es una pregunta nueva; trabajando en ello. Para el original, consulte aquí (creo que había más sobre cómo se arma php).

(@pdlowner)

Hace 3 años, 3 meses

El problema con la activación en bypass, el código de error 500 también podría.

Código de error 500 (la instalación nueva completa con archivo zip resolvió ese problema)

activando (modificando zotpress.php y eliminando las líneas en él, solo hay un mensaje de advertencia para la actualización :))

mi problema con la base de datos sigue ahí … ¿ayudaría una actualización de php? Podría intentar actualizar Hostadmins a la última versión… 5.3.3 está instalado actualmente.

[28-Aug-2017 08:07:55] Error fatal de PHP: llamada de la función miembro no objeto getAll () en /www/virtualhosts/perceptualdynamics.be/html/wp-content/plugins/zotpress/lib/request/request.class.php en línea 157

es la nueva línea de error.

(@ fabuloso1)

Hace 3 años, 3 meses

Hola Katie, estoy experimentando el mismo problema de errores fatales después de actualizar Zotpress ayer. Lo eliminé e intenté reinstalarlo, pero ahora ni siquiera puedo activarlo.

Error fatal: el valor de retorno de la función no se puede usar en el contexto de escritura en /home2/teambuilding/public_html/wp-content/plugins/zotpress/zotpress.php en línea 355

Esperando una solución. Muchas gracias por este gran plugin.

(@pdlowner)

Hace 3 años, 3 meses

@ terrific1

puedes evitar ese error en este momento

activando (modificando zotpress.php y eliminando las líneas en él, solo hay un mensaje de advertencia para la actualización :))

más que las líneas entre ZOTPRESS 6.2.1 AVISO. eso debería arreglarse por el momento.

(@pdlowner)

Hace 3 años, 3 meses

Jugué con un entorno de prueba, no tengo problemas … podría ser porque la versión anterior de PHP está causando los problemas

(@kseaborn)

Hace 3 años, 3 meses

@pdlowner ¿Puedes contactarme? No estoy seguro de si solucioné alguno de los dos errores y no puedo replicarlo, así que me gustaría enviarte una versión para que la pruebes.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *