Pregunta sobre All-in-One Event Calendar de Wordpress:

Error fatal de PHP: TypeError no detectado

Un usuario pregunt贸 馃憞

No se generan archivos CSS.

PHP Fatal error:  Uncaught TypeError: Argument 1 passed to Ai1ec_Exception_Handler::handle_exception() must be an instance of Exception, instance of Error given in /var/www/html/zll/wp-content/plugins/all-in-one-event-calendar/lib/exception/handler.php:191
Stack trace:
#0 [internal function]: Ai1ec_Exception_Handler->handle_exception(Object(Error))
#1 {main}
  thrown in /var/www/html/zll/wp-content/plugins/all-in-one-event-calendar/lib/exception/handler.php on line 191
Fatal error: Uncaught TypeError: Argument 1 passed to Ai1ec_Exception_Handler::handle_exception() must be an instance of Exception, instance of Error given in /var/www/html/zll/wp-content/plugins/all-in-one-event-calendar/lib/exception/handler.php:191
Stack trace:
#0 [internal function]: Ai1ec_Exception_Handler->handle_exception(Object(Error))
#1 {main}
  thrown in /var/www/html/zll/wp-content/plugins/all-in-one-event-calendar/lib/exception/handler.php on line 191

Este tema fue modificado hace 3 a帽os, 2 meses por.

(@ soleado454)

Hace 3 a帽os, 2 meses

Hola @rztab,

Aseg煤rese de que su instalaci贸n de WordPress y todos nuestros plugins de calendario principales est茅n actualizados, y si no los actualiza en Plugins.

Si el error persiste, si su host est谩 ejecutando PHP versi贸n 7+, puede intentar que su host vuelva a PHP versin 5.6, que parece ser m谩s estable y crea muchos menos problemas.

(@rztab)

Hace 3 a帽os, 2 meses

Hola @ sunny454, la instalaci贸n de cualquier sitio con la misma versi贸n de PHP no presenta ning煤n problema. El problema se produce en una instalaci贸n de varios sitios. Y todos los plugins est谩n actualizados

Esta respuesta fue modificada hace 3 a帽os, 2 meses por.

(@ soleado454)

Hace 3 a帽os, 2 meses

@rztab:

Gracias por la informaci贸n. Hubo un error con las instalaciones de varios sitios, pero se solucion贸 hace algunos problemas. Este problema puede ser el resultado de un plugin o un conflicto de tema (generalmente con un plugin de seguridad o almacenamiento en cach茅). Pruebe un tema diferente temporalmente como Twenty Seventeen, o desactive todos los plugins y luego verifique si el problema vuelve a surgir; luego, reutil铆celos todos hasta que encuentre el que caus贸 el problema. Por favor d茅jeme saber los resultados.

(@sallymoos)

Hace 3 a帽os, 1 mes

Hola,

Estoy cometiendo este mismo error cuando cambio a PHP5.6 desde PHP7.

PHP7 tiene el sitio bien, pero no puedo ingresar a wp-admin porque cuesta 500. Cuando vuelve a PHP5.6, vuelve a funcionar.

No tengo ning煤n plugin de seguridad o almacenamiento en cach茅 en ejecuci贸n. Los plugins 500 todav铆a tienen un error de wp-admin desactivado. 驴Hay alguna raz贸n por la que la 煤ltima versi贸n (2.5.26) no solucione este problema?

(@ soleado454)

Hace 3 a帽os, 1 mes

Hola @sallymoos,

Desafortunadamente, no s茅 por qu茅 esto resuelve el problema. Este es un problema de compatibilidad arbitrario que PHP 7+ ha tenido en algunos sitios web. Pero no hay informaci贸n espec铆fica sobre por qu茅 esta 煤ltima versi贸n (7+) interrumpe el funcionamiento de algunas funciones o resquebraja errores. En su caso, parece estar rompiendo la administraci贸n de su panel de WordPress. Baste decir que es inestable.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *