Pregunta sobre OceanWP de Wordpress:

Fallo de intercambio de imagen de Woocommerce

Un usuario preguntó 👇

En primer lugar, quiero agradecerles mucho por crear este tema original para nosotros, porque ahora este es mi tema favorito de woocmomerce.

Ahora quiero compartir un problema que no pude solucionar yo mismo incluso después de buscar la solución en cualquier lugar posible en Internet, por lo que estoy publicando aquí para obtener el apoyo de una persona experta que podría ayúdame a resolver el problema.

Mi problema es que cuando la función «Intercambio de imágenes» está habilitada para las imágenes del producto woocommerce, la imagen secundaria se estira automáticamente y sale de su posición.

La imagen principal es visible en su tamaño real, pero la imagen secundaria se vuelve más grande y visible en el fondo de la imagen principal de mal aspecto.

Así que intenté usar el CSS sugerido por el autor de OceanWP en https://wordpress.org/support/topic/woocommerce-image-sizes-when-using-more-than-1-picture/ pero no se resuelve la pregunta, pero en la portada y en la página de la tienda el problema sigue siendo el mismo.

CSS es:

.woocommerce ul.products li.product .woo-entry-image-swap img {ancho: automático; } .woocommerce ul.products li.product .woo-entry-image-swap .woo-entry-image-secundaria {izquierda: 50%; transformación: translateX (-50%); }

Así que ahora he eliminado la SEC y estoy buscando ayuda de alguien que sepa cómo resolver el problema.

Estaría muy agradecido si alguien pudiera ayudarme a solucionar el problema lo antes posible.

Gracias y saludos. Wasim

(@apprimit)

Hace 1 año, 7 meses

Hola,

Intente utilizar las imágenes del mismo tamaño para organizarlas. También puede usar el código CSS a continuación y verificar que funcione o no:

.woocommerce ul.products li.product .woo-entry-image-swap .woo-entry-image-secondary {
    height: auto;
}

(@thewasimofficial)

Hace 1 año, 7 meses

Hola, Amit, gracias por tu sugerencia, pero lamentablemente el CSS que proporcionaste no funciona.

Y quiero confirmar que todas las imágenes que subí tienen un tamaño de 800x800px y todavía no he tenido suerte.

(@apprimit)

Hace 1 año, 6 meses

El código funciona bien. ¿Borraste el caché después de agregar el código?

(@thewasimofficial)

Hace 1 año, 6 meses

Hola amit

Después de borrar todo el caché no estaba funcionando pero de repente ahora está funcionando 🙂 Muchas gracias por tu ayuda, eres genial 😀

(@apprimit)

Hace 1 año, 6 meses

¡De nada!

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *