Pregunta sobre Smart Slider 3 de Wordpress:

Haga clic en JavaScript no funciona

Un usuario pregunt贸 馃憞

隆Hola!

En primer lugar, quiero decir que me gusta mucho el plugin. Sigan con el buen trabajo 馃榾

Me encontr茅 con un desaf铆o y espero que puedan ayudarme. Cre茅 botones personalizados para navegar a diferentes diapositivas en mi control deslizante. Por ejemplo, el bot贸n de la segunda diapositiva tiene el siguiente c贸digo:

<div class="app_yes">YES, I ALREADY HAVE THE APP, SO  BRING ME DIRECTLY TO STEP 3.</div>
<script>
N2R('#n2-ss-2', function($, slider){
    jQuery('.app_yes').click(function(){
        slider.slideToID(11);});
});
</script>

Todos los botones tienen un nombre de clase 煤nico y el bot贸n de texto de Smart Slider contiene el c贸digo JavaScript.

Desaf铆o:
A veces necesita m谩s de un clic para realizar la acci贸n (digamos que va a la p谩gina siguiente). Puede ver que esto no es realmente amigable. Por lo tanto, espero que conozca una soluci贸n para solucionar este problema.

Muchas gracias por tu ayuda.

A la espera de saber de ti.

Todo lo mejor,

Patricio

(@laszloszalvak)

hace 1 a帽o

隆Hola Patrick!

El problema parece estar relacionado con el hecho de que solo coloca la clase en el texto, por lo que no activar谩 el c贸digo JavaScript cuando haga clic en las partes del bot贸n que no cubren el texto.

Entonces, lo siguiente es lo que debe hacer en su lugar:

agregue la clase para la Capa de botones en su pesta帽a Configuraci贸n, en el campo 芦Clase CSS禄: https://smartslider3.helpscoutdocs.com/article/392-layer-window-settings#class

en la etiqueta de Capa de bot贸n, solo debe ingresar el texto sin HTML (ya que la clase CSS debe agregarse en el lugar que mencion茅 anteriormente) debe agregar los c贸digos JavaScript en Configuraci贸n de diapositiva> Desarrollador> Devoluci贸n de llamada de JavaScript como puede ver aqu铆: https://smartslider3.helpscoutdocs.com/article/1294-slider-settings-developer#javascript-callbacks

隆Y eso probablemente solucionar谩 el problema!

Todo lo mejor, Laszlo.

(@patrickpelsma)

hace 1 a帽o

Hola Laszlo,

隆Vaya, qu茅 respuesta tan r谩pida! Muchas gracias por tu ayuda. Solo cambi茅 un bot贸n y parece funcionar perfectamente.

隆Otra vez, gracias por tu ayuda!

Tenga un buen d铆a !!

Patricio

Esta respuesta fue modificada hace 1 a帽o por.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *