Pregunta sobre Backup Jetpack - WP Security Speed de Wordpress:

¿Jetpack 7.0 es incompatible con Yoast SEO?

Un usuario preguntó 👇

Tengo Jetpack y Yoast SEO instalados. Los uso para diferentes cosas; Controlo mi configuración de SEO a través de Yoast, pero uso Jetpack para comentarios, suscripciones y otras funciones. Ayer, inicié sesión en WordPress y me pidió que actualizara Jetpack a la versión 7.0. Luego, cuando fui a agregar una nueva publicación, generalmente no tenía todos los metadatos que Yoast me permite personalizar: caracol, fragmento, etc. – ser visto. Usé WP Rollback para devolver Jetpack a la versión 6.9, y en ese momento todas las opciones de Yoast aparecieron nuevamente.

Entonces, ¿la versión más reciente de Jetpack es incompatible con Yoast SEO, por lo que no puedo usar ambas correctamente? Ejecuté «Debug» en Jetpack 7.0 y no se hizo clic en el módulo «SEO» (ni siquiera se podía hacer clic), por lo que parece extraño que esta nueva versión exceda las capacidades de metadatos de Yoast.

¿Alguien más tiene esta pregunta? A medida que Jetpack continúa evolucionando, quiero asegurarme de poder continuar usándolo para suscripciones mientras uso Yoast para la gestión de SEO.

Gracias Jeremy

(@macmanx)

Moderador voluntario

Hace 1 año, 10 meses

No somos conscientes de la incompatibilidad con Yoast SEO, así que verifiqué con Jetpack 7.0 y Yoast SEO 9.5 además de WordPress 5.0.3 y no vi el problema descrito.

¿Quizás un plugin u otra función de tema está creando un conflicto entre los dos? Intente deshabilitar todos los plugins excepto Jetpack y Yoast SEO, y cambie al tema Twenty Nine predeterminado. Si el problema desaparece, permítales identificar el origen del problema uno por uno.

Si puede instalar plugins, marque Install Health. En la pestaña de solución de problemas, puede hacer clic en el botón para deshabilitar todos los plugins y cambiar el tema por usted, mientras aún está conectado, sin molestar a los visitantes normales de su sitio.

(@jeremybeck)

Hace 1 año, 10 meses

Entiendo lo que está diciendo, pero creo que la prueba de que Jetpack está causando el problema es bastante convincente. Nuevamente, el problema solo salió a la luz cuando actualicé a Jetpack 7.0 y, lo que es más importante, desapareció cuando volví a Jetpack 6.9. Así que realmente no veo el sentido de intentar controlar otras variables.

Creo que existe la posibilidad de que a mi TEMA (Astrid) no le guste Jetpack 7.0 por alguna razón. Pero no hay forma de que pueda cambiar mi tema a largo plazo, por lo que solo sería un callejón sin salida.

(@kokkieh)

Hace 1 año, 10 meses

Hola Jeremy,

Creo que la prueba de que Jetpack está causando el problema es bastante convincente. Nuevamente, el problema solo salió a la luz cuando actualicé a Jetpack 7.0 y, lo que es más importante, desapareció cuando volví a Jetpack 6.9.

Todo lo que sugiere es que algo en su sitio puede estar en conflicto con Jetpack 7.0 que no tenía con Jetpack 6.9. Jetpack 7.0 no es una prueba definitiva de que Yoast sea incompatible con Yoast THIS, especialmente porque ambos parecen funcionar perfectamente si solo los plugins se ejecutan en un sitio en nuestra prueba.

Creo que existe la posibilidad de que a mi TEMA (Astrid) no le guste Jetpack 7.0 por alguna razón. Pero no hay forma de que pueda cambiar mi tema a largo plazo, por lo que solo sería un callejón sin salida.

No queremos que cambies tu tema a largo plazo. Pero para tener alguna esperanza de solucionar este problema, necesitamos poder determinar exactamente qué está causando el problema. La razón más probable de este tipo de problema es un conflicto de plugin o tema, por lo que suele ser lo primero que cualquier plugin te pedirá que salgas.

Si usa el plugin Health Check sugerido por @macmanx arriba, puede hacerlo sin comprometer la apariencia de su sitio para los visitantes cuando está ocupado.

(@macmanx)

Moderador voluntario

Hace 1 año, 10 meses

Para ser claros, se trata de descubrir qué está introduciendo el conflicto, para que podamos comenzar a abordar esto, porque hasta ahora no podemos reproducir el conflicto solo con Jetpack 7.0 y Yoast SEO 9.5 en barr WordPress 5.0.3.

(@poltraxx)

Hace 1 año, 5 meses

Tengo Jetpack 7.5.1 que no es compatible con Yoast 5.2.2

Estoy usando PHP 7.2.7

Recibo un mensaje de error de Jetpack

========================================


### wp-core ###

version: 5.2.2
site_language: en_US
user_language: en_US
permalink: /%year%/%monthnum%/%day%/%postname%/
https_status: true
user_registration: 0
default_comment_status: open
multisite: false
user_count: 1
dotorg_communication: true

### wp-paths-sizes ###

wordpress_path: /home4/poltrack/public_html
wordpress_size: 2.02 GB (2164282991 bytes)
uploads_path: /home4/poltrack/public_html/wp-content/uploads
uploads_size: 2.06 GB (2216838568 bytes)
themes_path: /home4/poltrack/public_html/wp-content/themes
themes_size: 4.00 MB (4198518 bytes)
plugins_path: /home4/poltrack/public_html/wp-content/plugins
plugins_size: 67.87 MB (71164463 bytes)
database_size: 32.25 MB (33821252 bytes)
total_size: 4.18 GB (4490305792 bytes)

### wp-active-theme ###

name: PhotoBlogster
version: 5.3
author: lighthouseseo
author_website: https://outstandingthemes.com/
parent_theme: none
theme_features: automatic-feed-links, title-tag, post-thumbnails, menus, html5, custom-background, custom-header, infinite-scroll, custom-logo, widgets
theme_path: /home4/poltrack/public_html/wp-content/themes/photoblogster

### wp-mu-plugins (4) ###

Endurance Browser Cache: version: 0.4, author: Mike Hansen
Endurance Page Cache: version: 1.5, author: Mike Hansen
Endurance PHP Edge: version: 0.2, author: Mike Hansen
SSO: version: 0.2, author: Garth Mortensen, Mike Hansen

### wp-plugins-active (12) ###

Akismet Anti-Spam: version: 4.1.2, author: Automattic
Glue for Yoast SEO & AMP: version: 0.4.3, author: Joost de Valk
Google Analytics for WordPress by MonsterInsights: version: 7.7.1, author: MonsterInsights
Instagram Feed: version: 1.12, author: Smash Balloon
Jetpack by WordPress.com: version: 7.5.1, author: Automattic
MOJO Marketplace: version: 1.4.5, author: Mike Hansen
Photonic Gallery & Lightbox for Flickr, SmugMug, Google Photos, Zenfolio and Instagram: version: 2.27, author: Sayontan Sinha
Redirection: version: 4.3.1, author: John Godley
VaultPress: version: 1.9.10, author: Automattic
WPForms Lite: version: 1.5.3.1, author: WPForms
WPS Hide Login: version: 1.5.2.2, author: WPServeur, NicolasKulka, tabrisrp
Yoast SEO: version: 11.5, author: Team Yoast

### wp-media ###

image_editor: WP_Image_Editor_Imagick
imagick_module_version: 1650
imagemagick_version: ImageMagick 6.7.2-7 2017-03-22 Q16 http://www.imagemagick.org
imagick_limits: 
	imagick::RESOURCETYPE_AREA: 14 GB
	imagick::RESOURCETYPE_DISK: -1
	imagick::RESOURCETYPE_FILE: 12288
	imagick::RESOURCETYPE_MAP: 48 MB
	imagick::RESOURCETYPE_MEMORY: 48 MB
	imagick::RESOURCETYPE_THREAD: not available
gd_version: bundled (2.1.0 compatible)
ghostscript_version: 8.70

### wp-server ###

server_architecture: Linux 3.10.0-862.3.2.4.ELK.el6.x86_64 x86_64
httpd_software: Apache
php_version: 7.0.33 64bit
php_sapi: cgi-fcgi
max_input_variables: 1000
time_limit: 30
memory_limit: 256M
max_input_time: 60
upload_max_size: 256M
php_post_max_size: 260M
curl_version: 7.65.1 OpenSSL/1.0.2s
suhosin: false
imagick_availability: true
htaccess_extra_rules: true

### wp-database ###

extension: mysqli
server_version: 5.6.41-84.1
client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: b5c5906d452ec590732a93b051f3827e02749b83 $

### wp-constants ###

WP_HOME: undefined
WP_SITEURL: undefined
WP_CONTENT_DIR: /home4/poltrack/public_html/wp-content
WP_PLUGIN_DIR: /home4/poltrack/public_html/wp-content/plugins
WP_MAX_MEMORY_LIMIT: 256M
WP_DEBUG: false
WP_DEBUG_DISPLAY: true
WP_DEBUG_LOG: false
SCRIPT_DEBUG: false
WP_CACHE: false
CONCATENATE_SCRIPTS: undefined
COMPRESS_SCRIPTS: undefined
COMPRESS_CSS: undefined
WP_LOCAL_DEV: undefined

### wp-filesystem ###

wordpress: writable
wp-content: writable
uploads: writable
plugins: writable
themes: writable
mu-plugins: writable

### jetpack ###

site_id: 150152441
ssl_cert: No
time_diff: undefined
version_option: 7.5.1:1562119158
old_version: 7.5:1562110443
public: Public
master_user: #1 admin ([email protected])
current_user: #1 admin ([email protected])
tokens_set: Blog User
blog_token: ZD2!oS(2G7k5x)*yFsfy7s17jXSEKb5W
user_token: I&shEGzjzeoZuG4O71LGuipN8rmn5Jiy
version: 7.5.1
jp_plugin_dir: /home4/poltrack/public_html/wp-content/plugins/jetpack/
plan: personal
HTTP_HOST: poltrack.net
SERVER_PORT: 443
HTTPS: on
HTTP_X_FORWARDED_FOR: 66.30.235.104
HTTP_X_REAL_IP: 66.30.235.104
REMOTE_ADDR: 66.30.235.104
protect_header: {"trusted_header":"REMOTE_ADDR","segments":1,"reverse":false}
full_sync: {"started":"Wed, 03 Jul 2019 02:02:43 +0000","queue_finished":"Wed, 03 Jul 2019 02:02:43 +0000","send_started":"Wed, 03 Jul 2019 02:02:49 +0000","finished":"Wed, 03 Jul 2019 02:02:50 +0000","sent":{"constants":1,"functions":1,"options":1,"users":1},"sent_total":{"constants":-1,"functions":-1,"options":-1,"users":1},"queue":{"constants":1,"functions":1,"options":1,"users":1},"config":{"options":true,"functions":true,"constants":true,"users":[1]},"total":{"constants":1,"functions":1,"options":1,"users":1}}
sync_size: undefined
sync_lag: 0 seconds
full_sync_size: undefined
full_sync_lag: 0 seconds
idc_urls: {"home":"https://poltrack.net","siteurl":"https://poltrack.net","WP_HOME":"","WP_SITEURL":""}
idc_error_option: false
idc_optin: true
cxn_tests: {"9":{"name":"test__wpcom_self_test","pass":false,"message":"Jetpack.com detected an error.","resolution":"Visit the Jetpack.com debugging page for more information or contact support.","action":false,"severity":"critical","group":["default"],"type":"direct"}}

(@kokkieh)

Hace 1 año, 5 meses

@poltraxx,

Si tiene un problema con Jetpack y Yoast en su sitio, abra su propio hilo de foro en https://wordpress.org/support/plugin/jetpack/#new-post o abra un ticket de soporte en https://jetpack.com/contact-support/?rel=supporty agregue un vínculo a su sitio y más información sobre lo que simplemente no está funcionando, y podemos ayudarlo a investigar.

No envíe contenido resuelto mensualmente por otros usuarios, especialmente porque el problema OP en este hilo era sobre versiones completamente diferentes de estos dos plugins.

Un mensaje de error no significa que los plugins sean incompatibles, y miles de personas usan Jetpack y Yoast en sus sitios sin ningún problema. Si abre su propia aplicación de soporte, estaremos encantados de ayudarle a averiguar exactamente qué está causando los problemas que está experimentando.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *