Pregunta sobre WooCommerce de Wordpress:

La actualización de Woocommerce 3.6.2 rompe las publicaciones populares de WordPress

Un usuario preguntó 👇

Siga (o revise) este hilo:

https://wordpress.org/support/topic/woocommerce-3-6-2-upgrade-breaks-wordpress-popular-posts/#post-11490608

Aquí está el hilo en la página de soporte de Publicaciones populares de WordPress:

https://wordpress.org/support/topic/stopped-counting-stats/

Versión corta: la actualización de Woocommerce a 3.6.2 rompe el plugin de publicaciones populares de WordPress y detiene el seguimiento de las estadísticas.

Genial, porque mucha gente está usando el plugin WPP con Woocommerce.

Cloné mi sitio y le di a Héctor Cabrera, un desarrollador de WPP, acceso al sitio de prueba para solucionar el problema.

Diagnóstico: WPP es una combinación de Woocommerce 3.6.2 y Woocommerce PayPal Checkway Gateway 1.6.11.

Informaré a Héctor sobre el problema:

Así que solo pasé una buena parte del día haciendo esto. Aquí están mis resultados:

Al principio, todo funcionó normalmente con solo WPP y WC 3.6.2 habilitados:

http://retro-marketing.com/temp/wpp_problem/wpp_screenshot1.png

Lo que ve arriba es la primera vez que visité uno de sus productos mientras navegaba por su sitio en modo incógnito. Visité algunos otros productos varias veces y cada vez que WPP rastreó las escenas correctamente.

Luego habilité aleatoriamente algunos de sus plugins y, después de un tiempo, la API REST comenzó a rechazar sus solicitudes WPP nuevamente:

http://retro-marketing.com/temp/wpp_problem/wpp_screenshot2.png

Inhabilité todos los plugins excepto WPP y WC, pero desafortunadamente el problema aún existía: WPP 403 seguía respondiendo desde la API REST.

Luego revisé el sitio usando un navegador diferente (Microsoft Edge) con WPP y WC recién habilitados y WPP rastreó mi visita perfectamente:

http://retro-marketing.com/temp/wpp_problem/wpp_screenshot3.png

Al habilitar los plugins nuevamente, pregunte:

http://retro-marketing.com/temp/wpp_problem/wpp_screenshot3.png

Entonces, el problema está, como dice la API REST, relacionado con una cookie.

Después de un poco de prueba y error, descubrí que el problema se manifiesta cuando estos plugins están activos al mismo tiempo:

WooCommerce 3.6.2 Pasarela de pago de PayPal WooCommerce 1.6.11 Publicaciones populares de WordPress 4.2.2

Entonces, en resumen, WooCommerce PayPal Checkout Gateway parece ser lo que está causando el problema.

Etapas de reproducción:

1. Habilite los tres plugins mencionados y marque una de sus publicaciones. La API REST corresponderá al estado 403. 2. Desactive el plugin PayPal WooCommerce PayPal Check Gateway, borre las cookies de su navegador y marque una de sus publicaciones. La API de REST corresponde al estado 200. 3. Habilite el plugin de la pasarela de pago de WooCommerce de PayPal, borre las cookies de su navegador y verifique una de sus publicaciones. REST API responde con el estado 403 nuevamente. ————————————————————————

Entonces, ¿qué hacemos aquí?

No soy el único que tiene este problema; Solo soy el alma afortunada que lo encontró.

¿Discutirían esto directamente con Héctor? O puedo proporcionar acceso a mi sitio de prueba para su equipo de desarrollo, si es necesario.

Por favor avise.

Charlie

(@fernashes)

Ingeniero Automático de Felicidad

Hace 1 año, 8 meses

Hola ann @essmeier,

¡Gracias por estas detalladas notas de prueba!

Lo revisé, y esto debería arreglarse en WooCommerce 3.6.2:
https://github.com/woocommerce/woocommerce/pull/23372

Lo mencionó en su respuesta original, pero ¿puede confirmar que todavía está viendo el problema? 3.6.2?

(@essmeier)

Hace 1 año, 8 meses

Si. Estaba ejecutando la versión 3.6.2 cuando noté el problema por primera vez.

Tengo un problema con este conjunto de plugins:

Woocommerce 3.6.2 PayPal Check Gateway Woocommerce 1.6.11 Publicaciones populares de WordPress 4.2.2

Hasta ahora, he devuelto Woocommerce a 3.5.8 en mi sitio en vivo para mantener mi sitio completamente funcional.

Estoy usando las tres listas anteriores en mi sitio de prueba y no funciona, aunque PUEDO hacer que las publicaciones populares de WordPress funcionen con Woocommerce 3.6.2 si desactivo el plugin PayPal Check Gateway.

Por supuesto, entonces no puedo pagar …

(@treibalen)

Hace 1 año, 8 meses

Hola ann @essmeier,

Respondí a tu hilo aquí – https://wordpress.org/support/topic/conflict-with-paypal-gateway-and-wordpress-popular-posts/#post-11534351 – así que cierra este tema.

¡Salud!

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *