Pregunta sobre Google Photos & Others Photonic Gallery & Lightbox for Flickr SmugMug de Wordpress:

La API de Google Fotos no puede funcionar

Un usuario pregunt贸 馃憞

Hola, estoy tratando de importar fotos de Google Photos a mi sitio web de WordPress usando photon, pero siempre dice que no se encontr贸 ning煤n 谩lbum.

Segu铆 la gu铆a proporcionada en https://aquoid.com/plugins/photonic/google-photos/#auth Fue de acuerdo con la direcci贸n hasta OBTENER TOKEN pero solo muestra una barra cargada y no pasa nada. As铆 que continu茅 el trabajo usando Playground OAuth2.0 y fui en contra de un cartel de actualizaci贸n que parec铆a 1 / t ____________________. Lo copi茅 y pegu茅 en Photonic Settings.

Luego fui a Photonic> Ayudante> Buscar ID de 谩lbum 鈥-> Dice que no se encontr贸 ning煤n 谩lbum.

Por favor ayuda. Gracias 馃檪

(@sayontan)

Hace 1 a帽o, 10 meses

驴Est谩 seguro de que utiliz贸 su propia identificaci贸n de cliente al generar los tokens? 驴Se ha asegurado de haber agregado los alcances correctos?

Desafortunadamente, esta es una de esas situaciones en las que no puedo ayudar (las reglas del foro me impiden obtener credenciales de inicio de sesi贸n para su sitio). Tambi茅n es uno de esos casos que rara vez ocurre, nunca. Hasta ahora, solo he logrado ayudar a un usuario con Google Fotos.

Es posible que desee configurar una p谩gina de prueba con este tipo de acceso directo all铆:

Una vez que lo hagas, puedes compartir la URL para que yo la vea.

(@muggle)

Hace 1 a帽o, 10 meses

Arregl茅 el atajo que me diste y lo pegu茅 en esta p谩gina http://whitehouse.com.np/gallery/ pero sigue siendo un editor cl谩sico y vac铆o, dice No encontrado encontrado

(@sayontan)

Hace 1 a帽o, 10 meses

驴Tiene un atajo personalizado configurado para Photonic (Configuraci贸n fot贸nica 鈫 鈫 Opciones gen茅ricas 鈫 Configuraci贸n gen茅rica 鈫 C贸digo abreviado personalizado)? El editor cl谩sico mostrar谩 芦No se encontraron art铆culos禄 si tiene un atajo personalizado configurado en las opciones pero est谩 usando el gallery atajo para definir las galer铆as fot贸nicas.

(@muggle)

Hace 1 a帽o, 10 meses

S铆, configur茅 el acceso directo personalizado a gphotos, reemplac茅 gphotos con 芦galer铆a禄 en el c贸digo abreviado y ahora introduje un nuevo error:

No se pudieron obtener los datos. Error: faltan las credenciales de autenticaci贸n que faltan en la solicitud. Se esperaba un token de acceso OAuth 2, una cookie de inicio de sesi贸n u otra credencial de autenticaci贸n v谩lida. Mira https://developers.google.com/identity/sign-in/web/devconsole-project.

Por cierto, gracias por una respuesta r谩pida y eres incre铆ble

(@sayontan)

Hace 1 a帽o, 10 meses

De acuerdo, desafortunadamente, parece ser el segundo usuario que no podr茅 hacer este trabajo por 茅l. Tuve una larga discusi贸n con otra persona que tuvo el mismo error y no pude resolverlo a pesar de los largos esfuerzos de ida y vuelta.

Intente eliminar sus credenciales de autenticaci贸n, es decir, eliminar las claves y los tokens. Luego, vuelva a iniciar el proceso de autenticaci贸n (use Google OAuth Playground directamente) y obtenga los tokens. Aseg煤rese de utilizar sus propias claves y los 谩mbitos correctos al realizar la autenticaci贸n.

Si funciona, muy bien. De lo contrario, lamentablemente, no creo que los esfuerzos para solucionar este problema funcionen.

(@muggle)

Hace 1 a帽o, 10 meses

ok gracias, estaba pensando que tal vez el error podr铆a hacerme debido a dos usuarios diferentes. Intentar茅 hacer lo que dijiste. Te actualizar茅 si algo sale bien.

Muchas gracias 馃檪

(@muggle)

Hace 1 a帽o, 10 meses

Pas茅 por toda la conversaci贸n entre t煤 y Steve. Adem谩s, pegu茅 los c贸digos que proporcion贸 en pastebin. Cuando pegu茅 el el primero (https://pastebin.com/Bje2vkvu) Encontr茅

No hab铆a Token Array ()

y luego me pegu茅 茅ste (https://pastebin.com/U5c1jMbX) y estoy consiguiendo

Objeto WP_Error ( [errors] => Editar ( [http_request_failed] => Editar ( [0] => error cURL 7: No se pudo conectar al puerto 443 de accounts.google.com: Enlace rechazado)) [error_data] => Editar ())

Dej茅 el documento con el segundo c贸digo php atascado. Echale un vistazo aqu铆

Usted me podr铆a ayudar ??

Elimin茅 todo el proyecto, luego cre茅 un nuevo proyecto y habilit茅 las fotos de la API y cambi茅 el correo electr贸nico del administrador al mismo correo electr贸nico que estoy usando.

Pero todav铆a no puedo usar un fot贸n

A diferencia de Steve, cuando trato de agregar la galer铆a de fotones a una interfaz de usuario, no puedo ir m谩s all谩 de seleccionar fotos de Google. Luego dice que no se encontraron 谩lbumes.

Gracias por tu apoyo. Espero que podamos salir de este t煤nel.

Perd贸n por mi pobre ingl茅s 馃檪

(@muggle)

Hace 1 a帽o, 10 meses

Tambi茅n trato de usar otro plugin llamado forminator para crear formularios y enviar datos a google api y tambi茅n me da una pregunta similar

Error al conectarse al puerto 443 de ports.google.com: conexi贸n rechazada

por lo que el problema podr铆a estar en otro lugar o algo incorrecto en la forma en que lo estoy haciendo.

(@sayontan)

Hace 1 a帽o, 10 meses

Lo siento, pero no s茅 c贸mo ayudar con esto. Si esto sucediera al final, podr铆a haber ido al c贸digo y haber examinado todas las opciones posibles, pero aqu铆 ese tipo de soluci贸n de problemas no es posible. B谩sicamente, el primer mensaje de error que recibi贸 (Request is missing required authentication credential. Expected OAuth 2 access token, login cookie or other valid authentication credential) es un escaparate, y si su autenticaci贸n ha sido exitosa, no hay ninguna raz贸n por la que deba surgir.

No estoy seguro de si esto ayudar谩, pero podr铆a serlo, as铆 que intent茅moslo: 驴puedes intentar deshabilitar la verificaci贸n SSL desde Photonic 鈫 Configuraci贸n 鈫 Opciones gen茅ricas 鈫 Avanzado 鈫 Desactivar la verificaci贸n SSL en las llamadas?

Si no funciona, el problema estar铆a en la configuraci贸n de su sitio, o con otro plugin que impide que se produzca el enlace.

(@muggle)

Hace 1 a帽o, 10 meses

No … no creo que funcione

Mala suerte, supongo. Intentar茅 esto en un nuevo dominio con una nueva cuenta de Google y todo este fin de semana y ver茅 si funciona.

Gracias por todo su apoyo

Debe haber sido alg煤n tipo de error tonto de mi parte

Buenas noches,

Muchas gracias 馃檪

(@muggle)

Hace 1 a帽o, 10 meses

Tambi茅n tal vez deber铆a probar flickr

(@muggle)

Hace 1 a帽o, 10 meses

Hey, @sayontan finalmente resolvi贸 el problema

No fue un error con el plugin o la autenticaci贸n, sino un error debido al sitio web desde el que estaba alojando. Estaba usando alojamiento gratuito (espacio de premio) y su paquete gratuito no me permit铆a comunicarme con servidores externos o enviar solicitudes HTTPS. as铆 que ninguna de las apis estaba funcionando.

Gracias por su apoyo y su incre铆ble plugin 馃檪

(@sayontan)

Hace 1 a帽o, 10 meses

Eso es una gran noticia (隆uf!)

隆Gracias por hac茅rmelo saber!

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *