Pregunta sobre Localhost Installs de Wordpress:

La versión de PHP se cambió cuando se cargó en el servidor desde localhost

Un usuario preguntó 👇

Actualmente estoy desarrollando un sitio web de wordpress en localhost con Xampp. Mi versión de Xampp es muy antigua y tiene una versión php de 5.6.3.

Quería actualizar mi sitio para usar la última versión de wordpress, pero aparece este mensaje: «No se puede actualizar porque WordPress 5.3.2 requiere la versión de PHP 5.6.20 o superior».

No quiero actualizar ni reinstalar mi versión de Xampp en este momento.

Mi pregunta es … tan pronto como subo un sitio web de WordPress a mi servidor en línea … ¿estoy cargando mi versión anterior de PHP al sitio web y los archivos de la base de datos? ¿O WordPress toma PHP de lo que proporciona el servidor … así puedo pedirle a mi servidor que proporcione una versión posterior de PHP (es decir, 7.0)? ¿Y qué debo hacer para vincular a la última versión de PHP para mi sitio web?

Acabo de revisar el tablero en uno de mis otros sitios de WordPress en este servidor … y parece que usan una versión aún más antigua de PHP: 5.3.29.

Si elijo una versión más reciente como la 7, ¿hay alguna preposición que deba hacer en el sitio por adelantado? ¿Y habría algún problema con volver a una versión anterior si tengo problemas para ejecutar PHP 7?

Gracias por cualquier sugerencia. (Lo siento, sé que probablemente estas sean preguntas muy básicas).

Saludos, SunnyOz

(@catacaustica)

Hace 1 año, 1 mes

Cuando mueva el sitio, solo contendrá los archivos y la base de datos del sitio. El servidor se encarga de PHP, MySQL, etc. Así que no tienes que preocuparte por ese lado de las cosas. En su caso, sugeriría que lo mejor que puede hacer es cambiarlo y hacerlo funcionar y luego ver la actualización de PHP.

Dependiendo del servidor que reciba, es posible que pueda seleccionar versiones de PH en el panel de control de alojamiento. CPanel tiene esa opción, y supongo que muchos otros también la tienen. De lo contrario, su empresa de alojamiento debería poder ayudar, principalmente porque PHP 5.6 es muy antiguo, no es compatible y debe actualizarse de inmediato.

Lanzador de hilos

(@sunnyoz)

Hace 1 año, 1 mes

Gracias @catacaustic por su rápida respuesta. Acabo de comprobar mi servidor y puedo cambiar la versión de php a través de mi panel de control. Tienen opciones para 5.2, 5.3, 5.4, 5.5, 5.6 y 7.

¿Hay algún problema con cambiar la versión a 7, y si hay problemas funcionales con mi sitio de WordPress, vuelva a cambiarlo a la versión anterior (es decir, 5.3)? ¿Requiere el sitio alguna preparación previa? ¿O en el servidor? ¿O puede alternar entre versiones si está probando configuraciones (si es necesario debido a la versión más nueva)?

Gracias de nuevo.

Saludos, SunnyOz

(@catacaustica)

Hace 1 año, 1 mes

Si fuera yo, lo configuraría, luego cambiaría a 7 y vería si algo sale mal. Lo más probable es que esté bien, pero puede volver atrás si sale demasiado mal.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *