Pregunta sobre Yoast SEO de Wordpress:

LinkedIn muestra una imagen incorrecta

Un usuario preguntó 👇

Hola

Para el sitio web de mi cliente, tengo un problema con las etiquetas OG.

En este plugin de Yoast, arreglé una imagen de Open Graph. Cuando comparto la URL en Facebook, esto funciona perfectamente y el depurador también muestra la imagen correcta. (http://personalcoach4u.be/wp-content/uploads/2017/11/facebook-delen.png)

Pero cuando comparto el sitio en linkedIn, no muestra la imagen de arriba, sino una imagen del pie de página. Sé que LinkedIn tiene un caché durante una semana, así que esperé 2 semanas, pero sigue siendo el mismo.

¿Alguna idea de cómo puedo resolver esto sin usar una imagen visible ya que se está usando un control deslizante?

Gracias de antemano, Saludos,

Bart

(@mazedulislamkhan)

hace 3 años

Miramos tu provisión ubicación y podemos confirmar que SEO Yoast está generando correctamente las metaetiquetas de gráficos abiertos sociales necesarios como se esperaba.

Luego verifique la imagen que definió como el og:image y podemos confirmar que satisface las necesidades de Linkedin. Por lo tanto, no estamos seguros de por qué Linkedin no muestra la imagen correcta.

Dicho eso según el Linkedin, si la imagen cumple con los requisitos, pero aún no está visible en las actualizaciones de LinkedIn, es posible que su sitio web nos esté impidiendo que arrastremos la imagen o que la imagen esté ubicada en un directorio o sitio Web protegida.

Para obtener más ayuda, visite el foros del sitio para desarrolladores.

(@jerparx)

Hace 2 años, 12 meses

Cerrado por inactividad.

(@ mindfire-tnagy)

Hace 2 años, 7 meses

Perdón por la reapertura, pero por temor a involucrarme y ayudar a alguien más, el soporte de LinkedIn me informó que priorizan oEmbeds sobre las etiquetas Open Graph. Por defecto (creo), WordPress agrega las siguientes líneas en el <head> alt:

<link rel="alternate" type="application/json+oembed" href="https://www.example.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.example.com%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.example.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.example.com%2F&format=xml" />

En el JSON / XML resultante, thumbnail_url corresponde a la Imagen Destacada de mi publicación. Esto fue compartir LinkedIn en lugar de mis etiquetas Open Graph. Dibujo estas líneas por:

remove_action('wp_head', 'wp_oembed_add_discovery_links', 10);
remove_action('wp_head', 'wp_oembed_add_host_js');

Traté de compartirlo nuevamente con una página diferente en mi sitio que no se almacenó en caché durante 7 días (suspiro LinkedIn) y comencé a dibujar la imagen OG correcta.

(@gbougas)

Hace 2 años, 2 meses

Tony hola .. gracias primero por abrir de nuevo el ticket y dar la solución. Pero dígame algo porque tengo el mismo problema. codifique estas líneas: remove_action (‘wp_head’, ‘wp_oembed_add_discovery_links’, 10); remove_action (‘wp_head’, ‘wp_oembed_add_host_js’);

donde esta colocado? ¿Qué archivo de wordpress?

Muchísimas gracias por su tiempo.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *