Pregunta sobre Arreglando WordPress de Wordpress:

Los enlaces permanentes no funcionan; probé configuraciones comunes

Un usuario preguntó 👇

¡Saludos!

Soy un aficionado y un novato, ¡así que únete a mí!

Estoy alojando mi sitio localmente usando Wamp. Estoy usando el tema premium click mag. Estoy en la publicación en su formulario de soporte, pero como tuve este problema con otros temas gratuitos, pensé en abrir esto al público en general y ver si puedo encontrar algunos secretos.

Los hechos:

Servidor: Tema local (Wamp): Haga clic en Mag Versión de WordPress: 4.9.1

Qué sucede: cuando cambio la estructura del enlace permanente a nada más que la predeterminada, obtengo el error 404 cuando intento acceder a las páginas internas.

La página de inicio se muestra perfectamente.

Lo que intenté: Eliminar el archivo HTASSESS. Recrea uno nuevo con:

# COMIENZO WordPress RewriteEngine en RewriteBase / The% 20Red% 20Take / wordpress / RewriteRule ^ index .php $ – [L] RewriteCond% {REQUEST_FILENAME}! -F RewriteCond% {REQUEST_FILENAME}! -D RewriteRule. /The%20Red%20Take/wordpress/index.php [L]

# FIN WordPress

Si cambio el contenido de HTACCESS o lo elimino y luego reutilizo el cambio en los enlaces permanentes, automáticamente reconstruye el archivo HTACCESS igual que arriba.

Revisé Apache y mi módulo de reescritura está activo.

Estoy perdido. ¿Alguien puede dar sugerencias?

¡Muchas gracias de antemano!

Chris

(@keithdriscoll)

Hace 2 años, 10 meses

No estoy seguro si esta es la solución ya que no uso WAMP, pero mira esto: http://www.wpbeginner.com/wp-tutorials/how-to-enable-custom-permalinks-in-wordpress-wamp-installation/. Le dice que se asegure de que la reescritura de mod esté habilitada.

Espero que eso ayude 🙂

(@ chrisnmandy2004)

Hace 2 años, 10 meses

Keith (@keithdriscoll)

No estoy seguro si esta es la solución ya que no uso WAMP, pero mira esto: http://www.wpbeginner.com/wp-tutorials/how-to-enable-custom-permalinks-in-wordpress-wamp-installation/. Le dice que se asegure de que la reescritura de mod esté habilitada.

Espero que eso ayude 🙂

¡Gracias, Keith! Agradezco la respuesta; desafortunadamente, lo he intentado antes. Mi módulo de reescritura ya está habilitado, pero incluso intenté deshabilitarlo y volver a habilitarlo, lo cual no sirvió de nada 🙁 ¡Realmente aprecio la ayuda!

(@keithdriscoll)

Hace 2 años, 10 meses

Abra un archivo httpd.conf haciendo clic en el icono de WAMP y vaya a apache> httpd.conf. Buscar #LoadModule rewrite_module modules/mod_rewrite.so y elimine el símbolo # (descomentar).

¡Déjame saber si eso funciona!

(@ chrisnmandy2004)

Hace 2 años, 10 meses

Verifique el archivo … el # ya ha sido eliminado. Pero gracias … ¿alguna otra sugerencia?

(@sterndata)

Moderador del foro y voluntario del equipo de apoyo

Hace 2 años, 10 meses

Verifique el archivo httpd.conf y agréguelo

<Directory /path/to/wordpress/installation>
  AllowOverride All
</Directory>

luego reinicie WAMP.

(Nota: no uso Windows y no tengo idea de qué camino tomar con WAMP).

Si eso no funciona, puede deshacerse de WAMP y usarlo Local Le Flywheel para alojar su instalación local.

Esta respuesta fue modificada hace 2 años, 10 meses por.

(@tobifjellner)

Hace 2 años, 10 meses

¿Ha verificado la URL del sitio ingresado en /wp-admin/options-general.php?

(@ otto42)

Administración de WordPress.org

Hace 2 años, 10 meses

¿Funciona si usa un nombre de directorio sin espacios en él?

(@ chrisnmandy2004)

Hace 2 años, 10 meses

¡Gracias por todas sus sugerencias!

No sé lo que estoy haciendo, así que voy por Google y trato de averiguar cómo probar todas tus sugerencias. Una vez que tenga la confianza de que los he probado todos correctamente, informaré de mis resultados …

¡Gracias de nuevo!

Chris

(@ chrisnmandy2004)

Hace 2 años, 10 meses

¡Hola!

Gracias por todos los buenos consejos. Al final, seguí el consejo de Steve Stern, apliqué Local by Flywheel y comencé desde cero. Esto no solo resolvió de inmediato el problema del enlace permanente, sino que resolvió otro problema que tenía con el intercambio de redes sociales.

Gracias de nuevo !!

Chris

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *