Pregunta sobre Authorize.net Payment Gateway For WooCommerce de Wordpress:

MD5 Eliminar / Deshabilitar Hash de Authorize.Net

Un usuario pregunt贸 馃憞

Esta ma帽ana recib铆 un correo electr贸nico de Authorize.Net con respecto a la eliminaci贸n / desactivaci贸n de hash MD5. Esto es exactamente lo que mencionaron.

Authorize.Net se est谩 deshaciendo gradualmente del elemento transHash basado en MD5 en favor del transHashSHA2 basado en SHA-256. La configuraci贸n en la interfaz de comerciante que rige la opci贸n MD5 Hash se eliminar谩 a fines de enero de 2019, y el elemento transHash dejar谩 de devolver valores m谩s adelante para tomar una decisi贸n.

Los compradores que utilizan esta funci贸n deben trabajar con su desarrollador web o proveedor de soluciones para verificar si todav铆a est谩n usando un hash basado en MD5 y si a煤n necesitan pasar a un hash SHA-256 a trav茅s de la clave de firma.

Verifiqu茅 un plugin usando el campo hash Md5 en su ubicaci贸n. Mi pregunta es, 驴es un plugin actualizado para admitir una nueva funci贸n de Authorize.Net o para proporcionar cualquier otra soluci贸n alternativa?

Investigue este problema lo antes posible. Por favor av铆seme de cualquier soluci贸n alternativa.

(@winternetweb)

Hace 1 a帽o, 11 meses

La misma pregunta aqu铆. Gracias por publicar esto.

(@mariagriddl)

Hace 1 a帽o, 11 meses

隆El mismo problema aqu铆! Comun铆quese con nosotros lo antes posible.

(@backpages)

Hace 1 a帽o, 11 meses

La misma pregunta aqu铆. H谩ganos saber si esto est谩 cubierto en el plugin o si necesitamos hacer algo por nuestra parte. Muchas gracias.

(@ishanverma)

Hace 1 a帽o, 11 meses

Las actualizaciones relevantes del plugin estar谩n disponibles para todos los usuarios antes del final de esta semana.

(@marketingsst)

Hace 1 a帽o, 11 meses

隆Gracias por publicar y actualizar esto! Estaba a punto de tener el mismo problema.

(@bryanlopez)

Hace 1 a帽o, 11 meses

Yo tambi茅n estaba a punto de tener el mismo problema, 隆gracias por publicar esto!

(@looksink)

Hace 1 a帽o, 11 meses

隆Gracias por responder, Ishan!

驴Sigues en camino de lanzar una actualizaci贸n en los pr贸ximos d铆as?

(@ mercado12)

Hace 1 a帽o, 10 meses

Gracias por publicar esto, estaba a punto de publicar lo mismo con la misma pregunta. 驴Cu谩ndo puedo esperar las actualizaciones?

(@mariagriddl)

Hace 1 a帽o, 10 meses

Solo quer铆a un certificado. Este problema no se solucion贸 en la versi贸n 4.3.3 y deber铆amos esperar a la pr贸xima actualizaci贸n, 驴verdad?

Ser铆a genial si pudiera actualizar el registro de cambios para que sepamos qu茅 se ha actualizado.

隆Gracias!

(@stephenopet)

Hace 1 a帽o, 10 meses

La actualizaci贸n 4.3.3 parece haberse adelantado hoy, pero a煤n no hay soporte para SHA-256. 驴Qu茅 cambios se incluyeron en esta actualizaci贸n si la actualizaci贸n no estaba encriptada?

(@sandyme)

Hace 1 a帽o, 10 meses

Continuo. Definitivamente est谩 interesado en la actualizaci贸n y el soporte para SHA-256.

(@ sharath96)

Hace 1 a帽o, 10 meses

He visto las notas sueltas. Pero no se menciona nada sobre el cifrado SHA. Y en la interfaz de usuario tambi茅n podemos usar MD5 Field. Por favor revise esto lo antes posible.

(@looksink)

Hace 1 a帽o, 10 meses

Compar茅 4.3.2 y 4.3.3 para ver qu茅 cambi贸. Esto es lo que encontr茅.

El plugin ahora indica que se ha probado con WooCommerce 3.5.3 y WordPress 5.0.3. La descripci贸n del plugin y el plugin de administraci贸n se han cambiado para incluir este mensaje: 芦La nueva actualizaci贸n de Hash se lanzar谩 antes del 26 de enero de 2019禄.

As铆 que 4.3.3 parece haber sido una peque帽a versi贸n para que la gente sepa que la actualizaci贸n de hash llegar谩 pronto.

(@winternetweb)

Hace 1 a帽o, 10 meses

驴Alguien especula si debemos ponernos en contacto con Authorize.net para encontrar algo para que esta actualizaci贸n funcione? 驴O la actualizaci贸n arreglar谩 la configuraci贸n actual?

(@stephenopet)

Hace 1 a帽o, 10 meses

Dado que ahora estamos ocho d铆as despu茅s de la fecha l铆mite original establecida por el autor del plugin, eliminar茅 este plugin a favor de la extensi贸n WooCommerce de pago de Indatos (https://www.indatos.com/products/authorize-net-woocommerce-plugin-certified-solution/). Su software utiliza cifrado TLS seguro, lo que elimina la necesidad de cifrado SHA o MD5.

El cifrado MD5 se rompi贸 en 2013 y se confirm贸 que no era seguro. Dada la demanda de transacciones web seguras, me sorprende que el autor de los plugins tard贸 tanto en actualizar su software a los est谩ndares modernos, incluso despu茅s de que se anunci贸 la autorizaci贸n de depreciaci贸n MD5. El OP marc贸 esta huella como resuelta antes de que se abordara el problema. Siento que ya no puedo confiar en este software o autor. Deseo buena suerte a mis compa帽eros usuarios de Autorizaci贸n.

Esta respuesta fue modificada hace 1 a帽o, 10 meses.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *