Pregunta sobre Events Made Easy de Wordpress:

Mensaje de ‘error’ después de actualizar a la versión: 2.0.53

Un usuario preguntó 👇

Hola,

Todo iba muy bien, hasta el día de hoy, cuando algunos clientes potenciales me dijeron que nuestro sistema de reservas no funcionaba.

Cuando ingresa toda la información, y cuando presiona ‘enviar su reserva’, aparece el mensaje de error en la parte superior del capca ‘Se ha producido un error’.

Tengo los plugins deshabilitados, etc., y todavía es visible. La actualización de EME solo pareció cambiar a 2.0.53 durante el fin de semana. (Trabajando 100% viernes).

¿Hay algo en la actualización que pueda causar esto, o necesito modificarlo o modificarlo?

Gracias de antemano, Joe

(@liedekef)

Hace 2 años, 5 meses

¿Usas algunos plugins de almacenamiento en caché extraños? Además: verifique los registros de su servidor web y los registros de la consola de su navegador. Haré una reserva ficticia más tarde y también verificaré en mi navegador.

(@liedekef)

Hace 2 años, 5 meses

Probé 2 reservas, ambas funcionaron perfectamente. Si bien no esperas entrar en un captcha incorrecto y aun así estar «bien». Lo comprobaré por la noche,

Lanzador de hilos

(@cattsjoe)

Hace 2 años, 5 meses

Hola Franky.

Acabo de ver que hiciste una reserva y funcionó.

Revisé mis registros y obtengo JQMIGRATE: Migrate está instalado, versión 1.4.1 main-min.js: 2 PAGE END

Estaba apagando los plugins uno por uno. Sigo recibiendo el error mientras lo pruebo en este momento en Chrome o en varios dispositivos. ¿Qué navegador estás usando?

Gracias Joe

Lanzador de hilos

(@cattsjoe)

Hace 2 años, 5 meses

Lo siento, ¿otro fragmento de la consola de errores si eso puede ayudar?
[Violation] setTimeout handler tomó 52ms
[Violation] Se necesitó un reabastecimiento obligatorio de 32 ms mientras se ejecutaba JavaScript

¿Tiene esto algún sentido en cuanto a por qué no funciona? Por el momento, son solo los plugins del tema y desactivan todo el caché que puedo encontrar en la configuración. 🙁

(@ jcsauer2)

Hace 2 años, 5 meses

Solo quería evitar este problema porque estamos experimentando lo mismo http://gic.geog.mcgill.ca/events/?event_id=63.

Algunas personas pueden registrarse mientras que la mayoría no. Tenemos instalada la última versión de Events Made Easy.

(@liedekef)

Hace 2 años, 5 meses

@ jcsauer2: su problema es más fácil de explicar: no está usando https en la interfaz, pero está usando https los fines de semana. Dado que wordpress ajax en realidad va al fin de semana, https se usa para obtener https://gic.geog.mcgill.ca/wp-admin/admin-ajax.php . Pero también hay un certificado autofirmado detrás, que la mayoría de las personas no han aceptado (todavía) ya que no llegan allí en primer lugar … Solución: póngase boca arriba con https también y un emisor de certificado reconocido (gratis): permite el cifrado).

(@liedekef)

Hace 2 años, 5 meses

@cattsjoe: estaba usando Chrome en Windows, y ahora Firefox en Linux: ambos funcionan perfectamente. Además, un pequeño auricular: los mensajes dobles “campo obligatorio” se solucionarán en la próxima versión. Y creo que debería revisar su plantilla / formulario y eliminar algunas etiquetas o líneas nuevas (o tengo un error …)

(@ jcsauer2)

Hace 2 años, 5 meses

@liedekef ¡gracias por tu rápida respuesta! probaremos esta solución lo antes posible.

Lanzador de hilos

(@cattsjoe)

Hace 2 años, 5 meses

Hola Franky,

Gracias, lo haré. Acabo de comprobar mi evento de comprobación de errores (recién salido de la plantilla de cuadro EME automático, no se ha añadido nada nuevo), http://www.cattsireland.com/events/28/bugcheck/ y funcionó perfectamente.

Creo que estás en el formulario y tienes un problema, así que tendré que revisarlo. Debido a que este sábado es uno de los cursos y tengo que vender otros 10 asientos para entonces, no tengo mucho tiempo para jugar con eso además del trabajo diario. Estoy pensando en 2 opciones, ¿verías una de estas mejor que la otra?

– Modifique un evento existente para usar el formulario estándar que viene con el plugin EME y parece funcionar perfectamente. – algo que debería probar antes de que esto te moleste. Lo siento.) Debido a que hay menos campos en el formulario estándar, ¿se rompería o crearía un problema si se dice que 20 personas están registradas con el formulario anterior y logro vender 10 con el nuevo?

– cerrar el evento actual, luego reemplazarlo (con un nombre ligeramente modificado) con un nuevo formulario, y configurar los asientos para que se llenen los 10 restantes?

Gracias por tu ayuda, Joe.

(@liedekef)

Hace 2 años, 5 meses

Su formulario existente parece funcionar perfectamente aquí también. Tal vez algunos errores de html, pero dado que cada envío de prueba que hago en su sitio funciona, no puedo decirle qué es lo que está mal, ya que nada parece estar mal.

Lanzador de hilos

(@cattsjoe)

Hace 2 años, 5 meses

Hola Franky,

Eres un genio.

Seguí su ejemplo en las etiquetas br y eliminé todos los espacios de línea en el formulario, y ahora parece funcionar perfectamente.

Creo que me ceñiré a la forma estándar de EME de ahora en adelante. ¡Parece que fue demasiado inteligente para mi propio bien!

José

(@liedekef)

Hace 2 años, 5 meses

Bueno, me alegro de que funcione, pero estoy bastante seguro de que el resultado del envío de un formulario no cambiará …

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *