Pregunta sobre Dominant Colors Lazy Loading de Wordpress:

No funciona con el campo de imagen ACF

Un usuario preguntó 👇

¡Hola!

Estoy desarrollando un tema con el plugin ACF Pro para administrar imágenes, en lugar de imágenes visibles.

Una vez que el enchufe está instalado, no veo ninguna carga diferida ni ningún reemplazo de color dominante. ¿Funciona con campos de imagen ACF? Si no es así, ¿hay algo que pueda hacer?

Gracias por adelantado.

(@manuelwieser)

Hace 2 años, 1 mes

Salut Nicolas,

No estoy familiarizado con ACF.

¿Puede utilizar el filtro personalizado mencionado en https://github.com/Lorti/dominant-colors-lazy-loading-wordpress-plugin#how-do-i-use-the-custom-filter-in-my-themes?

De lo contrario, puede leer los valores de color de la base de datos, que crea mi plugin cuando carga una imagen.

Atentamente, Manuel

(@pushaune)

Hace 2 años, 1 mes

Aquí está el código para recuperar imágenes del campo ACF:


$image = get_field('vignette_du_projet'); // Get the image's ID 
$size = 'vignette_projet'; // Get the thumbail size
// If the image field field is not empty, diplay the image with the right size:
if( $image ) {
	 echo wp_get_attachment_image( $image, $size );
}

Intenté esto apply_filters( 'dominant_colors' pero la imagen no se muestra.

(@manuelwieser)

Hace 2 años, 1 mes

Debe aplicar el filtro a su salida y luego repetir la salida del filtro.


$id = get_field('vignette_du_projet');
$image = wp_get_attachment_image( $image, 'vignette_projet' );
$image = apply_filters( 'dominant_colors', $image, $id );
echo $image;

Esta respuesta fue modificada hace 2 años, hace un mes por.

(@manuelwieser)

Hace 2 años

Hola Nicolas

por favor intente 0.7.0 y vea si ayuda. Todas las imágenes de URL que se refieren a cargas de WordPress ahora deberían reemplazarse correctamente.

(@ alenza9)

Hace 1 año, 11 meses

Buenas noches señor,

Por cierto, lamento haberlo escrito aquí, tal vez por ser un novato en un foro de WP.

Como leí en su comentario en «PHP Detector Browser» hace años https://wordpress.org/support/topic/not-working-with-ie-edge-and-mobile

no le sirvió con la detección de IE. Si es así, ¿podría encontrar otro que claramente funcione?

Atentamente, Alejandro

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *