Pregunta sobre Slideshow de Wordpress:

No se admite el uso de un generador de clases de estilo PHP4 despectivo

Un usuario pregunt贸 馃憞

ARCHIVO: wp-content / plugins / slidehow-jquery-image-gallery / classes / SlidePluginWidget.php | ADVERTENCIA No se admite el uso de PHP 7 para utilizar un generador de clases de estilo PHP4 respetado.

Estoy intentando actualizar a PHP7, este plugin es el 煤nico que queda que muestra un error.

(@deweil)

Hace 3 a帽os, 8 meses

Esto se debe a que la clase SlideshowPluginWidget tiene un constructor despectivo (es antiguo y php lo hace de manera diferente ahora). Esta es una configuraci贸n realmente f谩cil si tiene acceso al archivo en cuesti贸n 芦/wp-content/plugins/slideshow-jquery-image-gallery/classes/SlideshowPluginWidget.php禄

La l铆nea 8 de SlideshowPluginWidget.php se ve as铆:

         function SlideshowPluginWidget()
          {

cambia eso a

         function __construct()
          {

El m铆o se ve as铆:

       /**
         * Initializes the widget
         *
         * @since 1.2.0
         */
// commented the old constructor out because it is deprecated 
//      function SlideshowPluginWidget() 
// add the new generic constructor name
        function __construct()
        {

(@deweil)

Hace 3 a帽os, 8 meses

Esta es una configuraci贸n realmente f谩cil si tiene acceso al archivo en cuesti贸n 芦/wp-content/plugins/slideshow-jquery-image-gallery/classes/SlideshowPluginWidget.php禄

La l铆nea 8 de SlideshowPluginWidget.php se ve as铆:

         function SlideshowPluginWidget()
          {

cambia eso a

         function __construct()
          {

El m铆o se ve as铆:

       /**
         * Initializes the widget
         *
         * @since 1.2.0
         */
// commented the old constructor out because it is deprecated 
//      function SlideshowPluginWidget() 
// add the new generic constructor name
        function __construct()
        {

(@scottblackopsca)

Hace 3 a帽os, 8 meses

Estoy de acuerdo en que debe ser el arreglo. Pero si lo soluciono y cambio mi versi贸n de PHP, la pr贸xima vez que haya una actualizaci贸n se romper谩, si no se corrige, entonces tambi茅n

(@deweil)

Hace 3 a帽os, 8 meses

Cuando dijiste:

se romper谩 la pr贸xima vez que haya una actualizaci贸n, si no se arregla all铆 tambi茅n

驴Quiso decir la pr贸xima vez que se actualice el plugin? Si es as铆, tienes raz贸n. Pero es de esperar que el autor del plugin StefanBoonstra actualice esa parte del plugin. Si no es as铆, puede hacerlo usted mismo f谩cilmente, de nuevo.

Perd贸n por las publicaciones repetidas. No se actualiz贸 la primera vez que envi茅, as铆 que volv铆 a publicar mi respuesta. Ahora no puedo borrarlo.

(@tamarakorr)

Hace 3 a帽os, 5 meses

Necesitamos actualizar nuestro servidor web a PHP7. Tambi茅n estamos recibiendo esta advertencia:

FILE: /plugins/slideshow-jquery-image-gallery/classes/SlideshowPluginWidget.php
---------------------------------------------------------------------------------------------------------------
FOUND 0 ERRORS AND 1 WARNING AFFECTING 1 LINE
---------------------------------------------------------------------------------------------------------------
 18 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
---------------------------------------------------------------------------------------------------------------

(@deweil)

Hace 3 a帽os, 5 meses

@tamarakorr,

Suponiendo que puede editar los archivos php directamente, puede cambiarlos para usar el modo de actualizaci贸n. Consulte mi publicaci贸n anterior para obtener m谩s detalles. Publique aqu铆 si tiene m谩s preguntas.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *