Pregunta sobre Gravity Forms Entries in Excel de Wordpress:

No se encontr贸 la clase ‘ZipArchive’

Un usuario pregunt贸 馃憞

Recibo este error en una p谩gina en mantenimiento. Comenz贸 a suceder despu茅s de eliminar m谩s de 200 registros.

Informaci贸n sobre el error

    Plugin Version: 1.5.2
    PHP Version: 7.1.18
    WordPress Version: 4.9.7
    Error message: Class 'ZipArchive' not found
    Error stack trace:

    #0 /home/isctech1/public_html/wp-content/plugins/gf-entries-in-excel/src/Renderer/AbstractPHPExcelRenderer.php(49): PhpOfficePhpSpreadsheetWriterXlsx->save('/tmp/phpxltmp8v...')
    #1 /home/isctech1/public_html/wp-content/plugins/gf-entries-in-excel/src/Renderer/PHPExcelRenderer.php(46): GFExcelRendererAbstractPHPExcelRenderer->renderOutput('xlsx', false)
    #2 /home/isctech1/public_html/wp-content/plugins/gf-entries-in-excel/src/GFExcelOutput.php(58): GFExcelRendererPHPExcelRenderer->handle(Array, Array, Array, false)
    #3 /home/isctech1/public_html/wp-content/plugins/gf-entries-in-excel/src/GFExcel.php(169): GFExcelGFExcelOutput->render()
    #4 /home/isctech1/public_html/wp-includes/class-wp-hook.php(286): GFExcelGFExcel->request(Array)
    #5 /home/isctech1/public_html/wp-includes/plugin.php(203): WP_Hook->apply_filters(Array, Array)
    #6 /home/isctech1/public_html/wp-includes/class-wp.php(364): apply_filters('request', Array)
    #7 /home/isctech1/public_html/wp-includes/class-wp.php(713): WP->parse_request('')
    #8 /home/isctech1/public_html/wp-includes/functions.php(960): WP->main('')
    #9 /home/isctech1/public_html/wp-blog-header.php(16): wp()
    #10 /home/isctech1/public_html/index.php(17): require('/home/isctech1/...')
    #11 {main}

Gracias por la ayuda.

(@doekenorg)

Hace 2 a帽os, 6 meses

Hola @ titor97,

Gracias por tu pregunta He visto este error antes y tiene que ver con la dependencia del 芦nuevo禄 renderizador de excelencia. 驴Ha realizado alguna actualizaci贸n a la versi贸n 1.2 a 1.5? Porque eso lo explicar铆a.

Necesita el paquete zip para php7.1 para optimizarlo ahora (debido a su versi贸n de php). Por favor mira https://stackoverflow.com/questions/3872555/fatal-error-class-ziparchive-not-found-in para obtener informaci贸n sobre c贸mo instalar ese paquete.

D茅jeme saber si esto ayuda.

(@ titor97)

Hace 2 a帽os, 6 meses

Gracias por la respuesta.

Pero, 驴qu茅 debo hacer si ya cargu茅 el php en el servidor web?

驴Hay alguna forma de degradar el plugin? Est谩 sucediendo en una p谩gina en la que solo conservo los plugins de wordpress, as铆 que no s茅 c贸mo cambiar PHP.

(@doekenorg)

Hace 2 a帽os, 6 meses

Deber铆a poder descargar la versi贸n 1.2.3 de la p谩gina del plugin como zip. https://wordpress.org/plugins/gf-entries-in-excel/advanced/ puede eliminar el plugin actual e instalar el m谩s antiguo del zip mediante la carga del plugin.

(@ titor97)

Hace 2 a帽os, 6 meses

Encontr茅 la manera de habilitar el m贸dulo zip desde GoDaddy CPanel y realmente resolvi贸 el problema.

Gracias por la ayuda.

(@doekenorg)

Hace 2 a帽os, 6 meses

隆Frio! 隆Gracias por la actualizaci贸n! Disfruta el plugin.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *