Pregunta sobre Custom Product Tabs for WooCommerce de Wordpress:

No se puede hacer clic en las pestañas

Un usuario preguntó 👇

Así que todas las pestañas están listas, pero realmente no puedes hacer clic en las pestañas.

Versión de WordPress: 5.2.1

Tema: Regina Lite

Versión de Woocommerce: 3.6.4

Pestañas de productos personalizados para la versión de WooCommerce: 1.6.10

(@yikesitskevin)

Hace 1 año, 9 meses

Hola @artichoku,

No veo ninguna pestaña personalizada en el producto que vinculó. ¿Me estoy perdiendo de algo? ¿Este producto tiene pestañas personalizadas?

Hágamelo saber.

Gracias, Kevin.

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

Hola, y sí. Es extraño que no vea las pestañas, porque no me muestra ningún problema.

aquí hay una foto para ti:

Captura de pantalla

(@yikesitskevin)

Hace 1 año, 9 meses

Mmm. ¿Quizás está almacenado en caché para usuarios que no han iniciado sesión? Solo veo la pestaña de descripción.

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

Curiosamente, no tengo ninguna pestaña en Google Chrome. Mi foto era de Firefox. ¿Eso tiene algún sentido?

Esta respuesta fue modificada hace 1 año, 9 meses por.

(@yikesitskevin)

Hace 1 año, 9 meses

Eso no quiere decir. Especialmente porque acabo de ir a su sitio en Firefox y todavía no veo pestañas: https://imgur.com/a/Q8zjTKt.

¡Extraño!

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

hmmmmmm. Puede tener razón en que se trata de un problema de caché para los usuarios actualmente desconectados. Si se aclara, te avisaré cuando eches otro vistazo … bastante raro …

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

Ok, entonces la caché se ha borrado y ahora muestra las pestañas, pero no puedo hacer clic en ellas.

(@yikesitskevin)

Hace 1 año, 9 meses

Aún no he visto las pestañas …

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

ok, ahora me está mostrando las pestañas sin haber iniciado sesión en Chrome y Firefox. No sé qué pasaba con ese caché loco sin limpiarlo correctamente …

(@yikesitskevin)

Hace 1 año, 9 meses

¡Veo las pestañas! Y la pregunta ciertamente me está sucediendo. Esto es raro. Puedo ver el archivo JS de WooCommerce que impulsa la funcionalidad de la pestaña pero no la activa. Tampoco está activado para la pestaña Informe predeterminada.

También veo un comportamiento de «desplazamiento automático» o «desplazamiento suave» que está sucediendo. Si fuerzo el contenido de la pestaña para que sea visible (p. Ej. https://imgur.com/a/5Jay44T), luego haga clic en esa pestaña automáticamente haciendo clic en el título de la pestaña.

Esto me hace pensar que lo que sea que controle el desplazamiento «listo / automático» está secuestrando el comportamiento predeterminado de WC y rompiéndolo. ¿Tiene sentido? ¿Conoce el comportamiento de desplazamiento del que estoy hablando? ¿Sabes de dónde viene eso?

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

* puede ser parte del tema. Dame algunos y te haré saber si ese es el culpable o no. Me alegro de que veas las pestañas al final, ¡jajaja!

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

Bien, definitivamente es un conflicto de tema. Al cambiar a otro tema, se resolvió el problema en sí. Investigaré un poco en los archivos php del tema y veré si puedo encontrar el conflicto. Te haré saber cómo va … Gracias de nuevo por tu ayuda.

(@yikesitskevin)

Hace 1 año, 9 meses

Oye, no hay problema. ¡Busque archivos JS! El conflicto ciertamente es impulsado por un archivo JS que se desplaza hacia las etiquetas de anclaje (<a>) y usos más probables preventDefault() y / o stopPropagation(). Puede intentar eliminar los archivos JS de su tema uno por uno para aislar el archivo conflictivo.

Lanzador de hilos

(@artichoku)

Hace 1 año, 9 meses

Ok, busqué en todos los archivos JS en el tema y solo uno de los códigos que mencionaste está en un archivo. En realidad, se asoció con «desplazamiento suave» y «rutas de ruta», pero una vez que se eliminó el código, las pestañas aún no funcionaban. Tendré que investigar más cuando esté en casa y haya terminado con el trabajo.

	/* ---------------------------------------------------------------------- */
	/*  Back to Top & Waypoint
	/* ---------------------------------------------------------------------- */

		$( '.back-to-top' ).on( 'click', function( event ) {
			event.preventDefault();
			$( 'body,html' ).animate({
				scrollTop: 0 }, 1000
			);
		});

		$( '#footer' ).waypoint(function() {
			$( '.back-to-top' ).fadeIn( 1000 );
		}, { offset: '50%' });

		/* ---------------------------------------------------------------------- */
		/*  Smooth Scrolling
		/* ---------------------------------------------------------------------- */

      $( 'a[href*="#"]:not([href="#"])' ).on( 'click', function() {
          var target;
          if ( location.pathname.replace( /^//, '' ) === this.pathname.replace( /^//, '' ) && location.hostname === this.hostname ) {
              target = $( this.hash );
              target = target.length ? target : $( '[name=' + this.hash.slice( 1 ) + ']' );
              if ( target.length ) {
                  $( 'html,body' ).animate({
                      scrollTop: target.offset().top
                  }, 1000 );
                  return false;
              }
          }
      });

Gracias otra véz …

(@yikesitskevin)

Hace 1 año, 9 meses

Hola @artichoku,

¿Está seguro de que los cambios aún no se han enviado? ¿Probaste de nuevo durante el fin de semana? Ese palo parece ser el culpable para mí.

Hágamelo saber.

Gracias, Kevin.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *