Pregunta sobre WooCommerce Ajax Cart Plugin de Wordpress:

No utilice PHP short_open_tag

Un usuario pregunt贸 馃憞

En el archivo common/MHSettings.php est谩 utilizando la sintaxis PHP como <?= que requiere configuraci贸n de php.ini, es decir, se requiere short_open_tag = On, que se ejecuta de forma predeterminada, pero php.ini dice que se recomienda desactivarlo. Est谩 deshabilitado en la configuraci贸n de nuestro servidor, por lo que tuvimos que actualizar manualmente su plugin y reemplazarlo <?= le <?php echo. Ver comentario de php.ini:

; This directive determines whether or not PHP will recognize code between
; <? and ?> tags as PHP source which should be processed as such. It is
; generally recommended that <?php and ?> should be used and that this feature
; should be disabled, as enabling it may result in issues when generating XML
; documents, however this remains supported for backward compatibility reasons.
; Note that this directive does not control the <?= shorthand tag, which can be
; used regardless of this directive.
; Default Value: On
; Development Value: Off
; Production Value: Off
; http://php.net/short-open-tag
short_open_tag = Off

Este tema fue modificado hace 4 meses, 2 semanas por. Este tema fue modificado hace 4 meses, 2 semanas por.

(@moiseh)

Hace 4 meses, 1 semana

Gracias por reportar el problema. Corregido en nueva versi贸n.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *