Pregunta sobre Black Studio TinyMCE Widget de Wordpress:

Plugin de traducci贸n de cadenas de WPML

Un usuario pregunt贸 馃憞

Hola,

Cuando miro mis widgets en sitios que usan WPMl y Black Studio, veo advertencias:

ADVERTENCIA: Este widget ha realizado una o m谩s traducciones utilizando el plugin de traducci贸n de cadenas de WPML, que ahora es un m茅todo de depreciaci贸n para traducir widgets, a favor del men煤 desplegable 芦Mostrar en el idioma禄 introducido con WPML 3.8. Omita las traducciones existentes creando nuevos widgets y seleccionando el idioma de este widget y los nuevos en consecuencia. Finalmente, elimine las traducciones existentes de la interfaz de traducci贸n de cadenas de WPML. 芦

Inicialmente pens茅 que esto proven铆a de WPML, por lo que su soporte hizo un escaneo general y confirm茅 que este mensaje no proviene de WPML. Es generado por TinyMCE Black Studio Widget.

驴Puede proporcionar m谩s informaci贸n sobre esta advertencia? Tengo docenas de sitios, algunos con muchos widgets, as铆 que quiero entender cu谩n cr铆tico es esto y si las cosas se romper谩n pronto antes de que pueda actualizar todos los widgets.

Gracias.

(@marcochiesi)

Hace 3 a帽os, 1 mes

Hola Yael, confirmo que nuestro plugin advierte cuando detecta widgets que se han transferido a trav茅s de WPML String Translation, un m茅todo que ahora est谩 desaprobado por tener widgets multiling眉es.

A partir del WPML 3.8 lanzado recientemente, recomendamos utilizar el men煤 desplegable nativo 芦Mostrar en el idioma禄.

Consulte tambi茅n nuestras Preguntas frecuentes sobre esto, aqu铆 hay una copia:

Si est谩 utilizando WPML v3.8 o m谩s reciente y necesita traducir un widget, le recomendamos que cree un widget separado para cada idioma de su sitio y asigne el idioma a cada widget en consecuencia utilizando la opci贸n 芦Mostrar en idioma禄. 鈥漃roporcionado por WPML. De esta manera podr谩 trabajar con el editor de video para la traducci贸n. Para versiones anteriores de WPML (hasta 3.7.x), recomendamos instalar el plugin WPML Widgets de terceros, que proporciona la misma funci贸n descrita anteriormente, que no estaba disponible de forma nativa en WPML. En el pasado, tambi茅n recomendamos traducir los widgets usando el plugin oficial de traducci贸n de cadenas de WPML, pero este m茅todo ahora es despectivo porque no era muy f谩cil de usar debido a la imposibilidad de usar el editor de video para la traducci贸n. Si estaba utilizando la traducci贸n de cadenas de WPML, le recomendamos que cambie al m茅todo de traducci贸n anterior y elimine las entradas de la lista de traducci贸n de cadenas de WPML despu茅s de haberlas traducido para que se conviertan en widgets reales. A partir de la versi贸n 2.6.0 del widget TinyMCE Black Studio, se mostrar谩 una advertencia si se detecta alguna traducci贸n depreciada.

Ejemplo para aclarar: probablemente tenga un widget que deba mostrarse en dos idiomas, es decir, ingl茅s (principal) e italiano.

Con la configuraci贸n anterior, habr铆a creado el widget en ingl茅s en la pantalla Widgets y luego lo habr铆a traducido con el plugin de traducci贸n de cadenas de WPML (sin editor visual).

Con la nueva configuraci贸n, crear铆a dos widgets en la pantalla Widgets, utilizando el editor de video, y asignar铆a el idioma en consecuencia, con el bot贸n desplegable 芦Mostrar en idioma禄 proporcionado por la nueva versi贸n de WPML.

Para cambiar de la configuraci贸n anterior a la nueva, deber谩 copiar y pegar las traducciones (t铆tulo + texto) de WPML String Translation en widgets reci茅n creados para los idiomas secundarios, y tambi茅n asignar el idioma correcto a cada widget. (tanto el original como el nuevo).

Las traducciones antiguas seguir谩n funcionando como de costumbre, pero recomendamos cambiar al nuevo sistema.

(@pixelhappystudio)

Hace 3 a帽os, 1 mes

Gracias por la respuesta detallada, Marco, 隆lo apreciamos!

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *