Pregunta sobre WP w3all phpBB de Wordpress:

Problema al usar la funci贸n iframe con https

Un usuario pregunt贸 馃憞

Hola, estoy usando la funci贸n iframe que funcion贸 muy bien, pero ahora que agregu茅 SSL a mi sitio web, ya no puedo cargar el foro en el iframe. Todo funcion贸 bien con http plain.

Esto es lo que hice: – Habilite la funci贸n Let ‘s Encrypt SSL de la empresa de alojamiento web – Cambie la configuraci贸n de WP en la URL a la nueva URL https – Cambie la URL a https en la configuraci贸n de w3all en WP – Cambi贸 de http: // a https: // en la configuraci贸n del servidor de administraci贸n phpBB: se actualizaron los enlaces en general_footer.html para que usen https en lugar de http: se habilit贸 la remodelaci贸n en phpBB y se carg贸 el foro desde el enlace directo

El foro funciona sin el iframe en https://wp2.transamclub.se/phpBB3

驴Me he perdido algo?

Actualizaci贸n: estoy usando la 煤ltima versi贸n de su plugin.

/ Thomas

Este tema fue modificado hace 1 a帽o, 10 meses por. Este tema fue modificado hace 1 a帽o, 10 meses por.

(@axewww)

Hace 1 a帽o, 10 meses

驴Cambiaste al c贸digo v3, luego tambi茅n actualizaste / reconstruiste page-forum.php como se indica? porque se cambi贸 para que funcione con el c贸digo iframe v3. En la configuraci贸n de cookies de ACP -> cookie segura configurada en s铆. 驴Limpiando las cookies?

(@tlagren)

Hace 1 a帽o, 10 meses

Gracias por una respuesta muy r谩pida. S铆, copi茅 iframeResizer.contentWindow.min.js desde el directorio del plugin a la carpeta ra铆z phpBB3. La versi贸n de restablecimiento (primera l铆nea en el archivo js) es v3.6.2 – 2018-09-16.

He creado page-forum.php haciendo clic en el bot贸n 芦Crear / Reconstruir plantilla de p谩gina PhpBB禄 en la configuraci贸n de WP.

Olvid茅 cambiar la configuraci贸n de cookies para guardar, pero no ayud贸 despu茅s de cambiar eso. He borrado todas las cookies y tambi茅n he probado otros dispositivos.

Cuando visito el foro / url, Javascript se ejecuta e intenta cargar la p谩gina, pero el resultado est谩 vac铆o. Intent茅 volver a http plain de nuevo y el foro volvi贸 a funcionar. Entonces mi problema est谩 relacionado con https.

Al comparar archivos, not茅 que page-forum.php es un poco diferente de la versi贸n en su TRUNK, pero creo que ya est谩 en la pr贸xima versi贸n en TRUNK.

$ diff page-forum.php page-forum.php_fromtrunk 
275c275,276
< if(/[^-0-9A-Za-z._#:?/=&%]/ig.exec(w3all_passed_url) !== null){
---
> // security: do not pass to be encoded an url with sid or if point to phpBB admin ACP via iframe
> if( /[^-0-9A-Za-z._#:?/=&%]/ig.exec(w3all_passed_url) !== null || /adm//ig.exec(w3all_passed_url) !== null || /sid=/ig.exec(w3all_passed_url) !== null ){

/ Thomas

Esta respuesta fue modificada hace 1 a帽o, 10 meses.

(@tlagren)

Hace 1 a帽o, 10 meses

Prob茅 una vieja PC Win7 con Internet Explorer y muestra el encabezado de mi foro phpBB. La altura del ifrane parece peque帽a, pero con Google Chrome de la misma computadora Win est谩 vac铆a.

Entonces, 驴tal vez el foro est谩 cargado, pero no es visible si hay un problema con la altura del iframe mientras se usa ssl?

/ Thomas

(@axewww)

Hace 1 a帽o, 10 meses

locked loading mixed active content 鈥渉ttp://wp2.transamclub.se/phpBB3/鈥

pero como veo que lo tienes todo arreglado correctamente seg煤n sea necesario … qu茅 situaci贸n tan est煤pida … d茅jame pensarlo un poco m谩s … golpe …

(@axewww)

Hace 1 a帽o, 10 meses

ps lo anterior que veo en una consola, esto fue causado por un error js, 驴borraste el cach茅 phpBB? no imaginen c贸mo podr铆a interferir por si acaso鈥 y eventualmente wp cache si hay un plugin de wp cache. La url que carga phpBB en iframe es https, pero la consola invierte lo anterior, as铆 que reh煤sa cargarla y este es el resultado. 驴Por qu茅 todav铆a no entend铆?

Esta respuesta fue modificada hace 1 a帽o, 10 meses.

(@axewww)

Hace 1 a帽o, 10 meses

ver alguna imagen en phpbb se carga como http, podr铆a ser este el problema. 驴C贸mo configuro la URL de phpBB? https o http? Tal vez este es el problema. Verifique la configuraci贸n general en acp

Esta respuesta fue modificada hace 1 a帽o, 10 meses.

(@tlagren)

Hace 1 a帽o, 10 meses

Aah, me perd铆 la advertencia en Chrome sobre el bloqueo de scripts no seguros. Si hago clic en el permiso, el foro est谩 bien cargado. Entonces, volvemos al problema de por qu茅 est谩 sucediendo esto. Si navego directamente al foro, no hay advertencias sobre contenido mixto.

Revis茅 tanto / phpBB3 / como / forum / url con http://www.whynopadlock.com y esa herramienta no encontr贸 contenido mixto, pero probablemente no pudo cargar el javascript.

No tengo ning煤n plugin de cach茅 instalado en WP, elimin茅 todos los archivos en la carpeta de cach茅 para phpBB3.

Quiz谩s mi proveedor de hosting tenga algo de cach茅 porque no obtengo ning煤n archivo o configuraci贸n en la que preste atenci贸n http: // wp2 & # 8230; como informa Chrome.

Tengo que seguir buscando esto, gracias por tu ayuda hasta ahora.

/ Thomas

(@axewww)

Hace 1 a帽o, 10 meses

隆finalmente implementado despu茅s de una larga caminata por debajo de 0 grados! 隆quiz谩s sea m谩s normal para ti!

Bien, vea que no hay una raz贸n aparente para esto, pero puedo seguir eso ahora que verificar茅 m谩s y: aqu铆 est谩 la solicitud:

Host: wp2.transamclub.se
User-Agent: Mozilla/5.0 
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate, br
Referer: https://wp2.transamclub.se/forum/
DNT: 1
Connection: keep-alive
Cookie: phpbb3_jgdwe_u=1; phpbb3_jgdwe_k=; phpbb3_jgdwe_sid=92be3c746cedb2aa8d253539b102240c; cookie_notice_accepted=true
Upgrade-Insecure-Requests: 1>

y aqu铆 est谩 la respuesta:

HTTP/1.1 301 Moved Permanently
Date: Fri, 04 Jan 2019 18:38:10 GMT
Server: Apache
Location: http://wp2.transamclub.se/phpBB3/
Content-Length: 241
Keep-Alive: timeout=5, max=191
Connection: Keep-Alive
Content-Type: text/html; charset=iso-8859-1

por alguna raz贸n, la respuesta de phpBB es http 301, la raz贸n no me queda clara en este momento, 驴comprende bien que todos est谩n disponibles para probar?

(@tlagren)

Hace 1 a帽o, 10 meses

En esta 茅poca del a帽o la temperatura suele estar por debajo de 0. El a帽o pasado estaba loco con la nieve, est谩bamos casi 1 metro y unos -10 grados, pero hoy hac铆a 3-5 grados m谩s y la nieve es un poco que estamos derritiendo. Espero que cambie para que tengamos un invierno adecuado aqu铆 en el norte de Suecia.

Cre茅 un ticket de soporte para mi empresa de alojamiento web y pregunt茅 si exist铆a alg煤n mecanismo de almacenamiento en cach茅, todav铆a esperando una respuesta.

Para HTTP 301 tambi茅n me di cuenta de eso, pero cuando no pones la / (barra) al final de la URL. Es lo mismo con todas las URL de WP, por ejemplo https://wp2.transamclub.se/kontakt as铆 que supongo que es una caracter铆stica de WP.

/ Thomas

(@tlagren)

Hace 1 a帽o, 10 meses

Not茅 otra cosa. Cuando hago clic en 芦Crear / Reconstruir plantilla de p谩gina禄 en la configuraci贸n de w3all, marco el error de php a continuaci贸n.
Notice: Undefined variable: w3all_pages in /wp2.transamclub.se/public_html/wp-content/plugins/wp-w3all-phpbb-integration/views/config.php on line 95 Warning: Invalid argument supplied for foreach() in /wp2.transamclub.se/public_html/wp-content/plugins/wp-w3all-phpbb-integration/views/config.php on line 95

/ Thomas

(@axewww)

Hace 1 a帽o, 10 meses

Para HTTP 301 tambi茅n me di cuenta de eso, pero cuando no pones la / (barra) al final de la URL. Es lo mismo con todas las URL de WP, por ejemplo https://wp2.transamclub.se/kontakt as铆 que supongo que es una caracter铆stica de WP.

No creo que est茅 relacionado con otra cosa, pero tal vez me equivoque. El enlace de arriba no devuelve lo mismo, es posible que haya explicado con malas palabras lo que suceder谩. 驴Cu谩l es el contenido de su htaccess en phpBB?

Esta respuesta fue modificada hace 1 a帽o, 10 meses.

(@tlagren)

Hace 1 a帽o, 10 meses

El phpBB .htaccess es el predeterminado, creo.

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ app.php [QSA,L]
Options +FollowSymLinks
</IfModule>
<IfModule mod_version.c>
	<IfVersion < 2.4>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfVersion>
	<IfVersion >= 2.4>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfVersion>
</IfModule>
<IfModule !mod_version.c>
	<IfModule !mod_authz_core.c>
		<Files "config.php">
			Order Allow,Deny
			Deny from All
		</Files>
		<Files "common.php">
			Order Allow,Deny
			Deny from All
		</Files>
	</IfModule>
	<IfModule mod_authz_core.c>
		<Files "config.php">
			Require all denied
		</Files>
		<Files "common.php">
			Require all denied
		</Files>
	</IfModule>
</IfModule>

/ Thomas

(@axewww)

Hace 1 a帽o, 10 meses

Ok gracias por un informe, veo el error pero no hay problema, lo arreglar茅 pero no va a hacer nada mal, la p谩gina se reconstruye correctamente, lo 煤nico que pasar谩 es que no se reponga la anterior si la tienes nueva p谩gina para construir. Voy a arreglar esto lo antes posible.

驴Sobre el problema en iframe y el wt htaccess?

(@tlagren)

Hace 1 a帽o, 10 meses

Seo .htaccess para WP.

<FilesMatch "^.*(error_log|wp-config.php|php.ini|.[hH][tT][aApP].*)$">
Order deny,allow
Deny from all
</FilesMatch>

RewriteEngine On
RewriteBase /
RewriteRule ^index.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]

/ Thomas

(@axewww)

Hace 1 a帽o, 10 meses

el error de informe informado del error se solucion贸 cuando se cre贸 un foro de repositorio, por cierto, como se dijo, no hubo problemas.

y tambi茅n para wp htaccess no digo nada … wow …

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *