Pregunta sobre LiteSpeed Cache de Wordpress:

Problema con la carga remota de JQuery

Un usuario preguntó 👇

Hola.

Si configura «Importación remota de JQuery» en la pestaña CDN de un plugin de LiteSpeed ​​Cache en Google o Cdnjs, se produce un error 404.

https://ajax.googleapis.com/ajax/libs/jquery/1.12.4-wp/jquery.min.js

https://cdnjs.cloudflare.com/ajax/libs/jquery/1.12.4-wp/jquery.min.js

Confirmé que tampoco hay un destino de enlace y pensé que sería necesario modificar el plugin de URL de destino remoto de JQuery, así que lo escribí.

Las URL válidas que encontré fueron:

https://ajax.googleapis.com/ajax/libs/jquery/1.12.4/jquery.min.js

https://cdnjs.cloudflare.com/ajax/libs/jquery/1.12.4/jquery.min.js

Modifique la URL de destino de la conexión para la biblioteca jquery del plugin.

No tengo buen inglés, así que perdóname si tienes problemas para leer.

Este tema fue modificado hace 1 año, 6 meses por.

(@prowebassist)

Hace 1 año, 6 meses

@leoraphael ¡Lo mismo aquí! Esto solo rompió todo nuestro sitio, ya que el control remoto no pudo cargar jQuery y, por lo tanto, todos los scripts que se basaban en jQuery arrojaron un error.

Arréglalo lo antes posible.

Ahora mismo puede solucionar el problema a través del Cargar JQuery de forma remota acerca de CDN pestaña para APAGADO.

(@daganloygmailcom)

Hace 1 año, 6 meses

Esto también rompió mi sitio. Pero, ¿qué pasó exactamente? ¿Parece que Google no actualizó el archivo o el litespeed de alguna manera para actualizar su plugin externamente? De todos modos, sí, apagándolo, vuelve a funcionar.

(@leoraphael)

Hace 1 año, 6 meses

@prowebassist @daganloygmailcom

No sé el motivo, pero después de actualizar a WordPress 5.2.1, se produjo de repente un problema en el sitio web.

Mientras investigaba la causa, confirmé que había un error en el funcionamiento de JQuery y encontré la solución cambiando la configuración del plugin LiteSpeed ​​Cache.

Dado que la desactivación del plugin funcionó correctamente, como resultado de verificar minuciosamente los elementos reparados, el problema se resolvió mediante el uso de «JQuery Remote Import» como Google o Cdnjs.

(@oliverhtml)

Hace 1 año, 6 meses

Hola, tenía la misma pregunta, en el último núcleo de wordpress en wp-include / script-loader.php online 1015 Las siguientes dos líneas corresponden a la versión incorrecta de jquery

$ scripts-> add (‘jquery’, false, edit (‘jquery-core’, ‘jquery-migrate’), ‘1.12.4-wp’); $ scripts-> add (‘jquery-core’, ‘/wp-includes/js/jquery/jquery.js’, edit (), ‘1.12.4-wp’);

el cuarto argumento es el número de versión

en el plugin parece estar extrayendo el número de versión de wordpress de la línea litespeed-cache-cdn.class.php 590

Para el, Oliver

(@tomrobak)

Hace 1 año, 6 meses

fijo https://www.youtube.com/watch?v=GsBW3XIrXEM

(@hailita)

Hace 1 año, 6 meses

Hola, el arreglo está en https://github.com/litespeedtech/lscache_wp/commit/5f648b47da8624975c4671adf6665d135d57b3de y se lanzará hoy en v2.9.8

(@hailita)

Hace 1 año, 6 meses

Gracias también @tomrobak por el video de solución rápida: p

(@leoraphael)

Hace 1 año, 6 meses

@oliverhtml @tomrobak @hailite

Gracias por tu respuesta y explicación.

Dejaré de usar temporalmente el jquery externo y esperaré a que se actualice el plugin.

Se guardó con la rápida respuesta de todos. Estoy muy agradecido contigo.

Esta respuesta fue modificada hace 1 año, 6 meses.

(@daganloygmailcom)

Hace 1 año, 6 meses

Sí, todos estaremos esperando 2.9.8

Gracias.

(@titsmaker)

Hace 1 año, 5 meses

No estoy seguro de que esta sea la forma correcta de resolver el problema. Jquery 1.12.4 ya no se mantiene, razón por la cual WordPress aplicó algunos parches de seguridad de versiones posteriores y comenzó a entregarlo como «1.12.4-wp». Eliminación de cambios «-wp» en una versión independiente de Google CDN. Lea aquí: https://core.trac.wordpress.org/ticket/47342#comment:3

(@hailita)

Hace 1 año, 5 meses

Es verdad. Como finalmente se dijo, ¿quizás deberíamos esperar a la última jquery en WP v5.4 / 5.5 para resolver este problema? En cuanto al uso de jQuery externo, no estoy seguro de dónde podríamos obtener el parche wp personalizado.

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *