Pregunta sobre Installing WordPress de Wordpress:

problema con mySQL 8 en IIS Windows Server 2016

Un usuario pregunt贸 馃憞

驴Alguien ha aprendido a configurar WordPress usando mySQL 8.oi Windows Server? Todas las instrucciones aqu铆 son solo para Linux. Descargu茅 y complet茅 una instalaci贸n manual de WP 5 y mySQL 8. pero mi instalaci贸n no reconoce la contrase帽a.

este es el error

Advertencia: mysqli_real_connect (): el servidor solicit贸 un m茅todo de autenticaci贸n desconocido para el cliente [caching_sha2_password] en C: inetpub wwwroot xxxxxxxx wp-include wp-db.php online 1633 Advertencia: mysqli_real_connect (): (HY000 / 2054): El servidor solicit贸 un m茅todo de autenticaci贸n desconocido para el cliente en C : inetpub wwwroot quickbookusa wp-include wp-db.php online 1633 El servidor solicit贸 un m茅todo de autenticaci贸n desconocido para el cliente

Este tema fue modificado hace un a帽o por. Este tema fue modificado hace un a帽o por. Este tema fue modificado hace un a帽o por.

(@sterndata)

Moderador del foro y voluntario del equipo de apoyo

hace 1 a帽o

Mira https://www.akamenskiy.com/fix-wordpress-database-connection-mysql-8/

(@autotutorial)

hace 1 a帽o

Para conectarse al servidor despu茅s de la inicializaci贸n del directorio de datos, debe utilizar un cliente o conector que admita caching_sha2_password. Si puede hacer esto pero prefiere que la cuenta not_user_root use mysql_native_password despu茅s de la instalaci贸n, instale MySQL e inicie el directorio de datos como lo har铆a normalmente. Luego con茅ctese al servidor como root y use ALTER USER de la siguiente manera para cambiar el plugin de autenticaci贸n de la cuenta y la contrase帽a:

ALTER USER 'not_user_root'@'localhost'
  IDENTIFIED WITH mysql_native_password
  BY 'password';

Si el cliente o conector que usa a煤n no es compatible con caching_sha2_password, puede usar un procedimiento de modificaci贸n del directorio de inicio de datos que combine la cuenta not_user_root con mysql_native_password una vez creada la cuenta. Para hacer esto, use cualquiera de estas t茅cnicas:

Proporcione una opci贸n 鈥揹efault-validification-plugin = mysql_native_password combinada con 鈥搃nitialize o 鈥搃nitialize-insecure.

Establezca default_authentication_plugin en mysql_native_password en el archivo de opciones, y asigne un nombre a ese archivo de opciones utilizando la opci贸n 鈥揹efaults-file junto con 鈥搃nitialize o 鈥搃nitialize-insecure. (En este caso, si contin煤a utilizando ese archivo de opciones para el inicio posterior del servidor, se crear谩n nuevas cuentas con mysql_native_password en lugar de caching_sha2_password a menos que elimine la configuraci贸n default_authentication_plugin del archivo de opciones).

https://dev.mysql.com/doc/refman/8.0/en/upgrading-from-previous-series.html#upgrade-caching-sha2-password

(WordPress 5.3 es compatible con php 7.4) Desde php 7.4 Controlador nativo de MYSQL (MYSQLND) debe ser compatible con el conector, con caching_sha2_password tambi茅n
https://github.com/php/php-src/commit/4f06e67ad2201390ed35a9ea6288a00c0b04782b#commitcomment-32356655

Para el plugin PAM https://wordpress.org/support/topic/mariadb-authentication-does-not-work-when-mariadb-is-integrated-with-pamldap/

Esta respuesta fue modificada hace 1 a帽o por.

(@sterndata)

Moderador del foro y voluntario del equipo de apoyo

hace 1 a帽o

@autotutorial 隆Agradable! Lo marcar茅 como favorito.

(@autotutorial)

hace 1 a帽o

Publicar actualizaci贸n Hola @sterndata.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *