Pregunta sobre LiteSpeed Cache de Wordpress:

Problema de visualización de miniaturas

Un usuario preguntó 👇

¡Hola!

¡He estado usando este plugin por un tiempo y ustedes hicieron un gran trabajo con él! Funciona de maravilla.

Hay un problema que encontré.

Las miniaturas no se muestran al azar y difieren de un navegador a otro. Creo que este es un problema de caché, ya que no encontré este problema mientras usaba Wp Total Cache y solo he sido visible desde que cambié a Litespeed Cache.

He probado diferentes PC y diferentes navegadores y no he mostrado miniaturas aleatorias.

Ejemplo 1: cómo se muestran las mismas miniaturas en Google Chrome y la miniatura aleatoria de Firefox no se muestra en Google Chrome
https://i.imgur.com/tMHOPto.jpg
La misma miniatura se muestra perfectamente en Firefox
https://i.imgur.com/Bn6p5Y7.jpg

Ej 2: otra miniatura que se muestra esta vez en Google Chrome
https://i.imgur.com/Hs2DX6Q.jpg
pero no se muestra en Firefox en su lugar
https://i.imgur.com/7HCySLY.jpg

¿Qué se puede hacer? = /

(@stanleylitespeed)

Hace 1 año, 10 meses

Hola @forprofile, ¿podrías Numero de reporte y háganos saber las imágenes rotas en qué página?

Lanzador de hilos

(@forprofile)

Hace 1 año, 10 meses

¡Hola! Intenté obtener el número de informe, pero es un error. 🙁
https://i.imgur.com/n2hEN4d.jpg

(@hailita)

Hace 1 año, 10 meses

Actualice su plugin a la última versión. Gracias.

Lanzador de hilos

(@forprofile)

Hace 1 año, 10 meses

¡Hola! ¡Gracias por su respuesta! Actualicé el plugin a la última versión.

Número de informe: EVBFDRCK

(@stanleylitespeed)

Hace 1 año, 10 meses

Descubrimos que algunas de las miniaturas no se generaban correctamente, por ejemplo:

/wp-content/uploads/2019/04/red-velvet-the-red-summer-review-300x168.jpg
/wp-content/uploads/2019/04/red-velvet-the-red-summer-review-285x160.jpg
/wp-content/uploads/2019/04/red-velvet-the-red-summer-review-900x506.jpg

por lo tanto, cuando está utilizando un navegador diferente, puede mostrar el roto que crea el problema de la miniatura.

¿Sé si tiene algún plugin instalado para la generación de miniaturas?

Lanzador de hilos

(@forprofile)

Hace 1 año, 10 meses

¡Gracias por el rompecabezas!

Teníamos Smush instalado para optimizar la imagen y cuando regeneramos las miniaturas mientras lo usábamos. Sin embargo, no notamos nada extraño después de eso. Pero ese plugin ha estado desactivado durante mucho tiempo. ¿Podría causar un nuevo problema de miniaturas incluso si está desactivado?

(@stanleylitespeed)

Hace 1 año, 10 meses

¿Ocurrió este problema después de desactivar el plugin? Y encontré que la miniatura de la publicación funciona normalmente ahora.

Lanzador de hilos

(@forprofile)

Hace 1 año, 10 meses

Sí, ese plugin se ha desactivado desde principios de 2018. En ese entonces estábamos en Apache, Centos, con caché con Wp Total Cache.

Las miniaturas generalmente se mostraban hasta febrero de 2019, cuando nos mudamos a Litespeed con caché de Litespeed.

Pero lo extraño es que las miniaturas se muestran de forma diferente de un navegador a otro. Cuando una miniatura está en un navegador, se muestra que una miniatura está ‘rota’ en un navegador diferente, la misma miniatura se muestra funcionando perfectamente.

Desafortunadamente, el problema sigue ahí. 🙁 Cómo mostrar miniaturas en Google Chrome: https://i.imgur.com/Hi6FKmg.jpg
Cómo se muestran las miniaturas en FireFox: https://i.imgur.com/bRV6WlL.jpg

Además, notamos que si el servidor está inactivo durante un segundo, ese error se mostrará durante unas horas. Los visitantes verán la página en la que estaban mientras se produjo el error, interrumpida durante muchas horas y, por lo general, pueden navegar por el resto del sitio.

(@stanleylitespeed)

Hace 1 año, 10 meses

¿Podría revisar su registro de errores de PHP para ver si hubo algún error relacionado con esos archivos de imagen o el problema del tiempo de espera? Si no está seguro, puede enviarnos el registro de errores para su verificación. Gracias.

Y para We noticed that if the server is down for a second, that error will be shown for a few hours ¿Qué error viste? ¿Podrías describirlo más?

Lanzador de hilos

(@forprofile)

Hace 1 año, 10 meses

¡Gracias por su respuesta!

También notamos que cuando hace clic en una imagen en miniatura que no se muestra correctamente e intenta abrir esa imagen en una nueva pestaña, la URL de la imagen parece correcta pero se enfoca en una URL de página aleatoria en lugar de una URL de imagen.
https://i.imgur.com/siQXHu7.png
https://i.imgur.com/794iJWo.jpg
Esto sucede aleatoriamente en un navegador mientras funciona correctamente en un navegador diferente. Actúa muy extraño. 🙁

Aquí está el registro de errores: https://mega.nz/#!xUZTyQTa!nr0824fDBoNoN7mpZK0oAUe8hVWe-kUzKr7Ek_LN-GQ

El error del que estaba hablando es el error 502 típico que se muestra cuando el servidor deja de funcionar: https://i.imgur.com/HjnoZnQ.png
Si el servidor se cae durante unos 2 segundos y un usuario está navegando por una determinada página en ese momento, ese error se alojará automáticamente y se le servirá al usuario durante unas horas (normalmente hasta que ocultemos todo el caché manualmente).

(@stanleylitespeed)

Hace 1 año, 10 meses

Hola podrias por favor únete a nuestro canal de Slack o ingrese un boleto aquí por ayudarnos a reproducir el error, ¡gracias!

Lanzador de hilos

(@forprofile)

Hace 1 año, 9 meses

Perdón por la respuesta tardía, reinstalamos Ubuntu y Litespeed, desactivamos los plugins no deseados y cargamos las miniaturas con problemas. ¡Ahora todo parece volver a la normalidad! 😀

¡Gracias por tu orientación!

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *