Pregunta sobre LiteSpeed Cache de Wordpress:

Problemas con las imágenes y Amazon Cloudfront

Un usuario preguntó 👇

Tengo un sitio que ejecuta Litespeed 2.9.8.7 donde habilité Amazon Cloudfront CDN. Solía ​​estar bien durante varios meses, pero recientemente noté que había problemas serios con las imágenes: a veces, una imagen se reemplaza por una imagen al azar y, a menudo, no se cargan. Intenté resolver esto habilitando / deshabilitando el CDN, pero no funciona. La única forma de mostrar correctamente la visualización del sitio es deshabilitar Litespeed en absoluto. Ahora recibo alertas de Google Search Console sobre problemas de usabilidad. ¿Me puedes ayudar, por favor?

Número de informe: BZVCKZQX

Este tema fue modificado hace 1 año, 2 meses por.

(@stanleylitespeed)

Hace 1 año, 1 mes

Hola @ r3born, dijiste Tried to troubleshoot this by enabling/disabling the CDNParece que Cloudfront almacena la imagen en caché correctamente, por lo general, nuestro plugin no cambiará la URL de sus imágenes. ¿Podría verificar que nuestro plugin afectó la caché de Cloudfront?

(@ r3born)

Hace 1 año, 1 mes

Hola, ¿cómo puedo verificar esto?

(@qtwrk)

Hace 1 año, 1 mes

Hola,

Traté de resolver esto habilitando / deshabilitando la CDN, pero no funciona

¿Quiere decir que, incluso con un CDN desactivado, la imagen todavía se carga con un enlace incorrecto?

Si es así, ¿podría decir cuál era la URL original y la URL que se indicó incorrectamente?

Todo lo mejor,

(@ r3born)

Hace 1 año, 1 mes

Con CDN desactivado, la imagen se cargó correctamente, PERO hay muchas imágenes en la página que arrojaron un error 404.

(@qtwrk)

Hace 1 año, 1 mes

Hola,

¿Podría proporcionar una URL de muestra de estas imágenes 404 y cuál es la URL correcta para LSCWP?

¿También puede confirmar que después de deshabilitar / habilitar CDN, ha borrado todo?

porque puede que no surta efecto a menos que haya borrado un caché.

(@ r3born)

Hace 1 año, 1 mes

Limpié el caché más de 10 veces.

Aquí hay un ejemplo:
https://vintagewatchinc.com/wp-content/uploads/2019/08/generation-2-shield-338 post450.jpg
En esta página: https://vintagewatchinc.com/ussr/vostok/nvch-30/

Ahora la CDN está deshabilitada. Los problemas que encuentro son: – carga lenta de imágenes en general – imágenes que arrojan errores 404 al azar (a veces la página actualiza la página, pero esta no es una buena experiencia de usuario)

(@ r3born)

Hace 1 año, 1 mes

Obviamente, hacer clic en el enlace de la imagen funciona directamente, la imagen está en la carpeta de carga.

(@ r3born)

Hace 1 año, 1 mes

Solo realicé algunas pruebas de velocidad con webpagetest.org, algo anda muy mal: – Con Litespeed activado (CDN desactivado), el tiempo de carga es de 23 segundos – Con Litespeed completamente desactivado, el tiempo es de 10 segundos -Tiempo de carga.

(@qtwrk)

Hace 1 año, 1 mes

Hola,

Entonces en esta página https://vintagewatchinc.com/ussr/vostok/nvch-30/ , con imagen https://vintagewatchinc.com/wp-content/uploads/2019/08/generation-2-shield-338 post450.jpg , y esta es la URL de imagen correcta.

¿Tiene un registro de qué URL de imagen incorrecta está causando el error 404?

con la URL 404, podríamos estar adivinando qué podría estar causándolo o qué podría estar mal.

También habilite avanzado por favor registro de depuración a tu IP

luego, al acceder a la página en cuestión, registrará todas las reescrituras de URL de CDN en un registro de depuración, desde el cual podría decirme por qué o qué sucedió.

Para webpagetest, ¿podría enviar el resultado de la prueba con LSCWP y sin él? Revisaremos el informe y veremos si podemos decir por qué se ralentiza tanto.

Todo lo mejor,

(@ r3born)

Hace 1 año, 1 mes

Estos son los resultados de la web:

Litespeed habilitado:
https://www.webpagetest.org/result/191021_SM_83e3830a2043489332565eb411d79066/

Litespeed deshabilitado:
https://www.webpagetest.org/result/191021_A4_3fff6ed9ba0bdf4e21a234ad3869fb17/

¿Cómo puedo enviarle el registro de depuración?

(@stanleylitespeed)

Hace 1 año, 1 mes

Hola @ r3born, habilitar Litespeed es una carga nueva en la página, por lo que la velocidad más lenta se deshabilitará porque nuestro plugin está ejecutando alguna función de optimización. Si desea probar el resultado almacenado en caché, pre-cachee la página.

Por ejemplo, este es el resultado almacenado en caché: https://www.webpagetest.org/result/191022_H1_cc99165f2f42f3bba7d5747be25cb743/

Además, obtengo la imagen (generation-2-shield-338×450.jpg) cargado en ambas versiones de la página web y ahora no puedo reproducir el problema en su sitio.

Puede agregarle el registro de depuración https://pastiebin.com y envíanos el enlace aquí.

(@lclarke)

Hace 1 año, 1 mes

Hola @ r3born,

¿Aún necesitas ayuda con esto? Si es así, proporcione el registro de depuración, según se solicite.

Voy a marcar «Resolver» este tema ahora, pero estaré encantado de volver a abrirlo si volvemos a tener noticias tuyas.

¡Gracias!

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *