Pregunta sobre Elementor Website Builder de Wordpress:

Problemas de localhost después de actualizar OSX High Sierra

Un usuario preguntó 👇

Actualicé mi Mac de Sierra a High Sierra (no Mojave, ¡estoy un poco atrasado!). Después de la actualización, no tuve más que problemas con mis copias locales de los sitios de Elementor. Normalmente trato de editar el servidor localhost, antes de cambiar la configuración en vivo.

Solo pude editar Elementor en la página de inicio, cualquier otra página advierte:

«Lo siento, no se pudo cargar la vista previa, pero algo salió mal».

Además, si visité el sitio en localhost y usé el navegador para intentar ir a cualquier página que no fuera la página de inicio, encontré «URL / water_WP / contact / required / required Este servidor.

Intenté deshabilitar todos los plugins, probé un tema de WP estándar (estoy usando Ocean plus Ocean Child en los sitios reales), lo intenté de manera más segura. No ayuda en absoluto.

Lo que encontré fue que tuve que configurar mis enlaces permanentes en «simple», ¡entonces funcionaría!

Los sitios locales tienen un archivo .htaccess de escritura.

Supongo que algo cambió en mi archivo php.ini durante la actualización del sistema operativo, pero mis límites de memoria expandida aún existen antes de la actualización.

Algunas ideas ??

Gracias, tom

== Entorno del servidor == Sistema operativo: Darwin Software: Apache / 2.4.33 (Unix) PHP / 7.1.1 Versión de MySQL: MySQL Community Server (GPL) v5.7.17 Versión de PHP: 7.1.1 PHP Max Input Vars: 1000 PHP Tamaño máximo de publicación: 768M GD Instalado: Sí ZIP instalado: Sí Permisos de escritura: Todos los derechos Biblioteca Elementor: Adjunta

== Entorno de WordPress == Versión: 5.0.3 URL del sitio: http: // localhost / wate_WP
URL de inicio: http: // localhost / water_WP
WP Multisitio: No Carga máxima: 768 MB Límite de memoria: 256 M Estructura de enlace permanente: /% año% /% fino%

(@ tomf2468)

Hace 1 año, 9 meses

Lo descubrí 🙂

Estaba demasiado arreglado en el archivo php.ini, el «error» estaba en el archivo apache.config. ¡Fue reemplazado durante la actualización!

En un servidor Mac local, debe cambiar el archivo apache.config, permitir que se carguen los archivos «AllowOverride» y «mod_rewrite.so» o .htaccess. Si los archivos .htaccess no funcionan, WordPress no puede usar nombres simples para las páginas.

¡He hecho esto antes! ¿Por qué me tomó dos días recordarlo?

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *