Pregunta sobre Arreglando WordPress de Wordpress:

«Se requiere actualización de PHP» no desaparece

Un usuario preguntó 👇

Tengo un sitio de WordPress alojado en HostGator. Cuando recibí la advertencia «Se requiere actualización de PHP» en el Panel, actualicé el alojamiento a PHP 7.0.25 y phpinfo.php muestra que estamos ejecutando 7.0.25. Pero la advertencia «Actualización de PHP requerida» no funcionó. Tengo instalado Backup Buddy, y cuando reviso esas herramientas de servidor, me advierten que el sitio está ejecutando 5.6. Eliminé el caché (incluso desactivé el programa de almacenamiento en caché) y confirmé con HostGator que el sitio se está ejecutando 7.0.25, pero algo está claramente mal en alguna parte. Agradeceríamos cualquier idea o sugerencia sobre lo que se debe verificar. Busqué pero no pude enumerar un problema similar en los foros.

(@macmanx)

Moderador voluntario

Hace 1 año, 1 mes

¿Tiene algún archivo .htaccess en el directorio del sitio que pueda contener una directiva que lo obligue a usar una versión específica (y anterior) de PHP?

(@ 2 gatos)

Hace 1 año, 1 mes

Sí, lo verifiqué y no se refiere a la versión de PHP. ¿Podría ser un archivo php.ini? Quiero contactar a HostGator sobre eso. ¡Gracias!

(@macmanx)

Moderador voluntario

Hace 1 año, 1 mes

Espera, creo que veo el problema.

La rama de PHP 7.0 ya no recibe actualizaciones de seguridad: https://www.php.net/supported-versions.php

¿Puede actualizar a PHP 7.3 o 7.2?

(@ 2 gatos)

Hace 1 año, 1 mes

Gracias James. Lo comprobaré el lunes cuando regrese, pero creo que aún no estaban disponibles en HostGator. ¡Aprecio su rápida respuesta!

(@ 2 gatos)

Hace 1 año, 1 mes

Gracias de nuevo por su ayuda, solo quería actualizar esto: rastreamos el problema en los archivos htaccess dentro de los directorios de WordPress, no estoy seguro de cómo obtuvieron la dirección de PHP, es posible que se haya instalado ellos con una versión anterior del programa de seguridad que hicimos en ejecución. De todos modos, borramos esas líneas y ahora estamos ejecutando PHP 7.3. ¡Gracias!

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *