Pregunta sobre Arreglando WordPress de Wordpress:

Servidor Hangup

Un usuario preguntó 👇

Hola,

Quiero iniciar sesión en mi / wp-admin, pero me dirige al servidor Hangup.

Al mirar los registros de errores, veo este error.

[Fri Oct 11 14:17:33 2019] [error] [client 64.209.128.50] Advertencia de PHP: require_once (/var/www/vhosts/hamaward.com/httpdocs/wp-admin/includes/plugin.php): no se pudo abrir la secuencia: no existe ese archivo o directorio en / var / www / vhosts /hamboneaward.com / httpdocs / wp-content / plugins / gravityforms / common.php en línea 4110
[Fri Oct 11 14:17:33 2019] [error] [client 64.209.128.50] Error fatal de PHP: require_once (): No se pudo abrir falló ‘/var/www/vhosts/hamaward.com/httpdocs/wp-admin/includes/plugin.php’ (include_path = ‘:’) en / var / www / vhosts /hamaward.com/httpdocs/wp-content/plugins/gravityforms/common.php en línea 4110

online 4110: función estática pública is_logging_plugin_active () {if (! function_exists (‘is_plugin_active’)) {require_once ABSPATH. ‘wp-admin / include / plugin.php’; }

// En algunos casos, is_plugin_active () devuelve verdadero cuando un archivo de plugin se elimina manualmente. enviar is_plugin_active (‘gravityformslogging / logging.php’) && file_exists (trailingslashit (WP_PLUGIN_DIR). ‘gravityformslogging / logging.php’);

}

¿Alguien sabe cómo solucionar este problema?

(@tp)

Hace 1 año, 3 meses

Intente restablecer sus plugins manualmente (no se requiere acceso al Panel). Si eso resuelve el problema, reactive cada uno individualmente hasta que encuentre la causa.

Si esto no resuelve el problema, acceda a su servidor a través de SFTP o FTP, o administrador de archivos en el panel de control de su cuenta de alojamiento, navegue hasta /wp-content/themes/ y cambie el nombre de un directorio para un tema actualmente activo. Esto obligará al tema predeterminado a activar un problema específico del tema y, con suerte, puede interferir como un plugin).

(@ yoonj4)

Hace 1 año, 3 meses

Probé ambas soluciones, pero ahora «Esta página no funciona» HTTP ERROR 500. No pude acceder a ninguna parte del sitio web cuando cambié el nombre y los temas de la carpeta del plugin.

(@sterndata)

Moderador del foro y voluntario del equipo de apoyo

Hace 1 año, 3 meses

Parece que faltan uno o más archivos de formas de gravedad. Descargue una copia nueva, descomprima localmente y cárguela en el directorio correcto en wp-content / plugins.

(@ yoonj4)

Hace 1 año, 3 meses

Así que pude acceder al panel de wp-admin de alguna manera, pero lo extraño es que cuando desactivo «Gravity-Forms-ACF-Field», obtengo un error 500 tanto para el sitio web como para el panel de administración. Cuando desactivo «gravityforms», aparece un error de bloqueo del servidor en el panel wp-admin, pero el sitio web parece estar funcionando.

Hemos subcontratado nuestro tema y estamos ejecutando WordPress 4.9.6

Intentamos actualizar el plugin de formularios de gravedad con una actualización más reciente, pero todavía recibimos la misma pregunta.

(@sterndata)

Moderador del foro y voluntario del equipo de apoyo

Hace 1 año, 3 meses

Estás utilizando un tema / plugin comercial, así que usa su canal de soporte oficial. Creemos que son las mejores personas que respaldan sus productos.

https://www.gravityforms.com/support/

Los productos comerciales no son compatibles con estos foros.

Por cierto, 4.9.6? WP está en 5.2.3 y 5.3 estará disponible en unas pocas semanas.

(@ yoonj4)

Hace 1 año, 3 meses

Sí, Steven, estamos usando 4.9.6. No lo actualizamos porque pensamos que crearía problemas de incompatibilidad con el tema personalizado que subcontratamos hace 3 años.

(@tp)

Hace 1 año, 3 meses

FYI: WordPress 5.2.3 es una versión de seguridad y mantenimiento. Estos errores afectan a las versiones 5.2.2 y anteriores de WordPress; están corregidos por la versión 5.2.3.

(@ yoonj4)

Hace 1 año, 3 meses

Gracias por tu respuesta @tp. Lo que pasa es que no puedo ir a la página de actualizaciones en wp-admin. Me da un error 502 cuando hago clic para ir a la página de actualizaciones o cuando hago clic en una actualización en el Panel.

(@tp)

Hace 1 año, 3 meses

502 Bad Gateway es probablemente un error del servidor. Intente ponerse en contacto con su proveedor de alojamiento.

Mientras tanto, intente: – borrar sus cookies, caché – varios navegadores

Ver también: https://www.wpbeginner.com/common-wordpress-errors-and-how-to-fix-them/#502badgateway

(@jnashhawkins)

Hace 1 año, 3 meses

Entonces es extraño. El sitio parece estar intentando utilizar dos directorios diferentes …

hamboneawards.com y hamawards.com o algo así … ¿es una copia / pegado del error real?

¿Hay dos directorios diferentes en ‘/ var / www / vhosts /’? ¿Podrías mirar cosas y ver? Es posible que incluso desee mirar los enlaces simbólicos y luego la base de datos si ve un patrón con este problema.

(@jnashhawkins)

Hace 1 año, 3 meses

Puedo ver dónde los plugins aún están obsoletos, pero también creo que un tema genérico podría eliminarlo de ese «error» de formas de gravedad que puede estar desencadenando algo o tal vez ese tema también está rompiendo cosas.

Cambiar el tema durante unos minutos es probablemente una buena idea, ya que a altas horas de la noche probablemente no perjudicará a los clientes.

Estoy pensando en ese panel de control de Plesk y en la ayuda que ofrece … No sé mucho sobre Plesk.

– Una vez que tenga esto ordenado, creo que una actualización a 4.9.11 (¿o todavía es 4.9.10?) Estaría en orden. Querrá ejecutar PHP 7.3 si puede … En PHP 7.2 o 7.3 debería poder ejecutar 5.2.X y aprovechar las mejores y más seguras versiones. ¡Tu elección entonces!

Si desea omitir el editor de bloques (Gutenberg), instale el plugin del editor clásico y use la configuración para separar ambos editores. Puedes acceder a ese nuevo editor de esa manera.

(@ yoonj4)

Hace 1 año, 3 meses

@jnashhawkins Gracias por sus sugerencias. Para los mensajes de error, no fue copiar / pegar.

Iré, seguiré tu sugerencia y la actualizaré tan pronto como pueda. ¡Gracias por tu ayuda!

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *