Pregunta sobre WordPress Infinite Scroll - Ajax Load More de Wordpress:

TypeError: no se puede leer la propiedad ‘dividida’ no especificada

Un usuario preguntó 👇

Hola, La consola de desarrollo muestra el siguiente error. ¿Que puedo hacer? ¡Gracias por tu ayuda!

ajax-load-more.min.js? ver = 3.3.1: 1 Error TypeError: la propiedad ‘split’ no especificada en el nuevo t.ajaxloadmore (ajax-load-more.min.js? ver = 3.3.1: 1) no puede ser leída por ajax-load-more. min .js? Ver = 3.3.1: 1 en Array.forEach () en ajax-load-more.min.js? Ver = 3.3.1: 1 ag ajax- load-more.min.js? ver = 3.3.1: 1 t.ajaxloadmore @ ajax-load-more.min.js? ver = 3.3.1: 1 (sin nombre) @ ajax-load-more.min.js? ver = 3.3.1: 1 (sin nombre) @ ajax-load-more.min.js? ver = 3.3.1: 1 (sin nombre) @ ajax-load-more.min.js? ver = 3.3.1: 1

dentro de index.php


<?php if ( have_posts() ) :
 $catquery = new WP_Query( 'cat=12' );
 while ( $catquery->have_posts() ) : $catquery->the_post(); ?>
    <div id="post-<?php the_ID(); ?>" <?php post_class('masonry-post'); ?> >
						
<div class="post-inner">
  <div class="thumbnails">
    <div class="thumbnail"><a href="<?php the_permalink(); ?>"><?php the_post_thumbnail('full'); ?></a>
    </div>
  </div>
							
<h2><a class="permalink more" href="<?php the_permalink(); ?>">
  <?php echo str_replace(' | ', '<br />', wp_kses_post( get_the_title() )); ?></a>
</h2>
<div class="excerpt"><p>
    <?php echo wp_trim_words( get_the_excerpt(), 20, '  ' );?>
       <a class="permalink more" href="<?php the_permalink(); ?>">more...</a>					

    </p>
</div>
</div>
</div>
				
<?php endwhile;?>
</div><!-- #grid -->
</div><!-- .ajax-load-more-wrap -->
<?php wp_reset_postdata();
echo do_shortcode('[ajax_load_more 
			container_type="div" 
			post_type="post" 
			category="works" 
			category__not_in="11,1" 
			scroll_distance="0" 
			posts_per_page="10" 
			images_loaded="true" 
			transition="masonry" 
			masonry_selector=".masonry-post"]');
/*the_posts_navigation();*/ endif; ?>

(@dcooney)

hace 3 años

Hola @kumikok; No estoy realmente seguro de qué probaría esto. ¿Se pueden compartir un enlace y su plantilla repetidora?

Salud,

(@kumikok)

hace 3 años

Trabajo con el host local (MAMP) y no sé cómo compartir el enlace … Mi plantilla es un repetidor

<div id="post-<?php the_ID(); ?>" <?php post_class('masonry-post'); ?> >
   <div class="post-inner">
     <div class="thumbnails">
	<div class="thumbnail"><a href="<?php the_permalink(); ?>">
          <?php the_post_thumbnail('full'); ?></a></div>
     </div>
     <h2><a class="permalink more" href="<?php the_permalink(); ?>"><?php echo str_replace(' | ', '<br />', wp_kses_post( get_the_title() )); ?></a>
     </h2>
     <div class="excerpt"><p>
	<?php echo wp_trim_words( get_the_excerpt(), 20, '  ' ); ?>
          <a class="permalink more" href="<?php the_permalink(); ?>">more...</a>
     </p></div>
</div>
</div>

(@dcooney)

hace 3 años

Eso se ve genial. ¿Qué versión de jquery estás ejecutando?

(@kumikok)

hace 3 años

Estoy usando un jquery que está incluido en wordpress, en cola en function.php con wp_enqueue_script (‘jquery’);

(@dcooney)

hace 3 años

Bien gracias.

En la consola, puede mirar Red> y luego encontrar la aplicación admin-ajax y ver la pestaña Respuesta. Eso podría mostrarle un error de php o algo para verificar el problema.

Desafortunadamente, al no poder ver un enlace, no puedo brindar ninguna ayuda adicional.

(@kumikok)

hace 3 años

jquery.js, ver = 1.12.4 y jquery-migrate.min.js, ver = 1.4.1

(@kumikok)

hace 3 años

Tengo mi tema en vivo durante 7 días aquí
http://ugly-rat.w5.poopy.life/

Subí mi tema, instalé un plugin de ALM y aparece el mismo error. ¿Puedes ver lo que está pasando?

Gracias por tu ayuda

(@dcooney)

hace 3 años

Bien gracias. ¿Puedes intentar ejecutar ALM con el siguiente atajo? [ajax_load_more]

No estoy seguro de cuál es el problema, pero tal vez sea la mampostería.

(@kumikok)

hace 3 años

Desafortunadamente, el error persiste …

(@dcooney)

hace 3 años

Bien gracias. La última idea sería intentar actualizar a la versión 2.X de jquery.

(@kumikok)

hace 3 años

Mismo error que jQuery 2.2.4… No entiendo…

(@dcooney)

hace 3 años

No estoy seguro, todo se ve muy bien. Estoy feliz de iniciar sesión y verlo, pero deberá abrir un ticket de soporte aquí.
https://connekthq.com/plugins/ajax-load-more/support/

(@kumikok)

hace 3 años

Te envío una solicitud a través del formulario de contacto. Espero que puedas encontrar algo.

Gracias

(@dcooney)

hace 3 años

El problema se resolvió. Se agregó un problema manualmente .alm-masonry-wrap y .alm-listing divs en la página que causan problemas, por ejemplo, con ALM.

(@kumikok)

hace 3 años

¡¡Gracias!! Es un malentendido tan estúpido …

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *