Pregunta sobre WooCommerce de Wordpress:

ventana emergente que se abre cuando ingreso un cambio de precio

Un usuario preguntó 👇

Hola a todos, Desde los últimos meses, cuando puse un cambio de precio en el folleto del producto, aparece una ventana emergente con «¿guardar el cambio antes de cambiar de página?» y en «evitar que esta página abra más cuadros de diálogo». ¿Cuál es la causa y cómo evito que vuelva a aparecer? Gracias

(@corsonr)

Ingeniero Automático de Felicidad

Hace 5 meses, 1 semana

Hola,

En la mayoría de los casos, un problema como este puede ocurrir si hay un conflicto con un plugin que cambia el orden y la prioridad de los scripts que se ejecutan. Tenga en cuenta que el tema también puede estar involucrado.

No he podido replicar el problema en una instalación nueva, por lo que sospecho que el problema puede estar relacionado con un conflicto de compatibilidad con uno de sus plugins o temas activos.

Para probar si es así, puede seguir los pasos a continuación:

1. Asegúrese de que todos sus plugins estén actualizados a las últimas versiones de ellos y vea si el problema persiste. 2. Instale y active el [Health Check & Troubleshooting](https://en-au.wordpress.org/plugins/health-check/) plugin. Este plugin le permite solucionar problemas de su sitio web sin afectar a los clientes que puedan estar navegando en su sitio web. 3. Vaya a Tools > Health Check > Troubleshooting tab > Enable troubleshooting mode. 4. Cuando se actualice la página, en la parte superior de la página, haga clic en la flecha de alternancia junto a `Temas disponibles y asegúrese de que el tema predeterminado de WordPress esté activado. (Por ejemplo, veinte – diecinueve o [Storefront](https://woocommerce.com/storefront/?aff=10486&cid=1131038)). 5. Ir a Plugins. You'll see all plugins have been deactivated. Please activate onlyEl núcleo de WooCommerce` y los plugins que desea probar. 6. Si el paso 5 soluciona el problema, reactive todos los plugins a la vez y luego vea si el problema vuelve a aparecer. Esto nos dirá qué plugin es contradictorio. 7. Luego puede hacer clic en Disable Troubleshooting Mode en la parte superior del sitio web para volver a la normalidad.

Alternativamente, puede optar por hacer esto manualmente de acuerdo con los siguientes documentos:

https://docs.woocommerce.com/document/how-to-test-for-conflicts/

Con la prueba anterior, podremos averiguar si el problema está relacionado con un conflicto de compatibilidad (porque no podemos replicarlo en una instalación nueva) y obtener más información sobre los posibles errores generados durante este proceso.

Si no desea realizar los pasos anteriores en su sitio en vivo, puede clonar su sitio en un entorno de escenario, donde puede probar sin impresionar a sus usuarios. Si su anfitrión no proporciona instalaciones para el escenario, una forma sencilla de hacerlo es utilizar el plugin gratuito WP Staging:

– https://wordpress.org/plugins/wp-staging/

Háganos saber cómo le va y si tiene alguna información adicional para compartir con nosotros. Estaremos encantados de ayudar.

(@ wilky76)

hace 5 meses

Lo siento, respondí otra pregunta. No voy a comprobar …

Esta respuesta fue modificada hace 5 meses por.

(@ wilky76)

hace 5 meses

así que estoy haciendo algunos experimentos para actualizar todo: la versión de php es 5.6. No actualizo Woocommerce a menos que actualice php. Si actualizo a 7.3 puedo actualizar woocommerce pero hay algunos problemas: las marcas no se desplazan, todos los productos se deslizan en una columna, y luego en la parte superior aparecen estas líneas:

Advertencia: el interruptor «continuar» de destino es equivalente a «romper». ¿Tenía la intención de utilizar «seguir 2»? en /home/civicoshmj/wwww/civico29shop.it/wp-content/plugins/revslider/includes/operations.class.php en línea 5515

Advertencia: el interruptor de «continuar» dirigido es equivalente a «romper». ¿Tenía la intención de utilizar «continuar 2»? en /home/civicoshmj/wwww/civico29shop.it/wp-content/plugins/revslider/includes/operations.class.php en línea 5523

Advertencia: el interruptor de «continuar» dirigido es equivalente a «romper». ¿Tenía la intención de utilizar «continuar 2»? en /home/civicoshmj/wwww/civico29shop.it/wp-content/plugins/revslider/includes/output.class.php en línea 7411

Intenté restaurar la copia de seguridad de la base de datos y restaurar el php a la versión 5.6 pero los errores aún existen. ahora estoy tratando de restaurar los archivos para ver si el sitio vuelve a funcionar porque solo la carpeta del plugin recarga el sitio desde un error crítico. ¿Cómo puedo actualizar todo sin problemas? Creo que tal vez entonces el problema de los cambios de producto también podría resolverse. Gracias

(@ wilky76)

hace 5 meses

aquí está el error que ahora me lleva a recargar la carpeta del plugin que contiene la versión anterior de woocommerce:

Advertencia: require_once (classes / ActionScheduler_Versions.php): no se pudo abrir la transmisión: no existe ese archivo o directorio en /home/civicoshmj/www/civico29shop.it/wp-content/plugins/woocommerce/includes/libraries/action -scheduler / action -scheduler.php en línea 31

Error fatal: require_once (): no se pudo abrir ‘classes / ActionScheduler_Versions.php’ (include_path = ‘.: / Usr / local / php5.6 / lib / php’) en /home/civicoshmj/www/civico29shop.it/ wp -content / plugins / woocommerce / includes / libraries / action-planificador / action-planificador.php en línea 31

Ha ocurrido un error crítico en su sitio web.

¿Solucionó tu problema??

1 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *