Pregunta sobre WooCommerce Multilingual - run WooCommerce with WPML de Wordpress:

wc-ajax regresando 404

Un usuario pregunt贸 馃憞

Hola, despu茅s de mover el escenario a un sitio en vivo (Duplicador), lo estoy obteniendo 404 responde desde

wc-ajax=get_refreshed_fragments

y
wc-ajax=update_order_review

Si el plugin WooCommerce Multilingual est谩 desactivado, 404 desaparecer谩.

驴Es un error de plugin o d贸nde podr铆a ser un problema?

Gracias

Este tema fue modificado hace 2 a帽os, 9 meses por. Este tema fue modificado hace 2 a帽os, 9 meses por.

(@simonph)

Hace 2 a帽os, 9 meses

Tengo el mismo problema. WP All-in-One Migration Usado y en el segundo idioma de wc-ajax ahora hay 404.

(@botzev)

Hace 2 a帽os, 9 meses

Hola @gorem y @simonph Ambos dicen que el problema ocurre despu茅s de la migraci贸n. 驴Ha intentado guardar los enlaces permanentes en el panel de WordPress> Configuraci贸n> Enlaces permanentes? No he utilizado 芦WP All-in-One Migration禄 para los sitios de migraci贸n, pero hasta donde yo s茅, usar 芦Duplicator禄 despu茅s de que se complete la migraci贸n es un paso recomendado. Para m铆, esta parece ser la 煤nica explicaci贸n l贸gica.

(@gorem)

Hace 2 a帽os, 9 meses

Hola @botzev, la migraci贸n no parece estar provocando un error. Volver a guardar los enlaces permanentes no funciona.

De acuerdo con este tema y la recomendaci贸n @ christian70, he rebajado a Woocommerce 3.3.3 y puedo confirmar que los errores han desaparecido. Y creo que puedo estar de acuerdo con @icaleb en que la actualizaci贸n de Woocommerce 3.3.4 obviamente fue causada por un error:
* Fix - Use relative scheme for AJAX endpoint to avoid errors when using a mix of HTTP and HTTPS.

Woocommerce mutlilingual v4.2.9 es incompatible con Woocommerce 3.3.4.

La ayuda de desinstalaci贸n r谩pida es Woo 3.3.4, instalar Woo 3.3.3 y espere una actualizaci贸n de compatibilidad, hasta que su repositorio no se pueda usar, porque no puede pasar la verificaci贸n. ADVERTENCIA: Despu茅s de que Woo rebaje, algunos plugins (plugins de productos WooCommerce, facturas PDF de WooCommerce y albaranes) est谩n funcionando.

Esta respuesta fue modificada hace 2 a帽os, 9 meses por.

(@botzev)

Hace 2 a帽os, 9 meses

Gracias por los detalles. Por lo que tengo entendido, el problema surge cuando se mezclan http y https. Tal vez deber铆a verificar la configuraci贸n de su URL de inicio / URL en WordPress y configurarla en consecuencia en https o http y 驴resolver铆a un poco el problema?

Enviar茅 este ticket a nuestros desarrolladores para que lo vean.

(@gorem)

Hace 2 a帽os, 9 meses

Se parece a eso no es una combinaci贸n de http y https (Estoy en Woo 3.3.3 all铆). Las URL est谩n bien, lo revis茅 varias veces. Una cosa est谩 clara: se trata de la actualizaci贸n de Woo 3.3.4.

(@gorem)

Hace 2 a帽os, 9 meses

Gracias a @ankitgadertcampcom por una soluci贸n funcional https://wpml.org/forums/topic/subdomain-ajax-call-uses-http-instead-of-https/#post-1556422

(@botzev)

Hace 2 a帽os, 9 meses

Hola, solo una peque帽a actualizaci贸n m铆a. Hemos lanzado WPML 3.9.4 y deber铆a haber dos correcciones relacionadas con los problemas descritos aqu铆. Es posible que desee probarlo. Como procedimiento de actualizaci贸n normal y pr谩ctica recomendada, recuerde hacer una copia de seguridad antes de actualizar.

(@gorem)

Hace 2 a帽os, 8 meses

Hola,

s铆, puedo confirmar que los problemas se han ido, gracias.-)

(@botzev)

Hace 2 a帽os, 8 meses

Gracias por confirmar eso.

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *