Pregunta sobre WP Super Cache de Wordpress:

WordPress Editor 4.9.1 ya no puede guardar el código del tema

Un usuario preguntó 👇

Hola, después de actualizar WordPress 4.9.1 descubrí que no podía guardar archivos usando la sección Apariencia> Editor mientras WP Super Cache estaba activado y almacenado en caché.

Cuando intento guardar un cambio en un archivo de tema, aparece el error “No se puede comunicar con el sitio para verificar errores fatales, por lo que se restauró el cambio de PHP. Deberá cargar su archivo PHP de alguna otra manera, por ejemplo, usando SFTP. «

Esto se soluciona cuando desactivo el almacenamiento en caché en la pestaña «Fácil» o desactivo el plugin juntos. Considere solucionar este problema para que pueda dejar una marca mientras edita.

(@stodorovic)

Hace 3 años, 1 mes

Hola @andrewhewatt

Intenté reproducir esto, pero sin éxito. Debe habilitar el modo de depuración en WP – https://codex.wordpress.org/Debugging_in_WordPress. Este es probablemente un error fatal en PHP y debe encontrarlo en los registros de errores de PHP (o wp-content / debug. log si habilita WP_DEBUG). Si proporciona más detalles sobre un error, podemos averiguar cuál es el problema exacto.

Acerca de, Sasa

(@ cmartin2017)

hace 3 años

Tengo el mismo problema. Es lo mismo que el error del editor de temas 4.9, que solo se corrige en 4.9.1.

¿Está argumentando que puede ser incompatible con versiones anteriores de PHP?

¿Existe una versión específica de PHP que DEBE ejecutarse como 4.9.1? Tan pronto como hice una actualización de una versión anterior, encontré el error. Sé que probablemente necesite actualizar PHP, pero ¿cuál es exactamente la versión completa más antigua que se puede usar con 4.9.1?

(@andrewhewatt)

hace 3 años

@sasa gracias por la respuesta. Parece un problema remoto con este caso de WordPress, así que supongo que es un error como mencionaste o un problema de configuración.

(@prexblog)

Hace 2 años, 11 meses

Vaya a Plugins e instale un nuevo plugin llamado «Editor de temas“, Esto le permitirá editar y guardar cómodamente sus temas de código de archivo PHP sin usar el FTP como lo solicita la versión de WordPress. Además, puede «Editor de WP«Plugin para solucionar el problema.

Puedes ver el tutorial completo a través de https://prexblog.com/error-fixed-wordpress-inability-to-edit-and-save-theme-php-files/

(@accionesdeportivas)

Hace 2 años, 10 meses

agregar: define (‘WP_ALLOW_REPAIR’, verdadero); en wp-config.php vaya: /wp-admin/maint/repair.php remove: define (‘WP_ALLOW_REPAIR’, verdadero); de wp-config.php

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *