Pregunta sobre Arreglando WordPress de Wordpress:

WP 5.1 arroja un error fatal al llamar a la funci贸n Hook ()

Un usuario pregunt贸 馃憞

Estoy usando un tema personalizado no nativo de WP llamado News Station, de Flexithemes.

Estaci贸n de noticias con FlexiThemes

Es por eso que estoy publicando aqu铆, en lugar de en cualquier 芦p谩gina tem谩tica禄. WordPress no mantiene p谩ginas sobre temas creados por organizaciones distintas de WordPress. Tampoco esperar铆a un servicio as铆. De hecho, he dejado un mensaje con el apoyo de FlexiThemes, solo para cubrir esa base. Sin embargo, debe saber qu茅 est谩 sucediendo y c贸mo su actualizaci贸n rompi贸 mi tema, en caso de que rompa el tema personalizado de otra persona.

Cuando actualic茅 a WP 5.1, y despu茅s de actualizar cuidadosamente mi tema a su versi贸n actual, encontr茅 un error fatal en esta l铆nea en el archivo header.php de mi tema:

Gancho (‘meta’); ?>

El mensaje de error hablaba de llamar a la funci贸n hook () como nula, o algo as铆.

Afortunadamente, tuve disponible un plugin llamado Downgrade (隆horror!). Lo us茅 para establecer un objetivo permanente de WP 5.0.3. Eso es compatible.

Estoy usando PHP 5.6, la versi贸n estable actual. PHP 7.0 y 7.1 (la versi贸n 鈥淓dge鈥) est谩n disponibles para m铆.

驴Por qu茅 WP 5.1 rompe mi tema en esta l铆nea del archivo de encabezado?

Por favor, no sugiera que lo 芦comente禄. Cuando hago eso, nada se carga y ni siquiera recibo un mensaje de error que me diga qu茅 est谩 mal.

Tal vez soy una de las pocas personas en este foro que al menos puede recurrir a una versi贸n anterior del programa.

Agradecer铆a cualquier informaci贸n que tenga, especialmente cualquier cosa que pueda darle a FlexiThemes si pueden solucionarlo.

(@howdy_mcgee)

Hace 1 a帽o, 10 meses

Ese es un tema premium y debe buscarse en sus formas de soporte. Al pagar por la licencia del tema, al menos deber铆an proporcionar alg煤n tipo de soporte. El error que est谩 recibiendo no es un error tradicional de WordPress, sino un error espec铆fico del tema, por lo que los desarrolladores de ese tema lo sabr铆an mejor.

Dicho esto, si recibe un error fatal al llamar al m茅todo nulo, parece $theme no hay variable.

(@temlakos)

Hace 1 a帽o, 10 meses

El equipo de soporte de FlexiThemes volvi贸 a m铆 hace una hora. Se han puesto en contacto con su equipo central. Tambi茅n prometieron una r谩pida reescritura de su tema, que deber铆a estar disponible en cualquier momento. En pocas palabras: est谩n trabajando en ello. 芦Problema de compatibilidad con versiones anteriores禄, dijeron.

Tambi茅n confirmaron que el plugin Downgrade es un buen resultado por temor a problemas de compatibilidad adicionales.

驴Qu茅 versi贸n de PHP me recomiendan? Su Changelog me dice que ya est谩n en 芦Problemas de compatibilidad con PHP 7禄. Estoy usando PHP 5.6, mi anfitri贸n me dice que es la 煤ltima versi贸n estable. 驴Cierto? 驴O falso?

(@howdy_mcgee)

Hace 1 a帽o, 10 meses

Hoy es PHP 7+. Consulte la p谩gina de requisitos de WordPress para obtener m谩s informaci贸n:

Requirements

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada.