Pregunta sobre Arreglando WordPress de Wordpress:

wp-cli: seleccione la versi贸n de php

Un usuario pregunt贸 馃憞

wp-cli sobre ssh desde mi MacOS en la terminal.

5.5.38 es un servidor php

Cambie al directorio donde est谩 mi instalaci贸n de wp, la versi贸n de php es 7.2.22

Contigo en ese directorio:

wp cli info PHP binario: / opt / cpanel / ea-php55 / root / usr / bin / php Versi贸n de PHP: 5.5.38 php.ini utilizado: /opt/cpanel/ea-php55/root/etc/php.ini WP -CLI root dir: phar: //wp-cli.phar WP-CLI package dir: WP-CLI configuraci贸n global: WP-CLI configuraci贸n del proyecto: WP-CLI versi贸n: 0.24.1

y cualquier comando devuelve el mismo error

wp plugin list Su servidor ejecuta PHP versi贸n 5.5.38 pero WordPress 5.3.2 requiere al menos 5.6.20.

Busqu茅 de todas las formas que s茅 y no puedo encontrar la forma de convencerme de que use 7.2.22.

(@rrode)

Hace 10 meses

A menudo puede cambiar la versi贸n PHP predeterminada de su cPanel si su host tiene uno. Debe asegurarse de verificar el estado del sitio en WP admin en Herramientas> Estado del sitio para asegurarse de tener todos los m贸dulos y elementos correctos habilitados. Es posible que desee pedirle ayuda a su anfitri贸n si es demasiado dif铆cil de entender.

Si eso no funciona, es posible que deba actualizar la variable PATH o puede intentar configurar la variable WP_CLI_PHP:
https://wordpress.stackexchange.com/a/244170
https://make.wordpress.org/cli/handbook/installing/#using-a-custom-php-binary

(@spinhead)

Hace 10 meses

CPanel tiene una buena versi贸n de PHP, y est谩 bien si verifico la versi贸n de PHP en el terminal / ssh. El estado del sitio es bueno.

Si ritmo

exportar WP_CLI_PHP = / opt / php72 / bin

No obtengo ning煤n error, lo que significa que todo est谩 bien. Entonces el ritmo inmediatamente

lista de plugins de wp

y vuelve

Su servidor ejecuta PHP versi贸n 5.5.38 pero WordPress 5.3.2 requiere al menos 5.6.20.

Entonces, wp-cli parece estar ignorando la versi贸n de php en mi htaccess, la versi贸n que usa el sitio, e ignorando el comando express v7.2, y usando SOLO la versi贸n predeterminada de el servidor.

(@rrode)

Hace 10 meses

驴Qu茅 pasa con esto? https://www.knownhost.com/wiki/control-panels/directadmin/wrong-php-version-detected-using-multiple-php-versions

(@spinhead)

Hace 10 meses

-jailshell: / usr / bin / su: Permiso denegado

Mi esposo, el camarero, tiene una pregunta para su familia. Nunca ha usado wp-cli pero tiene recursos para verificar. Si necesito hacer algo, lo har谩 para evitar problemas de seguridad. Pero en este punto, ni siquiera estamos seguros de qu茅 podr铆a cambiar para que esto funcione.

Gracias por seguir ofreciendo sugerencias. Agradezco cualquier ayuda que pueda obtener.

(@tylerthedude)

Hace 10 meses

Hola,

Intente crear un nuevo archivo PHP y agregue el phpinfo(); aplicar al archivo. Sube esto al directorio ra铆z del servidor web y abre el archivo. 驴Qu茅 descripci贸n llam贸 esta funci贸n para la versi贸n PHP? Si es la versi贸n 5.5 de PHP, entonces este es el mismo archivo de configuraci贸n de PHP desde el que est谩 leyendo WP-CLI. Puede intentar eliminar y reinstalar el WP-CLI y ver si eso ayuda. Normalmente, en el directorio ra铆z de su servidor web encontrar谩 el directorio 芦.wp-cli禄. Elimine este directorio junto con wp-cli.phar del directorio bin. Despu茅s de hacer esto, reinstale el WP-CLI nuevamente y vea si lee la versi贸n correcta de PHP.

Puede ver aqu铆 que este archivo php.ini se est谩 cargando mediante WP-CLI:

php.ini used: /opt/cpanel/ea-php55/root/etc/php.ini

Lo extra帽o es que si cambi贸 la versi贸n de PHP en el cPanel, deber铆a eliminar este directorio y reemplazarlo con la versi贸n de PHP que tradujo. Debe ponerse en contacto con su anfitri贸n y preguntar por qu茅 este directorio se queda incluso despu茅s de haber cambiado las versiones de PHP.

Saludos, Tyler

(@spinhead)

Hace 10 meses

Phpinfo () est谩 deshabilitado en el servidor y con jailedshell no tengo acceso fuera de mi directorio de alojamiento, ni puedo instalar nada en el servidor.

Confirmar茅 con mi hombre acerca de los archivos php para la versi贸n anterior. Buena pregunta.

Gracias.

(@rrode)

Hace 10 meses

Parece que es posible que desee considerar un nuevo anfitri贸n. Personalmente, me gusta FastComet y he incorporado wp-cli desde el principio. Su apoyo tambi茅n suele ser muy bueno.

(@spinhead)

Hace 10 meses

驴Nuevo anfitri贸n porque tienen estricta seguridad? No lo creo. He estado con ellos durante m谩s de una d茅cada y he recibido el mejor servicio al cliente, no solo de cualquier empresa de hosting, sino de cualquier relaci贸n comercial en mi vida.

Pero otras sugerencias t茅cnicas son bienvenidas 馃檪

(@spinhead)

Hace 9 meses, 4 semanas

El anfitri贸n cambi贸 la ruta de mi cuenta a php y resolvi贸 este problema. Estoy averiguando qu茅 deber铆a ser capaz de hacer (error del usuario) o algo que ellos tuvieron que arreglar (configuraci贸n incorrecta).

驴Solucion贸 tu problema??

0 / 0

Deja una respuesta 0

Tu direcci贸n de correo electr贸nico no ser谩 publicada. Los campos obligatorios est谩n marcados con *