Pregunta sobre Pods Beaver Themer Add-On de Wordpress:

[wpbb post:pods_display] Ayuda HTML

Un usuario preguntó 👇

Estoy usando WordPress 4.8.1, BB Alpha 2.0 v5, Beaver Themer v1.0.2.1, Pods v2.7.0-rc-1 y Pods Beaver Theme Plugin v1.1.1. No puedo mostrar un enlace correctamente usando dos campos de Pods, el campo «collection_url» «Sitio web» y el campo «collection_art» «Relación».

Estoy usando el módulo BB HTML: <a href="pods_display field='collection_url']">[wpbb post:pods_display field='collection_art']</a>

Aquí hay una imagen de cómo se muestra: https://www.dropbox.com/s/icfk93ll0q0vzy7/Screenshot%20of%20Safari%20%289-8-17%2C%2010-43-16%20AM%29.png?dl=0

La conexión funciona, pero no se espera la visualización. ¿Qué estoy haciendo con HTML HREF?

Gracias. Doug

Este tema fue modificado hace 3 años, 4 meses por.

(@jimtrue)

Hace 3 años, 4 meses

@riderworks Actualmente solo podemos admitir las versiones de producción actuales de Beaver Builder, no Alphas o Betas. No podemos y no admitimos problemas con Alpha / Beta porque aún no se está produciendo para sitios en vivo.

Ya tenemos una edición de trabajo (pero que requiere mucha información aún no disponible de los desarrolladores de BB ya que están en Alpha) de nuestro Github aquí:
https://github.com/pods-framework/pods-beaver-builder-themer-add-on/issues/41

(@riderworks)

Hace 3 años, 4 meses

Hola Jim,

Acabo de devolver el plugin BB en la versión actual v1.10.8.1 y el problema sigue siendo el mismo.

(@quasel)

Hace 3 años, 4 meses

Tu código se ve raro

cada llamada a las vainas debería verse así
[wpbb post:pods_display field='collection_art']

pero
<a href="pods_display field='collection_url']">
debería verse así:
<a href="[wpbb post:pods_display field='collection_url']">

¿Cómo los creaste? manualmente o utilizando la opción de envío de enlace de campo? alternativ, puede usar la sintaxis de etiquetas mágicas de pods en la mayoría de los casos, p.

[pods]<a href="{@collection_url}">{@collection_art}</a>[/pods]

pero si collection_art es un campo de relación, es posible que desee especificar qué dominio de pod relacionado se muestra 😉 como collection_art.post_title

(@riderworks)

Hace 3 años, 4 meses

Hola Bernhard,

No estoy seguro de cuál es el «[” bracket was missing from my code. It’s shows in the HMTL module

<a href="[pods_display field='collection_url']">[wpbb post:pods_display field='collection_art']

También probé la sintaxis de la etiqueta mágica PODS y eso tampoco funciona. Dado que ‘collection_art’ es un campo de relación, lo cambié a ‘collection_art.post_title’. Pero eso tampoco funcionó.

Construiré esto con el apoyo de Beaver Builder.

Gracias. Doug

Esta respuesta fue modificada hace 3 años, 4 meses por.

(@quasel)

Hace 3 años, 4 meses

Tu código sigue siendo incorrecto…. sube más cerca, le falta la cuerda wpbb post:

un enlace al sitio siempre ayuda también; con una solución más rápida, puede estar en nuestro Slack https://pods.io/chat además

Bernhard

Esta respuesta fue modificada hace 3 años, 4 meses por.

(@riderworks)

Hace 3 años, 4 meses

Lo siento, me resulta difícil lidiar con la etiqueta de código. Este es el código que se está utilizando.
<a href="[wpbb post:pods_display field='collection_url']">[wpbb post:pods_display field='collection_art.post_title']</a>
Este es un sitio de prueba. He hecho una lista blanca de la publicación donde se puede ver la pantalla. Estoy usando Beaver Themer. https://beartproject.staging.wpengine.com/art/metamorphosis/

Esta respuesta fue modificada hace 3 años, 4 meses por.

(@quasel)

Hace 3 años, 4 meses

Parece que ha mirado el código fuente del sitio: «¿Salida como enlace?» en admin -> editar pod -> Opciones de campo adicionales

como resultado, la primera parte se emite como un enlace y el código cambia a

<a href="<a href="https://beartproject.staging.wpengine.com/collection/high-school-2015/">https://beartproject.staging.wpengine.com/collection/high-school-2015/</a>">High School 2015</a></div>

algo que no puede funcionar debido a una sintaxis incorrecta.

(@riderworks)

Hace 3 años, 4 meses

Hola Bernhard, muchas gracias. Eliminé el «Resultado como enlace» para el área del sitio web y ahora está funcionando.

Esta respuesta fue modificada hace 3 años, 4 meses por.

(@quasel)

Hace 3 años, 4 meses

¡De nada! La mejor manera de agradecer es dejar una reseña de 5 estrellas en https://wordpress.org/support/plugin/pods-beaver-builder-themer-add-on/reviews/#new-post * y * (si se siente generoso) Sea un amigo con un Pod en https://pods.io/friends-of-pods/

¡Me alegra poder resolver tu problema!

¿Solucionó tu problema??

0 / 0

Deja una respuesta 0

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *